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APPENDIX B. PROJECTWISE SEARCH FUNCTIONALITY  

The ProjectWise system includes search functions that allow users to filter documents in folders 
based on contextual keywords or document associated Attributes. The document associated 
Attributes are especially useful for users needing to collect and identify documents meeting 
specific parameters. Examples of such cases are outlined below.  

Search Examples: 

• Compile a list of all documents with the term “LR_SF” in the File Name, Document Type, 
or Description. 

• Identifying the total number of Critical Findings between two dates. 

• Compile a list of all Maintenance Manuals in the Bridge File by searching for a Document 
Type of “Proc_Maintenance.”  

B1 Building a Search Form 

To perform a customized ProjectWise search, users should follow the steps outlined below: 

 
Figure B1.1 Steps to perform a customized ProjectWise search using the Search Builder. 

*Note: Search parameters can include the type of document being searched, the defined Attribute 
View, or specific Attributes being searched.  

The steps are described in detail with an example search to identify all documents with the 
keyword “LR_SF” in the Document Type. 

 

 

 

 

 

 

 

Step 1. 
Navigate to the 

folder where 
the search is 

being 
performed.

Step 2. 
Use the Search 

Definition Dialog 
to open the 

Search Builder.

Step 3. 
Use the Define 
Search window 

to specify search 
parameters and 

Run search.*

Step 4. 
Save the Search 
for access from 

the Personal 
Search list.

Step 5. 
Run the Search 
by selecting it 

from the 
Personal Search 

list.
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Figure B1.2. Menu when right-clicking folder. Select the “Advanced Search” option. 

 

 

 
Figure B1.3. Search Definition Dialog box. Select the "Search Builder". 

 

 

Step 1 (Figure B1.2) 

1. Access the Advanced Search Wizard by navigating to the “Bridge Data” folder. (Or 
any desired search folder such as a County or other subfolder.) 

2. Right-click and select the “Advanced Search…” option.  

Step 2 (Figure B1.3) 

From the “Select Search Definition Dialog” window, select the “Search Builder” icon and click 
“OK”.  
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“Specify what are you looking 
for and the view for search 
results” section specifies what is 
being searched and which 
Environment is being used to 
display Attributes.  

“Find documents that match 
these criteria” section lists the 
search terms used in the search.  

The folder where the search will 
be performed is defined by 
default as the folder selected in 
Step 1. In this case, the folder is 
the ‘Bridge Data’ folder and all 
subfolders. 

“Define criteria” section details 
the types of Attributes available 
for searching. 

This section allows a user to 
save a search.  

Figure B1.4. Description of "Define Search" window sections. 

 

 

 

 

 

Step 3 (Figure B1.4) 

The search window shown in Figure B1.4 describes the four sections of the search window. 
For each search item, perform the following steps: 

1. Identify the “View” being used for the search data.  
2. Define the Criteria being searched by first identifying the Criterion Type, 

Property/Environment, and lastly the Attribute. 
3. Specify the Value being searched with the appropriate Relation search terms.  
4. Repeat Steps 2 and 3 for each Criteria being searched. 
5. Run search. 
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This example and guide focus on 
looking for Documents.  

 

The “View” option describes the 
Environments that can be used 
to view specific Attributes. For 
additional information on 
Views, see section B2Error! R
eference source not found.. 

 

For the example, use the 
“Maintenance_Bridge” View. 
(For custom views, see section 
B2.)  

Figure B1.5. Information for the types of Views. 

Custom views can be defined by the user. Refer to section B2 for instructions on creating a 
custom view. 

 

 

 

 

 

 

 

 

 

 

Step 3-1: Identify the “View” being used for the search data. (Figure B1.5) 

1. Select “Documents” in the “Look for:” section  
2. Define the Environment View. For this example, select “Maintenance_Bridge” as the 

View.  
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The “Define criteria” section 
details the types of Attributes 
available for searching. 

Criteria Type: This identifies the 
type of criteria being searched.  

For the example, select the 
“Environment Attribute” type. 

 

Figure B1.6. Criterion Type drop-down used to define criteria.  

 

 

 

 

 

 

 

Step 3-2: Define the Criteria being searched by first identifying the Criteria Type, 
Property/Environment, and lastly the Attribute. (Figure B1.6) 

To accurately identify documents in a search, users must specify the type of data to consider 
in a search. For most Bridge File searches, the type of data searched will be an Environment 
Attribute.  

1. From the Criterion Type drop-down, select “Environment Attribute.”  
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The “Environment” drop-down 
allows users to select an 
Environment where Attributes 
are defined.  

 

For the example, use the 
“Maintenance_Bridge” 
Environment to search based on 
Attributes defined when 
uploading files.  

Figure B1.7. Environment list drop-down used to specify where data is searched. 

Step 3-2: Define the Criteria being searched by first identifying the Criteria Type, 
Property/Environment, and lastly the Attribute. (Figure B1.7) 

When “Environment Attribute” is selected as a Criterion Type, the second search criteria 
drop-down will list all available Environments. Selecting the Environment facilitates the 
document Attributes being searched.  
 
For Bridge File documents, the applicable environments are: “Maintenance_Bridge” and 
“Maintenance_Bridge_QualityRecords.” 
 

2. From the “Environment” drop-down, select “Maintenance_Bridge.”  
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The Attribute drop-down 
populates based on the defined 
environment. Users will 
recognize several of the 
Attribute names from the 
wizard descriptions. 

 

It is useful to refer to the Folder 
Structure and Wizard 
Companion for specific 
Document Type Attributes.  

 

For the example, select 
“DOCUMENT TYPE:” from the 
drop-down. 

Figure B1.8. Attributes list drop-down with all available Attributes within the specified 
Environment.  

 

 

Step 3-2: Define the Criteria being searched by first identifying the Criteria Type, 
Property/Environment, and lastly the Attribute. (Figure B1.8) 

The selection of the “Maintenance_Bridge” Environment will populate the third drop-down 
of Attributes. These Attributes are related to data automatically and manually assigned from 
the Wizards detailed in preceding sections. Examples of automatically populated data 
include County, District, and Asset ID. Examples of data manually assigned with the Wizards 
includes Document Type, Document Date, and Freeform.  
 

3. From the Attributes drop-down, select the applicable Attribute for the search.  
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Figure B1.9. Search window when all Criteria is defined. 

 

Step 3-3: Specify the Value being searched with the appropriate Relation search terms. 
(Figure B1.9 & Figure B1.10) 

When the Search Criteria is specified, the “Value” search field (blue box shown below) is 
available for inputting specific search terms.  
 

1. Select the button (red box shown below) for the Criteria window. The search Value 
will populate in the “Value” box shown in Figure B1.9. 
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For the example, input “LR_SF*” in the Value 
field and select “LIKE” as the relation. 

Figure B1.10. Search window to input keywords. 

Step 3-3: Specify the Value being searched with the appropriate Relation search terms. 
(Figure B1.9 & Figure B1.10) 

A specified search “Value” is a keyword that will be used to parse available data. The 
keyword may be further categorized using the “Relation” drop-down. The “Relation” 
categories are Boolean search terms used to specify or broaden a search. For certain and 
specific searches, the equal sign is used to search the term. When searching for a similar 
Value, the “Like” Relation may be used. 
 
Wildcard term: An asterisk (*) may be used to include other similar Values. For example, 
when searching all LRSF’s, a user might search for “LR_SF*” to identify all Documents with a 
Document Type beginning with “LR_SF”. 
 

2. Enter the search term. 
3. Define the Relation.  
4. Select “OK.” 
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Figure B1.11. Search window when adding criteria. 

 

 

 

 

 

 

 

 

 

 

Step 3-3: Specify the Value being searched with the appropriate Relation search terms. 
(Figure B1.11) 

When a search term is specified, it will appear in the Value bar.  
 

5. Select the “Add Criteria” button to add it to the search list. It will then appear in the 
“Find documents that match these criteria” section.  

Step 3-4: Repeat Steps 3-2 and 3-3 for each Criteria being searched.  

Additional search criteria may be added by repeating Steps 3-2 and 3-3.  
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Figure B1.12. Search results when searching "LR_SF*" within the Document Type. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 3-5: Run Search. (Figure B1.11 & Figure B1.12) 

To run the search, select “Apply” or “OK” from Figure B1.11. 
 
Selecting “Apply” will run the search while keeping the Search Window open.  
Selecting “OK” will run the search and close the Search Window.  
 
Results will be shown as in Figure B1.12. 
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Figure B1.13. Window for saving a search. 

 

 

 

 

 

Step 4 (Figure B1.13) 

Users may save search forms to re-run them without repeating the steps to build the search 
form.  

1. To save a search, select the “Saved Search” button (red box) as shown in Figure B1.13. 
2. From the drop-down list, select the “Save As” option.  
3. In the “Save Search” window, input a custom name in the “Saved Search Name” box 

to save the search in the “Personal” list.  
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Figure B1.14. Saved Search list in Personal folder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 5 (Figure B1.14) 

A Saved Search can be found under the parent folder of Saved Searches > Personal. The Saved 
Search will be identified by the designated name.  

When the Search Name is selected, the search will run automatically and show the results.  
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B2 ProjectWise Environment, Views, and Customizations 

For ease of viewing Attributes, users may create custom Views that include the desired Attributes 
in the ProjectWise List View. The specified Attributes will appear as columns in the ProjectWise 
List View. 

 
Figure B2.1. Steps to create a customized View using Manage Views. 

 

 
 

Figure B2.2. Manage Views windows. 

 

Step 1. 
Navigate to the 
Manage Views 

window.

Step 2. 
Using the Create 

View window, 
specify the 

customized view 
name, and identify 

the source 
Environment 
Attributes.

Step 3. 
Define the 

Attributes of the 
custom View.

Step 4. 
Save the 

Attributes of the 
custom View.

Step 5. 
Access the custom 
View in the View 
drop-down list.

Step 1 (Figure B2.2) 

1. Navigate to the View drop-down and select “Manage Views…”  
2. From the Manage Views Window, select “New” 



  

 

South Carolina Department of Transportation | ProjectWise Bridge File Policy B-15 
 

 

 
Figure B2.3. Create View window. 

 

 

Step 2 (Figure B2.3) 

1. From the Create View Window, input a custom name for the View in the “View name” 
box. 

2. From the “Select an Environment” drop-down, select “Maintenance_Bridge.” This will 
populate the type of Attributes available for selection.  

Step 3 (Figure B2.4 through Figure B2.8) 

The Create View window shows two lists.  

The list on the left includes available types of Attributes for selection. Four types of Attributes 
can be defined based on the properties of a file, folder, Environment, or work area. The 
expanded lists are described in Figure B2.4 through Figure B2.8. 

The list on the right includes the selected Attributes for the custom view. 

From the list on the left select the desired types of Attributes by using the Right green arrow 
button to move them to the right. (Figure B2.8). 
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The “Basic Columns” list includes 
Attributes defined by the file 
metadata such as file names, 
size, author, and version. 

Figure B2.4. Basic Columns expanded list. 

 

The “Folder Columns” list 
includes Attributes defined by 
the parent folder of the file such 
as the folder name, creation 
date, and ID. 

Figure B2.5. Folder Columns expanded list. 
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The “Maintenance_Bridge” list 
includes Attributes defined 
during the file upload process. 

Figure B2.6. Maintenance_Bridge expanded list. 

 

The “Work Area Properties 
Columns” list includes Attributes 
defined by the work area such 
as the Bridge ID or County.  

This list is not commonly used 
for Attribute selection. 

Figure B2.7. Work Area Properties Columns expanded list. 
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Users may select a custom list of 
attributes for the view. 

Figure B2.8. Create View window for selecting Attributes and Manage Views Window to confirm 
view list. 

 

 

Step 4 (Figure B2.9) 

1. Once the list on the right is populated, select the “OK” button. 
2. The new custom view will now appear in the list of existing views. Select the “Close” 

button to exit the Manage Views window. 
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Figure B2.9. Create View window for selecting Attributes and Manage Views Window to confirm 
view list. 

 

 

 
Figure B2.10. ProjectWise Explorer Toolbar drop down options. 

Step 5 (Figure B2.10 & Figure B2.11) 

For ease of access to the various Views, users can turn on the Toolbar for Views by navigating 
to the View Menu > Toolbar > and selecting “View.” (Refer to Figure B2.10). 

Using the toolbar to view the ProjectWise List using the custom view, select it from the drop-
down list of views. This will automatically populate the data in the selected view as shown in 
Figure B2.11. 
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Figure B2.11. Custom View selection from View drop-down list. 
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B3 Exporting Search Results 

The following steps illustrate how to export a search result produced from a custom search and 
using a default or custom View to a text editor application file that can be used in a spreadsheet 
program like Excel. 

 

Figure B3.1 Steps for exporting a search. 

 

 

 

 

Figure B3.2. Selected files from a search. 

 

 

 

Step 1. 
Select the 

results.

Step 2. 
Copy the 

results to the 
clipboard.

Step 3. 
Save the 

results to a 
text file.

Step 4.
Import the 
results to 
excel or 

other 
software.

Step 1 (Figure B3.2) 

After a search has been completed, select all the results and right-click. 
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Figure B3.3. Menu when right clicking a search result. Select the “Clipboard Tab Separated” 
option. 
 

 

 

Figure B3.4. Paste the copied information to a text-editor application file such as Notepad.  

Step 2 (Figure B3.3) 

In the right-click context menu, navigate to and select the “Copy List To” > “Clipboard Tab 
Separated” option. 

Step 3 (Figure B3.4) 

Immediately after copying the search information, paste it to a text editor application file 
(such as Notepad). Save the file for access by other applications. 
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For assistance in importing a CSV file to Excel, refer to Microsoft support online such as Import 
data from a CSV, HTML, or text file. 

The following steps illustrate an example import process for Microsoft 365 Excel. 

1. In Excel, navigate to Data > From Text/CSV (Figure B3.5) 
2. Select CSV file from saved location and Import (Figure B3.6) 
3. In the Import window, select the “Load” option (Figure B3.7) 
4. The information from the file will be loaded to an Excel table (Figure B3.8) 

 

Figure B3.5. In Excel, navigate to Data ribbon and select “From Text/CSV.”  

 

Figure B3.6. Select the CSV file from the folder location. 

 

Step 4 

The saved text application file may be imported as a CSV to any spreadsheet program (such as 
Excel). 

https://support.microsoft.com/en-us/office/import-data-from-a-csv-html-or-text-file-b62efe49-4d5b-4429-b788-e1211b5e90f6#:~:text=On%20the%20File%20menu%2C%20click,and%20then%20click%20Get%20Data.
https://support.microsoft.com/en-us/office/import-data-from-a-csv-html-or-text-file-b62efe49-4d5b-4429-b788-e1211b5e90f6#:~:text=On%20the%20File%20menu%2C%20click,and%20then%20click%20Get%20Data.


  

 

South Carolina Department of Transportation | ProjectWise Bridge File Policy B-24 
 

 

Figure B3.7. In the pop-up window, select the “Load” button.  

 

Figure B3.8. The data from the CSV file loaded into a table.  
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