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1 
OBJECTIVES 

The objectives of this chapter are an introduction to GEOPAK, overview of file names, and discussion 
of User Preferences. 

INTRODUCTION 
GEOPAK is a comprehensive software package that covers every project phase from conceptualization 
to final quantities and construction stake-out.  The software works within the MicroStation graphic 
environment providing true interactive design.  For example, a horizontal alignment can be created 
graphically, it can be calculated with the coordinate geometry component of GEOPAK or some 
interactive combination of the two.  Dynamic on-screen design provides immediate interpretation of 
plan view geometrics for making design choices through visualization. 

Using GEOPAK will help ensure consistency and accuracy of design work and generate a significant 
time savings in the overall effort of producing construction plans. 

FILE NAMES 
GEOPAK uses and/or creates files during the design process.  Several of the more common files are 
detailed in the table below.  

job###.gpk This binary file is created when the user starts a coordinate geometry 
(COGO) session for the first time or created through Project Manager.  The 
file may be appended to during the design process. All coordinate geometry 
elements are stored in this file.  Multiple users can access this file at the 
same time, and only one file should be created for each project.  The "###" 
is the only variable in this filename.  It represents a job number (up to 3 
alphanumeric characters) unique to a project and is defined by the user upon 
creation. 

fname###.ioc 
Example: 
align999.ijd 

ASCII input file for loading data during a COGO session. "###" represents 
the job number and "oc" is the operator code (users initials). Filename 
characters are limited to 5 characters plus the 3 job number character 
designation as indicated with the example. 

fname###.ooc 
Example: 
align999.ojd 

ASCII output file created by GEOPAK during a COGO session. Variables 
are the same as defined above.  Filename characters are limited to 5 
characters plus the 3 job number character designation as indicated with the 
example. 

fname.inp  
Example: 
desxs.inp 

Any ASCII input file for running GEOPAK processes.  Name is user defined 
with a .INP extension.  

fname.dat 
 

A binary file that contains string and point information to be used for digital 
terrain model construction. 
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fname.tin A binary file containing triangular surfaces also known as the digital terrain 

model (DTM). 
Project-
name.prj 

Binary file resulting from the creation of a new project. 

 

ACCESSING GEOPAK 
GEOPAK is started upon entering a MicroStation File.  To verify that GEOPAK is active, scan the 
MicroStation menu bar where the Applications menu appears.  Simply select Applications > 
GEOPAK Road.  When each GEOPAK tool is selected, the corresponding dialog(s) open. 

To close a dialog, the following options are available, use the one that appears on the dialog: 

• Click the X in the upper right corner of the dialog. 
• Select the File > Exit option. 
• Or click Cancel on the dialog. 

Exiting the MicroStation file automatically closes all GEOPAK dialogs. 

USER PREFERENCES 
When a user begins GEOPAK for the first time or after GEOPAK has been reloaded, there are certain 
User Preferences the user needs to set.  The User Preferences dialog can be accessed from Applications 
> GEOPAK Road > User Preferences.   

 

Most of the settings in this dialog can be defined when a project is created within Project Manager (See 
Chapter 2). 

The Working Directory identifies where the data files for a particular project can be found.  If a user 
does not want to work within a specific project, the field may be left blank, and GEOPAK uses the 
directory wherein the open MicroStation file is located. 
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Lab Exercise:  User Preferences 

 
By clicking Feature Preferences, the Feature Preferences dialog opens. 

 

This defines the default file utilized for representation of coordinate geometry and survey elements 
when visualization is utilized during an active coordinate geometry session as well as the scale in 
which these elements will be displayed. 

By clicking COGO Preferences, the COGO Preferences dialog opens. 

 

The Job Directory field specifies the location of the GPK file.  Since multiple people can read and 
write the GPK file simultaneously, it is possible to have this file on a server or in a shared folder.  If 
any of the above directory fields are blank, they will default to the Working Directory set in the 
GEOPAK User preferences dialog. 

LAB EXERCISE:  USER PREFERENCES 

 Review of Steps to Define Design Preferences 

1. Open the MicroStation file C:\data\geo\S755\S755pp.dgn. 

2. Select the User Preferences tool (Applications > GEOPAK Road > User Preferences). 

 



Lab Exercise:  User Preferences 

 
3. Click Feature Preferences. 

 

4. Set the Plot Scale to 50. 

5. Toggle on Apply Best Match Feature. 

6. Click OK to close the Feature Preferences. 

7. Click OK to close the GEOPAK User Preferences. 

8. Exit MicroStation. 

 

 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 1-4 



Processing Survey Data 
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2 
CHAPTER OBJECTIVES 

In this chapter, you will learn about: 

• creating a survey dataset 

• importing survey data to the GPK file 

• visualizing survey data to a DGN file 

• creating a DTM from survey data 

INTRODUCTION 
GEOPAK Survey accepts raw survey data (horizontal angles, slope distances, vertical angles, etc.) as 
well as ASCII data already processed into coordinates and performs the following functions: 

• Data Reduction of raw survey data (not needed for ASCII data).  This software performs a 
Network Least Squares Adjustment with the ability to reduce the points to a user defined State 
Plane Grid. In addition, to network least squares reduction, GEOPAK Survey also supports no 
adjustment, compass rule and transit rule adjustments. 

• Stores the survey points and chains into the GEOPAK Coordinate Geometry database (.GPK file) 

• Draws MicroStation graphics of the survey based on the Survey Manager Database (.SMD file) of 
features. Lines, circular arcs and curve strings are drawn for particular combinations of point and 
curve geometry features to form the desired geometry of the survey. 

• Survey chains can optionally be stored as GEOPAK coordinate geometry chains (alignments). 

• Creates a Digital Terrain Model, and optionally the DAT file for GEOPAK (DTM) software. 
Surveyed chains can be represented as break lines that are adjusted into chord segments around 
curves. Inclusion of various survey shots into the DTM model can be dictated through specifying 
which features are to be included/excluded. 

• Surveyed chains and points can be interactively edited into the MicroStation file. 

 

ACCESSING 
GEOPAK Survey is accessed by selecting Applications > GEOPAK Survey > 
Survey from the MicroStation pull down menu. 
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ASCII Survey Data  Workflow 

 
Survey has the same set of tools or pull-downs for 2D versus 3D MicroStation design files.  GEOPAK  
monitors the file type and displays an Information dialog if a tool is activated in the wrong 
environment.  When an attempt is made to invoke the 3D Tools icon within a 2D file, the Information 
dialog is displayed.  The tool frame remains and reopens automatically even if you exit MicroStation, 
then re-enter later. 

ASCII SURVEY DATA  WORKFLOW 
SCDOT users will be processing ASCII survey data files supplied by surveyors in the field.  Below is a 
typical workflow for processing those files. 

• Create a new GEOPAK project (.PRJ file) by selecting Project > New from the Survey menu. 

• Create a new dataset by selecting Dataset > New from the Survey menu.  This includes simply 
naming the dataset and selecting the ASCII file(s) to process. 

• Set the columns and linking codes, then process the survey data, import the data to the GPK file 
and visualize it in the drawing with one click. 

• Visually review DGN file results. 

• Create the DTM by selecting DTM > Build DTM > From Survey Data from the Survey menu. 

• Close GEOPAK Survey. 

CREATING A PROJECT 
To create a Project, access the Project pulldown and 
select New. 

This dialog allows the user to provide a logical name for 
the project in addition to the coordinate geometry 
database to be used and a verbose description of the 
project. 

 

PROJECT PREFERENCES 
There are several preference settings that contribute to management of Projects.  These are found under 
the Project > Preferences pulldown as discussed in the previous chapter. 

The .prj file is stored in the directory shown in the Directory path at the top of the Project dialog box. 

The Project Name can be any number of alphanumeric characters.  The Directory specifies the location 
of the project data files and may be manually entered.  In lieu of typing, the Select button may be 
clicked and the appropriate directory selected.  

The next field is for keying in the COGO Job Number or the Select button may be clicked and the 
appropriate COGO job number selected. 
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Project Users Dialog 

 

 

PROJECT USERS DIALOG 
Once a project is created the Project Users dialog can be accessed from the Project > Users pulldown 
and the following dialog opens. 

 

This dialog has three sections: Project Users, User Info and Description.  The Project Users list 
displays a list of users that have been created to work with any project that resides in the current 
projects home directory.  The names shown in Project Users will be the user id’s of the people working 
on that project as specified in the Start Job dialog.  Within the User Info group box, the Full Name 
field further identifies the user, and displays the full name of the user that is currently selected.  The 
OP Code field displays the GEOPAK Operator Code of the currently selected user.  The GEOPAK 
Operator Code is used for all coordinate geometry operations during this session.  The Operator Code, 
along with the Job Number will be utilized whenever an input or output file is created by the software.  
The Operator Code should be the user’s initials.  The Description field displays the description of the 
currently selected user. 
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Lab Exercise:  Create a GEOPAK Survey Project 

 
Five tools are supported on the Project Users pulldown.  

New The New pull down menu option creates new users.  This option will create users only for the selected 
project. 

Edit Enables the user to change any of the parameters of the currently selected user.  (Note: The User cannot be 
changed.)  This changes the user information for the current project only. 

Delete Deletes the highlighted user. 

Password Creates or modifies a password for the selected user.  If the selected user already has a password, the user 
will be prompted to enter the current password before continuing. 

Exit Closes the User Dialog and returns back to the Project Manager dialog. 

LAB EXERCISE:  CREATE A GEOPAK SURVEY PROJECT 

 Survey Project Creation 

1. Open MicroStation file c:\data\geo\SC755\s755pp.dgn. 

2. Select Applications > GEOPAK Survey > Survey. 

3. Select Project > New from the Survey menu. 

4. Set the Name to SC755 and the Job Number to 755. 

5. Click OK to create the project. 

 

6. Select Project>Users from the Survey menu. 

 

7. Select Users > New from the Project Users dialog.  Populate with your information. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 2-5 

Lab Exercise:  Create a GEOPAK Survey Project 

 

 

8. Click OK to add yourself as a user on the project. 

9. Click No when prompted to define a password. 

 

 

10. Highlight your name in the list and click OK to set yourself as the active user on the project. 

11. Select Project>Preferences from the Survey menu. 

12. Select the Dataset tab, then the Linking Codes category. 

13. Enable the Linking Code is After Feature toggle. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 2-6 

Processing ASCII XYZ Data 

 

 

14. Select the Visualization tab, Mapping category. 

15. Enable the toggles for Name/Number and Comment. 

 

16. Click OK to accept this change. 

PROCESSING ASCII XYZ DATA 
The GEOPAK Survey Manager supports most any ASCII file containing reduced survey data or even 
just XYZ data. DTM input files can be derived from a file containing XYZ data with no point codes. 
Other features include embedded Linking Codes and Feature Codes, linking together shots based upon 
defined chains, comments and support for the situation where the user does not have a "continuation" 
linking code for each shot but wants these shots connected. These ASCII files need not conform to any 
particular structure or format other than a requirement that each point entry be restricted to a single 
row. The ASCII file should not contain more than one point per row. Similarly, multiple rows should 
not be required to define a single point code. 
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Within the row containing point code data, virtually no restrictions are placed on the arrangement and 
separation of survey data. Individual data items (point code, x-coordinate, y-coordinate, z-coordinate, 
point number) can be arranged in either free form or column formats. In addition, extraneous 
information may be present in the row and ignored by GEOPAK. Data items in the free form format 
can be separated by spaces, commas, dashes, etc. 

 

LAB EXERCISE:  PROCESSING ASCII DATA 

 Processing ASCII Data – Control Dataset 

For this Dataset, we will process 3 ASCII files that has already been reduced to coordinates from raw 
angle/distance data. 

1. Select the Dataset > New tool from the Survey menu.  Key in a name of control. 

 

2. Change the Data Source to ASCII Files and select XYZ. To Coordinates as shown above. 
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Lab Exercise:  Processing ASCII Data 

 
3. Click the Dataset Add Source File to List icon and select the ASCII file 

C:\Data\Geo|SC755\4236175_control.inp. 

4. Click OK. 

5. Set the Delimiter to Comma and the Comment Delimiter to ;. 

6. Highlight the first line in the display box. 

 

7. Notice how the combo buttons in the bottom of the window now have a corresponding field 
shown above it. Set each button for the appropriate value for that column.   

 

8. Click Linking Code and set the appropriate linking codes as shown below. 
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Lab Exercise:  Processing ASCII Data 

 

 

9. Toggle ON Process LcodePcode same as raw data in the lower left corner of the dialog. 

This will allow the chain name to be selected from the PCODE field, but increment the chain 
names so as not to overwrite a chain with the same name.  

10. Enable the Import after Process toggle. 

This instructs the software to import the points to the GPK file after processing.  By default, 
the points and chains will be visualized in the drawing immediately after importing them to 
the GPK file. 

11. Click Process in the dialog.  This will process, import and visualize the survey data. 

12. Fit the MicroStation view to see the resulting graphics. 

13. Close the XYZ to Coordinates dialog. 

 

 Process ASCII Data – Topo Dataset 

1. Select the Dataset > New tool.  Key in a name of topo. 

 

2. Remove the control file from the Files to Use list if present. 

3. Click the Dataset Add Source File to List icon and select the ASCII file 
C:\Data\Geo|SC755\4236175_topo.inp. 

4. Click OK. 
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Lab Exercise:  Processing ASCII Data 

 
5. Highlight the first line in the display box. Scroll down to select a line with a linking code of + 

or -. 

 

6. The Linking Code should still be set from the previous dataset. 

 

7. Click Process in the dialog.  This will process, import and visualize the survey data. 

8. Fit the MicroStation view to see the resulting graphics. 

9. Close the XYZ to Coordinates dialog. 

 Process ASCII Data – DTM Dataset 

1. Select the Dataset > New tool.  Key in a name of dtm. 
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Lab Exercise:  Processing ASCII Data 

 

 

2. Remove the control file from the Files to Use list if present. 

3. Click the Dataset Add Source File to List icon and select the ASCII file 
C:\Data\Geo|SC755\4236175_dtm.inp. 

4. Click OK. 

5. Highlight the first line in the display box. Scroll down to select a line with a linking code of + 
or -. 

 

6. The Linking Code should still be set from the previous dataset. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 2-12 

Digital Terrain Model From Survey 

 

 

7. Click Process in the dialog.  This will process, import and visualize the survey data. 

8. Fit the MicroStation view to see the resulting graphics. 

9. Close the XYZ to Coordinates dialog. 

 

DIGITAL TERRAIN MODEL FROM SURVEY 
A Digital Terrain Model (DTM) represents the topography of a project in the form of a triangulated 
network.  The DTM can be drawn in a 2D or 3D file, and then rotated to see the existing surface of the 
project area.  Digital Terrain Models can be generated from various sources including MicroStation 
elements, survey data, photogrammetry data, GEOPAK cross sections, and geometry data. 

Triangulation is a mathematical process applied to stored elevations points and stored elevations along 
DTM break lines to create surfaces.  The result of triangulation is the creation of a TIN file from which 
existing ground profiles and existing ground cross sections can be generated. 

ACCESSING 
Clicking the Build DTM > From Survey Data from the DTM option on the Main Survey Menu Bar 
opens the Build GEOPAK DTM dialog.  Various DTM tools can be accessed from the tool box for 
analyzing the DTM.  Before using the tools in the tool box, the data must first be triangulated to create 
a TIN file. 
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Digital Terrain Model From Survey 

 

 

FILE PARAMETERS  
Two user-defined stroking values need to be defined before data can be triangulated to create a DTM.  
Stroking is the process of automatically adding shots to the DTM Input file by interpolating new shots 
from the linear and curved sections of the data.  

Curve Stroke Tolerance The maximum distance between the arc and the chord used to approximate the arc in the DTM.  
Stroking only applies to breaks and contours. 

Minimum Linear 
Distance 

If a linear segment is greater than the Minimum Linear Distance, points are interpolated and 
added to the segment such that the distance between the points in not greater than the Minimum 
Linear Distance. 

Typically the DTM inclusion is determined from the SMD, however in some cases it may be desirable 
to determine the inclusion from the point/chain DTM attribute field. 

Consider a fence feature in the SMD as a “do not include.”  Suppose that one particular fence in the 
dataset was also a top of bank.  Chain edit could be used to change the DTM attribute to “include as 
break” and then the DTM built using the DTM attribute field to determine inclusion. 
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Load DTM Features 

 
The data file format is optional for processing Survey data.  However, this option can be used to 
generate an ASCII file with X, Y, Z data along with the feature code. 

File Type  Format of the new file.  Either format produces the same results.  The difference between the 
two is ASCII files can be viewed and edited with a text editor while Binary files process faster.  
For ASCII files, the number of decimal places can be chosen. 

File Open Indicates if you are creating a new file or appending data to an existing file. 

Create DAT File Toggled ON if it is desired to create this file. 

Write Comments in Data file Also toggled ON if desired. 

DTM Data File This is the name of the desired ASCII output. 

The TIN File parameters allow for the input of a TIN file to be created and also a maximum triangle 
length applied to the external triangles of the tin. 

The file extension TIN represents a triangulated irregular network and stores the triangulated model in 
binary format.  If the extension is not specified, GEOPAK automatically adds TIN.   The file can also 
be selected via the Files button.  If the full path is not given, GEOPAK utilizes the working directory. 

This dialog also displays the previously discussed Set Search button for selecting Datasets to be 
processed.  Once all of the desired Datasets have been selected, click Process to create the TIN file. 

LOAD DTM FEATURES 
Load is the process by which we can visualize the DTM data, TIN model, and contours.  Select the 
Load DTM Features tool from the DTM pulldown on the Main Survey Menu Bar.   

 

The user can choose to load the DTM data (.dat), the TIN file (TIN), or the Lattice file (.lat).  Each of 
these files can be loaded for the model extents, within a fence, or within a window.  

Toggle on Display Only enables the user to view the elements without writing them to the 
MicroStation file.  Conversely, toggle off writes the viewed elements as MicroStation elements.  If 
Display Only is on, updating your active screen clears the display of these elements.  When Display 
Only is off, the elements can be placed as a graphic group. 
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Analysis Tools 

 

 

The user can set what data to visualize, the symbology, and the contour interval (if Contours is turned 
on). 

 Turns on all items. 

 Turns off all items. 

 Turns on only the selected item. . Can also be done by enabling the toggle or double-
clicking on an item that is turned off. 

 Turns off only the selected item. Can also be done by disabling the toggle or double-
clicking on an item that is turned on. 

ANALYSIS TOOLS 
The Analysis tools allow the user to utilize the digital terrain model in many different analyses such as 
a profile, height, and drainage. 

Height Displays the x, y, and z coordinates and the slope of a given data point.  The 
contour at that elevation, the triangle the point lies within, and the direction of 
flow can be displayed. 

 

Profile Displays the profile of the digital terrain model between two points. 
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Analysis Tools 

 

 

 

Drainage Displays and analyzes drainage patterns within a TIN model.  Tools include 
drawing flow arrows, determining upstream and downstream traces, and finding 
high and low points. 
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TIN Statistics 

 
TIN STATISTICS 

The TIN statistical data can give the user some information as to the size of tin with regards to number 
of triangles, points, breaks and other features that may have been written to the file. 

 

For more information on these items, see the GEOPAK on-line help. 

LAB EXERCISE:  DIGITAL TERRAIN MODELING 

 Create DTM 

1. Open the MicroStation file C:\data\geo\SC755\s755pp.dgn. 

2.  Select the Project, User, and open the DTM dataset. 

3. Select the Build DTM Tool from Survey Data tool (Survey menu:  DTM > Build DTM > 
From Survey Data). 

This tool creates both the TIN file and the subsequent DAT file (if desired) to be utilized for 
reviewing and analyzing the DTM surface. 

4. Set the desired settings in the Build DTM dialog as shown below. 
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Lab Exercise:  Digital Terrain Modeling 

 

 

5. Click Process.  

 Load DTM Features 

1. Select the Load DTM Feature tool  (Survey menu: DTM > Load DTM Features).    

The tool allows for selection of desired features to display from the TIN file. 

2. Set the Load File option to TIN. 

3. Select the TIN file by clicking Files and selecting survey.tin. 

4. Activate the Triangles Displays to On by double clicking on the Triangles line.  

 

5. Enable the Display Only and Graphic Group toggles. 

6. Click Load to draw the triangles into the file. 
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Lab Exercise: Analysis Tools 

 
LAB EXERCISE: ANALYSIS TOOLS 

Several analysis tools are utilized in this lab exercise.  These include the profile tool, height tool, TIN 
Statistics, and drainage tools. 

 Height Tool 

1.  Select the Height Query tool (Survey menu:  DTM > Height Query).     

2. Set the dialog as shown below. 

 

3. Click Start. 

This shows the Flow Arrow, Contour and Elevation in different areas of the DTM.  

 Profile Tool 

1. Select the View Profiles tool (Survey menu:  DTM > View Profiles).   

Use the Selection tab to identify your DTM and the symbology for your profile. 
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Lab Exercise: Analysis Tools 

 
2. Click Files and navigate to SC755.tin. 

3. Double click on the symbology box to set the symbology for the profile. 

4. Click Add (top icon on right side of list box) to add the features to the list box. 

5. Click on the Profile tab. 

6. Click Place Element, then cut your actual profile by placing two data points (i.e. a line) or a 
series of data points (i.e. a line-string) across your DTM at any location. 

7. Use the Preferences tab to set a grid for your profile if desired. 

 

 

8. Return to the Selection Tab and notice there are additional icons on the dialog. 

If selected these will show graphically where each point along the profile was extracted, 
and/or draw the line that you placed to cut the profile, permanently into the graphic file. You 
can also create a COGO profile input file, and an optional ASCII file of the profile. 



Lab Exercise: Analysis Tools 

 
 TIN Statistics 

1. Select the TIN Statistics tool (Survey menu:  DTM > TIN Statistics).  

2. Click Files and navigate to SC755.tin. 

3. Click Process. 

 

4. Close the TIN Statistics dialog. 

5. Close GEOPAK Survey. 
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Project Manager 
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3 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• setting up a project using Project Manager. 
• how to utilize Project Manager as a workflow guide. 
• how to access GEOPAK dialogs from the Project Manager. 

INTRODUCTION 
Project Manager is a GEOPAK tool that associates a project with its respective coordinate geometry 
job number, users, working directories and project files.  Project Manager provides the user with an 
easy workflow system that keeps records of processes run throughout the design of a project. 

ACCESSING PROJECT MANAGER 
To access Project Manager, select Applications > 
GEOPAK Road > Project Manager or click the 
Project Manager icon.  The adjacent dialog 
appears. 
The current directory is displayed at the top of the 
dialog box.  This may be modified by traversing to 
a different directory in the Directories list box.  
Project files (.prj) are displayed in the projects list 
box.   
The remainder of the Project Manager dialog box 
displays information after a project has been 
selected from the Projects list box.  At the bottom 
of the dialog box are the OK and Cancel buttons.  
To exit Project Manager, click the Cancel button.  
To continue in the Project Manager process, click 
the OK button. 

 

PROJECT MANAGER MENU BAR 
There are three options on the Menu Bar: Projects, Directory and Admin.  Each of these choices has 
tools contained in the pull down. 

PROJECT TOOLS 
There are four options under the Projects pull down, New, Edit, Delete and Exit. 
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Project Manager Menu Bar 

 
The Windows motif also keeps track of the last few processes that have been executed, which may be 
recalled as needed by selecting the desired process.   

The New menu option is used to create a new project.  The .prj file is stored in the directory shown in 
the Directory path at the top of the Project Manager dialog box.   

 

The Project Name can be any number of alphanumeric characters.  The Working Directory specifies 
the location of the project data files and may be manually entered.  In lieu of typing, the Select button 
may be clicked and the appropriate directory selected.  

Note The Working Directory can be left blank if it is desired to have all of the MicroStation and 
GEOPAK files in a single directory. 

The next field is for keying in the COGO Job Number or the Select button may be clicked and the 
appropriate COGO job number selected. 

Next, Preferences should be clicked, invoking the Project Preferences dialog.  

 

The user may set the particular parameters for each project as well as the directories for the COGO job 
number, COGO input files and COGO output files.  By setting these parameters for each project, the 
user can open a design file in one directory and then open another design file in a different directory 
and still access the correct .GPK file and also save COGO input and output files to the proper 
directory.  The user simply chooses the project and all parameters are automatically set.  After all the 
information is entered, OK is clicked or if the user wishes to abort, Cancel may be clicked.   

Note If these fields are left blank, the project working directory is used. 
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Project Manager Menu Bar 

 
Shown below is a sample project that includes a project description, which may be keyed in at the 
bottom of the Create New Project dialog. 

 

The Edit menu option is used to change any settings associated with the currently selected project. 

The Delete menu option is used to delete any project that has been stored.  The user highlights the 
project in the Projects list box and selects Delete. 

The Exit menu option closes the Project Manager and writes the settings to a resource file. 

DIRECTORY TOOLS 
There are two options under the Directory pull down, Create New Directory and Current Working 
Directory. 

The Create New Directory option creates a new directory on the disk within the current directory.  If 
the Current Working Directory option is chosen, the directory path in Project Manager is changed to 
that directory.  

ADMINISTRATION TOOLS 
The Administration menu option is used to set a password on a project, if desired.  
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PROJECT USERS DIALOG 

Once a project is highlighted and OK is selected, the Project Users dialog appears. 

 

This dialog has three sections: Project Users, User Info and Description.  The Project Users list 
displays a list of users that have been created to work with any project that resides in the current 
projects home directory.  The names shown in Project Users will be the user id’s of the people working 
on that project as specified in the Start Job dialog.  Within the User Info group box, the Full Name 
field further identifies the user, and displays the full name of the user that is currently selected.  The 
OP Code field displays the GEOPAK Operator Code of the currently selected user.  The GEOPAK 
Operator Code is used for all coordinate geometry operations during this session.  The Operator Code, 
along with the Job Number will be utilized whenever a COGO input or output file is created by the 
software.  The Operator Code is typically the user’s initials.  The Description field displays the 
description of the currently selected user. 

Four tools are supported on the Project Users pulldown:  New, Edit, Delete and Exit.  
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ROAD PROJECT DIALOG 

After a minimum of one user has been defined, click OK in the lower left corner of the Project Users 
Dialog or double click on a Project User, which opens the Project Manager dialog. 

 

The top of the dialog displays the Working Directory, Working Alignment (if defined), User and 
GEOPAK Job Number.  In addition, a toggle for Working Alignment Influence Runs is also supported.  
The bottom portion of the dialog box displays the various processes supported during the design 
process.  The small square in the upper right corner will condense the dialog as depicted in the graphic 
below.  

 

ROAD PROJECT DIALOG MENU BAR 
There are two pull down menu bar options: File and Remember.  When the File option is selected, 
Close and Exit are supported.  

If the Close option is selected, the user is returned to the Applications dialog.  If Exit is selected the 
user is exited from the Project Manager. 

When the Remember option is selected, the user can instruct the software to remember the Project or 
User in subsequent sessions.  For example, if both toggles are activated, and the Project Manager is 
completely closed (all dialogs), the invocation of the Project Manager immediately invokes the Road 
Project dialog (flow chart) and utilizes the project name, user name, etc., which were active when the 
Remember toggles were selected.  
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If only the User toggle is activated, the user is returned to the Project dialog in later sessions.  If only 
the Project toggle is activated, the user is returned to the Project Users dialog in subsequent sessions.  
This option is particularly useful when numerous users are working on one project.  

When the Auto Sink option is enabled, the Road Project flow chart sinks behind all open views when 
any tool is selected from the flow chart. 

WORKING ALIGNMENT 
The concept of a working alignment enables the designer to organize a project and to access project 
information without continually typing the required information.  On a simple project, only one 
working alignment may be needed.  However, on a more complicated project, an unlimited number of 
working alignments may be defined.  With each working alignment, the designer can define associated 
data, i.e., name of cross section and plan view files, element symbology, etc.  The designer can easily 
change from one working alignment to another by highlighting the desired alignment listed in the 
Select dialog.  Once the working alignment is selected, all previously stored data is utilized in 
subsequent processing.  Three tools relating to working alignments are located at the top of the Road 
Project dialog: 

• Select 
• Define 
• Working Alignment Influence Runs (toggle on left side of dialog) 

 

SELECT OPTION 

 

When the Select button is clicked, the Select Working Alignment dialog appears as depicted to the 
right.  If no working alignments have been defined, UNTITLED appears in the Run List box.  If 
working alignments have been defined, they are listed with the last run time.  The description of the 
working alignment can be seen in the bottom of the dialog when each Name is highlighted.  To select a 
previously defined working alignment, highlight the run from the list, then click OK at the bottom of 
the dialog.  Double clicking on the Name also selects a previous working alignment for subsequent 
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processing.  Clicking Cancel closes the Select Run dialog without any File selection.  Several Run 
options are supported as detailed in the table below.   

 

New Create a new working alignment 
Copy Copy a run from an existing Project, a User in the same project or Run created by 

the current user. 

Modify Change the name of the existing working alignment. 

Delete Delete an existing working alignment. 

DEFINE OPTION 

Once a Run has been selected, clicking Define  opens the Working Alignment Definition dialog. 

 

The information that can be associated with a working alignment is listed in the left portion of the 
dialog box.  As each option is chosen, the right side of the dialog box will change to reflect the 
information needed as can be seen in the dialog box above after Plan View was selected.  

All information entered in these fields can be used in subsequent processes run from Project Manager.  
In the beginning of a project, much of this information will not be known, but as the user goes through 
the design process, it can be added to the working alignment definitions.  

For example, as soon as a chain has been stored in COGO, the user can enter that information in the 
Plan View fields on the right side of the dialog.  For a more complete explanation of each option 
shown, please see the On-Line Help. 
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PROJECT MANAGER PROCESS 

 

The primary Project Manager dialog is depicted above.  The advantage of utilizing the Project 
Manager rather than selecting functions directly from the Road menu is that pertinent information 
stored within the Project Manager is automatically displayed within the invoked dialog.  Therefore, job 
numbers, chain names, stationing, file names and data associated with the project do not have to be 
typed in each time a dialog is utilized.  However, if the user chooses to change the fields, they have 
that option. 

Many of the Project Manager processes function identically to their corresponding dialog’s invocation 
from the Road menu.  However, some of the procedures invoke the Select Run dialog prior to invoking 
the actual dialog.  The Select Run dialog enables the user to set up different options to use in 
alternative design choices or different typicals. 
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LAB EXERCISE:   PROJECT MANAGER 

 Create a GEOPAK Project 

1. Open the MicroStation file C:\data\geo\SC219\SC219pp.dgn. 

2. Select the Road Tools tool frame (Applications > GEOPAK Road > GEOPAK Road Tools). 

3. Select the Project Manager tool (Applications > GEOPAK Road > Project Manager).  

4. Ensure that the project directory is set to:    C:\data\geo\SC219\. 

 
5. Select Projects > New and create a new project. 

 

Project name: SC219 

Job Number: 839 

 

6. Click Preferences.  Ensure the dialog is populated as below. 

 

7. Click OK. 

After exiting the Preferences dialog, you will return to the Create New Project dialog.   

8. Click OK. 

9. Click OK. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 3-10 

Lab Exercise:   Project Manager 

 
An Alert message is displayed stating that Job 839 was not found in the Working Directory 
you have defined.   

 

10. Click Yes to automatically create this job file. 

The main Project Manager dialog is now displayed and the project has been created and ready 
to be accessed.   

 Create a User 

1. Highlight SC219.prj. 

To access the project, select the project by single clicking on name of the project in the dialog.  
The project is highlighted as shown in the dialog with all pertinent information displayed.  

 

2. Click OK. 

3. Select Users > New.  
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4. Enter the New User information. 

Name john 

Full Name John Doe 

OP Code 36 

Description Designer 

5. Click OK. When prompted to define a password for this user, click No. 

 

6. Double click the user. 

You will now see the Main Workflow dialog. 
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7. Use the Remember option to have Project Manager remember our Project and User. 

8. Select Options > Auto Sink to sink the Road flowchart each time a button is selected. 

 Define Working Alignment 

Before leaving this exercise, let’s go ahead and begin to set the stage for further design via the Project 
Manager by defining the Working Alignment.  To do this, we’ll need to use the Select and Define 
buttons on the Project Manager Workflow dialog.  The Project Manager dialog workflow dialog 
should still be active.  

1. Click Select.  

2. Select Run > New. 

3. Enter a Run Name of SC219. 

4. Enter a Description of SC219 Realignment. 

5. Click OK. 

 

6. Highlight the run then click OK. 

7. Click Define to access the Working Alignment Definition dialog. 

8. Highlight Plan View. 

9. Click File then select sc219pp.dgn. 
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10. Highlight DTM then complete the DTM definitions as shown below. 

 

11. Click OK. 

12. Exit MicroStation. 

 



Lab Exercise:   Project Manager 
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4 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about: 

• setting up and accessing the coordinate geometry database file. 
• becoming proficient in using GEOPAK Coordinate Geometry. 

INTRODUCTION 
The Coordinate Geometry database file (*.GPK file) is comprised of stored geometric elements such as 
points, lines, curves, spirals, chains, parcels and profiles.  When COGO calculations are completed, the 
results are stored in the binary database file, which is then utilized throughout the design process with 
many other applications. 

ACCESSING COGO 
When Coordinate Geometry is started, the Start-Up Dialog appears. 

 

Project Name Name displayed on reports.  This is an optional entry, with a maximum of 60 
alphanumeric characters.  If Project Manager is active, this field is populated 
automatically. 

Job Number Identifies coordinate geometry database file and is a required field. The job number is a 
maximum of three alphanumeric characters.  If Project Manager is active, this field 
populated automatically. This field is required. 

Operator Code Unique 2-character code which enables multiple users access to database file.  The user’s 
initials are suggested.  Note this field is not required for single user access, but highly 
recommended.  If Project Manager is active, this field is populated automatically. 

Subject Description of coordinate geometry work (could relate to the project) with a maximum of 
48 alphanumeric characters.   
This field is optional. 

After the dialog is populated and OK is clicked, the main coordinate geometry dialog is invoked. 
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COORDINATE GEOMETRY DIALOG 

 

The coordinate geometry dialog box is made up of three separate display areas: 

• Tool Bar consisting of drop down options and icons.  The display of specific icons is 
customizable. 

• COGO Key-in field enables manual entry of COGO commands.  The drop down button allows for 
a history of commands to be reviewed. 

• Output Display Window shows the results generated by the commands. 

FILE COMMANDS 

 

File 
Utility 

This option opens another dialog that contains group of file utilities that will be 
explained later. 

File 
Restore 

Loads an ASCII file of GEOPAK commands into the display window.  Note no 
processing occurs.  The file must be named j999ooc.inp, where 999 is the current job 
number and oc is the operator code. 
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Import  Imports horizontal and vertical alignments and points from ASCII Points, SDMS 

Alignments and Points, LandXML 1.0 Geometry, RDS, and VDOT PLT formats 
into the GEOPAK .gpk file. 

Export  Exports ASCII points, SDMS Points, SDMS Alignments, LandXML 1.0 Geometry, 
and Alignments and Profiles into formats for use in various data collectors.  

Exit Closes the COGO dialog box and ends the coordinate geometry session. A prompt to 
save the session appears. Yes saves the audit trail, No exits without saving, Cancel 
returns to the COGO session. Whether you pick Yes or No everything you did is still 
saved in the .gpk file. 

FILE UTILITY 
The File Utility option invokes the following dialog. 

 

Load When selected, a menu appears listing all saved input files. Highlight a file then 
click OK. The input lines from the highlighted file are now displayed in the display 
window for viewing, editing, or processing. 

Append This command is for input files only. A new input file is created by copying the 
contents of an existing input file to the end of the current input file.  The Save 
command must be used in order to store this new file. 

Catalog When selected, a menu appears listing all saved input files (under the current 
operator code) in the project directory.  This is for reference only no action is taken. 

Delete When selected, a menu appears listing all saved input files. Highlight a file then 
click the OK button to remove this file from your project directory.  Although the 
file is deleted, the elements stored as a result of processing the commands are not 
deleted. 

Output  Writes an ASCII file of the current display for reviewing and / or printing. 
(Fname999.ooc, where 999 is the current job number and oc is the operator code). 

Print Input 
File 

Sends your input file to the printer. 

Print Output 
File 

Sends your output file to the printer. 

Save Saves the current audit trail to a file. (Fname999.ioc, where 999 is the current job 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 4-4 

Coordinate Geometry Dialog 

 
number and oc is the operator code.). 

Allow 
Commands 
to be Added 

When this is toggled on, COGO commands are added to a previously loaded file. 

EDIT COMMANDS 

 

Clear Empties the memory of the current audit trail without saving and initializes the line 
numbers to begin a new sequence of commands.  Note this does not clear the display 
window. 

Delete Deletes input commands in the input buffer by line number (or range of line numbers) 
and re-sequences the line numbers for the remaining commands. 

Insert  Adds a command line to the current input buffer before a specified line number; 
subsequent command lines shift down and line numbering is automatically re-
sequenced. 

Modify  Changes a fragment in a command line. The modified command line is not processed 
until a Read command is performed. 

Read All Processes all lines in the audit trail. 
Type All Displays the contents of the audit trail. 
Line 
Range 

Opens the Line Range dialog where a range of lines can be entered that can either be 
read or displayed. 

Editor Opens the COGO Command Editor, which enables the user to edit the current input 
file. 

ELEMENT COMMANDS 
The mainstay of GEOPAK Coordinate Geometry are the various element commands.  Tools are 
supported for storing, stationing, adding additional data, deleting, etc.  GEOPAK supports a wide 
variety of elements:  points, curves, spirals, chains or alignments, parcels, and profiles.  Each element 
is detailed below. 
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ELEMENT > POINT 

 

One of the most utilized sets of COGO tools are the point commands, as detailed in the table below. 

Utility Opens the Point Utility dialog where the following options are available. 
Delete - Deletes a point number (or range of numbers) from the database file. 
Print - Displays the selected point numbers x, y, z coordinates, station value and 
other stored information in the display output window. 
Display - Visualizes the selected point numbers currently stored in the GPK file 
(Temporary Visualization or Permanent Visualization must be turned on). 

Cell Assigns a cell name to a previously stored point. 
Copy Copies points or a point range to a new point number or range within the same 

GEOPAK database file 
Elevation Assigns an elevation to a previously stored point 
Equate Stores a new point with the same values as a previously stored point 
Station Adds a station to a previously stored point. 
Store Stores a point by key-in coordinates or by selecting a location graphically.  A station, 

elevation, point code, cell, feature, or description can be optionally stored with the 
point. 
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Transfor-
mation 

Performs coordinate transformations based on user-defined control pairings 

Compare 
Points to 
TIN 

Utilizing a set of COGO points (with elevations) compares the COGO elevation to the 
TIN elevation and completes statistical analysis for "goodness of fit." 

Set 
Elevation 
from TIN 

Utilizing this command, GEOPAK adds or updates an elevation to a previously 
defined point, based on a TIN model. 
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ELEMENT > CURVE 

 

Utility Opens the Curve Utility dialog where the following options are available. 
Reverse - Reverses a previously stored curves direction.   
Delete - Deletes a curve (or range of curves) from the database file.   
Print - Displays the selected curves x, y, z coordinates, station value and other stored 
information in the display output window.   
Visualize - Visualizes the selected curves currently stored in the GPK file 
(Temporary Visualization or Permanent Visualization must be turned on). 

Copy Copies a specified curve to another curve name. 
Data Calculates the geometric parameters of a curve, displaying values for Delta, Degree, 

Tangent, Length and Radius. 

Segment Defines new curves by dividing a stored curve into segments. 
Station By identifying a curve and a control point on the curve (PC, PI, or PT), a station value 

may be assigned. 
Store Provides various options for defining and storing curves such as Store Curve By 

Tangents as shown below.  
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ELEMENT > SPIRAL 

 

Utility Opens the Spiral Utility dialog where the following options are available. 
Delete - Deletes a spiral (or range of spirals) from the database file.   
Print - Displays the selected spirals x, y, z coordinates, station value and other stored 
information in the display output window.   
Visualize - Visualizes the selected spirals currently stored in the GPK file 
(Temporary Visualization or Permanent Visualization must be turned on). 

Copy Copies a specified spiral to another spiral name. 
Store Provides various options for defining and storing spirals. 
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ELEMENT > CHAIN 

 

Utility Opens the Chain Utility dialog where the following options are available. 
Area - Calculates the area of a closed chain. 
Delete - Deletes a chain (or range of chains) from the database file.   
Print - Displays the name of each element in the selected chains. 
Describe - Displays the alignment data of each element in the selected chains. 
Visualize - Visualizes the selected spirals currently stored in the GPK file 
(Temporary Visualization or Permanent Visualization must be turned on). 

Layout Offset Project points onto a chain or compute offset distance and direction between two 
chains at each control point or at user defined intervals of a specified station range. 

Station Provides a method for stationing or re-stationing a chain. 
Station Equation  Provides a method for applying a station equation to a chain. 
Store Provides three options for storing a chain in the database file, From Elements, 

Store Offset Chain, and Store Transition Chain.  The Store Chain From 
Elements dialog is shown below.  (Chain name can be between 1-9 alphanumeric 
characters)  
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ELEMENT > PARCEL 

 

Utility Opens the Parcel Utility dialog where the following options are available. 
Delete - Deletes a parcel (or range of parcels) from the database file.   
Print - Displays the elements of composition, the area of tract stored, taken and 
remaining. 
Describe - Displays the elements of composition, the area of tract stored, taken and 
remaining and a point, bearing, distance description of the specified tract. 
Visualize - Visualizes the selected parcels currently stored in the GPK file (Temporary 
Visualization or Permanent Visualization must be turned on). 

Store Stores a parcel by adding points, curves and spirals. 
Subdivide Divides a parcel into individual lots. 
Editor Edits a parcel. 

PARCEL COMMANDS (MANUAL ENTRY) 

Several parcel commands are supported only by manual entry and have no associated dialogs. 

Store 
Taken 

Store the portion of a parcel taken by entering point and curve names in either a 
clockwise or counterclockwise direction. 

Store 
Easement  

Store easements by entering point and curve names in either a clockwise or 
counterclockwise direction. 

Own Parcel Stores the names of the owners associated with previously stored parcels.  
Make Legal  Creates a metes and bounds description and writes it to a user named text file. See 

also Legal Description Editor for the ability to create detailed and customizable legal 
descriptions. 
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ELEMENT > PROFILE 

 

The Profile commands (as displayed in the exploded view above) are detailed in the table below.  Note 
additional commands are supported as keyin only commands.   

Utility Opens the Profile Utility dialog where the following options are available. 
Delete - Deletes a profile (or range of profiles) from the database file.   
Print - Displays the data of the selected profile from the database file. 

Elevation Provides three options for reporting elevations along a selected profile, Station, Even 
Station, Incremental Stations. 

Offset Stores a new profile within a specified Station Range at a defined vertical offset from 
the original profile. 

Restation Creates a new profile with different stationing from a previously stored profile. 

VIEW COMMANDS 

 

Icons Enables the user to customize which icons appear in the tool bar. 
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Redefine Displays the Redefine box on the tool bar. 

Visualization Displays the visualization items on the tool bar. 
Format Displays the format items (i.e. number of decimals, station format, etc.) on 

the tool bar. 
COGO Key-in Displays the COGO Key-in box for entering commands in the dialog. 
Command Output Displays the Command Output Window in the dialog box, and controls 

options for the Command Output Window.  The Command output window 
can also be saved to a text file in lieu of using the File > Output command. 

Error Alert Enables the user to activate a beep and/or restore a minimized COGO dialog 
when an error occurs. 
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TOOLS COMMANDS 

 

Navigator Invokes the COGO Navigator. 

Inverse Calculates the distance and direction between points. 

Locate Stores a point or series of points not by specifying coordinates, but based on a 
previously stored point using several methods.  To locate a point by distance 
and bearing, use the Tools > Locate > Traverse as depicted in the dialog 
below. 
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Intersect Stores a point at the intersection of any two COGO elements. 
Best Fit  Calculates a best-fit chain through a set of points. 
Translation and 
Rotation  

Moves, rotates, and scales a data set. 

Map Check  Edits a parcel. 
Roadway 
Intersections 

Calculates data for the intersection of two COGO elements, usually chains. 

Cul-de-sacs  Calculates data for a cul-de-sac. 
Redraw 
Visualized 
Elements  

Re-syncs the visualized COGO elements in the MicroStation file with the 
coordinate geometry data. 

Clear Visualized 
Elements 
(Temporary)  

Removes all temporary visualized elements from the view. 

Clear Visualized 
Elements (All)  

Clears all temporary and permanent visualized elements from the 
MicroStation file. 
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USER PREFERENCES 

 

The User Preferences (as displayed in the exploded view above) are detailed in the table below. 

Dialog Allows access to COGO Preferences dialog box. 
Redefinition of 
Elements 

Toggles the Redefine option on/off.  If Redefine is on, COGO data can be 
redefined/overwritten. 

Visualization Enables the elements to be displayed in the MicroStation file permanently, 
temporarily, or not at all. 

Coordinate Display Toggles between displaying NE or XY coordinates. 
Angle Display Toggles between displaying Bearing or Azimuth. 
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COGO NAVIGATOR 

The COGO Navigator is a tool utilized to easily view and edit COGO data. Store, delete, edit, print 
elements, plus visualization and selection set commands are easily accessible via the Navigator.  The 
Navigator can be accessed by the pull down menu COGO > Tools > Navigator or by the Navigator 
icon.  The following dialog opens. 

 

From the Navigator, points, curves, spirals, chains, survey chains, parcels, and profiles  (all COGO 
elements contained in the coordinate geometry database file; *.gpk) can be added, deleted, modified, 
identified, visualized, printed, or selected. 

NAVIGATOR > SELECT TOOLS 
A variety of selection tools can be invoked via the Select pulldown, as depicted in the exploded view 
below. 

 

Select All Selects all data items of a certain type.  (i.e. all points) 
Invert 
Selection 

Selects all items not previously selected, and unselects all items previously 
selected. 

Clear 
Selection 

Unselects all items. 

Selection Set Allows the user to create a selection set that meets particular criteria.  Same as 
using the Selection Set icon 

Fit View 
(Selection Set) 

Fits the selected items to the active MicroStation window. 
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Show Selected 
Elements 
Only 

Only the items in the selection set are displayed in the MicroStation window. 

Show All 
Elements 

All items in database file are displayed in the MicroStation window. 

NAVIGATOR > TOOLS 
A variety of tools can be invoked via the Tools pulldown, as depicted in the exploded view below.  
Many can also be invoked via the shortcut icons displayed at the top of the Navigator. 

 
 

Add Element 

 

Enables the selected type of element to be stored.  When selected, the 
appropriate Store Element dialog is invoked. 

Delete Element 

 

Deletes the highlighted of element. 

Edit Element 

 

Invokes the appropriate Store Element dialog, populated with the 
associated data of the selected element for editing. 

Identify Element 

 

When clicked and a COGO element is graphically selected, the element is 
highlighted in the display field.  If the selected element is not the 
displayed element type (i.e., curve or point), the element type is also 
changed.   

Print/Describe Element

 

Displays the selected element’s data. 

Edit Element Feature Changes the feature code of the element. 
Visualize Element 

 

Displays the selected elements according to their feature code or default 
symbology. 

Unvisualize Element Removes display of  selected elements. 
Visualize All Displays all of the elements of a certain type, or all elements. 
Redraw Visualized Re-syncs the coordinate geometry data with the data displayed in the 
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Elements MicroStation file. 
Clear Visualized 
Elements (Temporary) 

Clears only temporary visualized elements from the view. 

Clear Visualized 
Elements (All) 

Clears all visualized elements from the MicroStation file. 

Settings Enables the user to define certain actions and behaviors of the Navigator. 
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LAB EXERCISE:   COORDINATE GEOMETRY 

 Accessing COGO 

1. Open the MicroStation file c:\data\geo\sc219\sc219pp.dgn. 

2. Access Project Manager. 

It should automatically access the Road workflow dialog since we “remembered” the options 
in Lab 2. 

3. Select the Coordinate Geometry tool from the Road Project dialog.  The dialog below 
should appear. 

 

This dialog is completely re-sizable, so you can position it where you’re most comfortable. 

 
 

 Import Survey Data to GPK File 

1. Set the visualization choice to Disable Visualization. 

2. Select File > Input File Restore from the Coordinate geometry window. 

3. Select Edit > Read All to process the file. 

4. Open the COGO Navigator to verify the points and survey chains are now stored in the GPK 
file.  (Tools>Navigator) 
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Lab Exercise:   Coordinate Geometry 

 

 

5. Select Edit > Clear to clear the COGO commands from the input file buffer. 

6. Select View > Command Output > Clear to empty the output window. 

Hint Instead of steps 5 and 6 above, you could close and re-open the COGO dialog for the same 
end result just as quickly. 
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 Store an Alignment 

In the next few steps, we’ll use Coordinate Geometry tools to store the alignment displayed below. 
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1. Select Temporary Visualization on the main COGO dialog. 

2. Select the Store Point tool (COGO:  Element > Point > Store).  

 
3. To store point 3100, enter the point number and coordinates as indicated in the dialog above. 

4. Activate the Auto Increment toggle. 

This will automatically increment the point number by 1 for subsequent Store Point 
commands. 

5. Click Store Point. 

This stores the point into the COGO database. 

6. Store Point 3101 using the coordinates shown below. 

 

7. Store Point 3102 using the coordinates shown below. 
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Lab Exercise:   Coordinate Geometry 

 

 

8. Store Point 3103 using the coordinates shown below. 

 

9. Store Point 3104 using the coordinates shown below. 

 

10. Store Point 3105 using the coordinates shown below. 
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Lab Exercise:   Coordinate Geometry 

 

 

11. Store Point 3106 using the coordinates shown below. 

 

12. Store Point 3107 using the coordinates shown below. 

 

13. Close the Store Point dialog. 
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 Store Curve Commands 

1. Access the Store Curve By Tangents dialog by pressing the Store Curve By Tangents icon 

 
or by selecting Element > Curve > Store > By Tangents from the COGO dialog.  The dialog 
below should appear. 

 
2. To store the curve SC219R-1, complete the dialog as shown below. 

 

3. Click Store Curve to store curve SC219R-1 into the COGO database. 

4. Store the remaining curves using the information provided on the alignment diagram and the 
images below.. 

Note Be careful to name each curve uniquely as the only the Store Point tools increment the 
element names automatically. 
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5. Dismiss the Store Curve By Tangents dialog by clicking the X in the upper right hand 
corner. 

 Store Chain Command 

Store the centerline chain SC219R according to the diagram on page 4-21. 

1. Access the Store Chain From Elements dialog by pressing the Store Chain From Elements 
icon 

 
or by selecting Element > Chain > Store > From Elements.  The dialog below should 
appear. 

 

2. Enter SC219R for the Chain Name. 

3. Set the option button to Begin Station and enter 87+25.49. 

4. Build the list of COGO elements which will become a part of the chain. 

You can fill in the elements comprising the chain by keyin or by graphically selecting the 
visualized elements in the design file. Ensure that the elements are added to the list in the 
order that you want them to be stored as a chain.  The dialog should appear as below. 
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5. Click Store Chain to store chain SC219R into the COGO database. 

6. Dismiss the Store Chain From Elements dialog by clicking the X in the upper right hand 
corner. 

 

 Describe Chain Command 

From the COGO dialog window, let’s preview the chain SC219R coordinate geometry. 

1. Access the COGO Navigator dialog by pressing the Navigator icon 

 
or by selecting Tools > Navigator.  The dialog below should appear. 

 

2. Set the Element option to Chain then highlight the chain SC219R. 
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3. Click the Print/Describe Element icon. 
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The chain geometry will be displayed in the main COGO window as below. 

 
4. Dismiss the Navigator dialog by clicking the X in the upper right hand corner. 
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 Create Input and Output Files 

In the following steps we will save an input trail of our commands and an output file with the 
computations of chain SC219R. 

1. Access the File Utility dialog by pressing the File Utility icon 

 
or by selecting File > File Utility.  The dialog below should appear. 

 
2. On the File Utility dialog, set the option button to Save. 

 
3. Enter “SC219” for the Name and “Chain SC219R” for the Subject then click Apply. The 

saved file will be called ‘SC219839.i36’ 
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4. To save an output file with the actual results of the computations, set the option button to 

Output on the File Utility dialog.   

 
5. Output File should be set to SC219.   

6. Toggle on “Redefine” on the main COGO dialog. 

7. Click Apply.  The saved file will be called ‘sc219839.o36’. 

8. Toggle off “Redefine” on the main COGO dialog. 

9. Dismiss the File Utility dialog by clicking the X in the upper right hand corner. 

 Working Alignment 

Now that we have our alignment, we have another piece of information for the Working Alignment 
definition.  

1. Access the Project Manager Road workflow dialog. 

2. Click Define. 

3. Highlight Plan View. 

4. Click Select and select chain SC219. 

 

5. Click OK. 

 



Lab Exercise:   Coordinate Geometry 

 
 Store Chain for Interstate 26 

 

1. Store points for the control points on the chain above.  Begin with point number 3111. 

2. Store curve I26 using the information provided above. 

3. Store chain I26 consisting of the one curve and two points. 

4. Save a COGO input file called I26. 
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5 
CHAPTER OBJECTIVES 

In this chapter, you will learn how to create and store horizontal chains using MicroStation elements. 

INTRODUCTION 
The Horizontal Layout Tools enable the user to create or modify horizontal geometry (using numerous 
tools) including placing spirals, curves, tapers, specified bearings and curves, complex ramp loops and 
connectors, and all to user-defined parameters. 

Note A session of COGO must be active. 

ACCESSING 
Clicking Horizontal Alignment from the Road Project: Sc219.prj dialog within Project Manager opens 
the tool frame shown below. 

 

When File > Preferences is selected, the Preferences dialog below appears and allows the user to set 
certain preferences. 
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Lines / Curves Tools 

 
The Design Tables option allows the user to set up Design Tables for Symmetrical 3 Centered Curves, 
Asymmetrical 3 Centered Curves, Symmetrical Taper Curves, Asymmetrical Taper Curves, and Spiral 
Curves.  These files are stores in an ASCII format. 

 

The Tools option allows the user to open the Main dialog or any of the dialogs needed do store a 
Horizontal Alignment. 

 

Values within the dialogs dynamically change simultaneously with dynamic graphic modifications. 

Note Spiral and compound curve commands do not support dynamic manipulation. 

 

LINES / CURVES TOOLS 

 

The Place Lines / Curves Commands are detailed in the table below. 

 
Store Line By 2 Points 
The store line by two points command requires two new points and a new line.  The 
command draws the line and the new points. 

 
Store Tangent Line 
The Store Tangent Line tool stores a line and its two endpoints in the coordinate 
geometry database. 

 
Store Curve By 3 Points 
The Store Circular Curve by Three Points tool stores a circular curve (using chord 
definition). 

 
Store Curve By Center 
This tool enables the user to store a circular curve by defining the center point, radius, 
and sweep angle. 
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Curve Combinations Tools 

 

 
Store Tangent Curve Unconstrained 
The Store an Unconstrained Tangent Curve tool places a curve through a specified 
point tangent to the specified curve or line. 

 
Place Simple Curve 
This tool enables the user to store a circular curve.  Options include offsets, truncate, 
and the ability to modify once the first curve is displayed. 

 
Place Simple Transition 
This tool enables the user to draw a transition element between two arcs.  Options for 
the Transition element include:  Tangent, Curve, or Spiral.  As the Transition option 
is changed, the dialog dynamically changes to reflect the selection.   

CURVE COMBINATIONS TOOLS 

 

The Curve Combinations Commands are detailed in the table below. 

 
Place Turning Paths 
This tool enables the user to draw turning paths. 

 
Place Compound Curves 
This tool enables the user to draw a compound curve between two elements. 

 
Place Three Centered Curves 
This tool enables the user to draw a three-centered curve between two elements.  The 
Design Vehicles group enables the user to select the desired vehicle, based on the 
data from files stored in the User Preferences. 

 
Place Taper Curves 
This tool enables the user to draw taper curves between two elements.  The Design 

 
Place Reverse Curves 
This tool enables the user to store reverse curves between two elements.  An option is 
supported for an intermediate user-defined Tangent Length. 

SPIRAL COMBINATIONS TOOLS 

 

 

 
Place SC Tangent To Line 
This tool enables the user to store a spiral / curve combination tangent to a line. 

 
Place ST Tangent To Curve 
This tool enables the user to store a spiral / tangent combination tangent to a curve.   

 
Place SC Tangent To Curve 
This tool enables the user to store a compound spiral / curve combination tangent to a 
curve. 
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Complex Transitions Tools 

 

 
Place SCS (Intersecting Elements) 
This tool enables the user to store a spiral / curve combination tangent to a line.  The 
Design Table enables the user to select the desired Design Speed / Lanes and Degree 
based on the data from files stored in the User Preferences. 

 
Place STS (Disjoint Curves) 
This tool enables the user to store a spiral tangent spiral combination tangent between 
two elements. 

 
Place SCS (Disjoint Curves) 
This tool stores a spiral curve spiral combination between two curves.  Note the tool 
also works with overlapping curves.  The Design Table enables the user to select the 
desired Design Speed / Lanes and Degree or Radius based on the data from files 
stored in the User Preferences. 

COMPLEX TRANSITIONS TOOLS 

 

 

 
Place Complex Ramp 
This versatile tool enables the user to draw simple to complex ramp geometry. 

 
Place Ramp Connector 
This versatile tool enables the user to draw simple to complex ramp connectors, 
with a variety of options. 

 

ALIGNMENT TOOLS 

 

 

 
Place Dynamic Alignment 
The first Alignment tool is placing a dynamic alignment. You initially select and 
accept a beginning element. By moving the cursor, the length of curve and dynamic 
ahead element change.  Continue placing data points to create curves and 
intermediate tangents.  At any time during the process, the Entry Radius may be 
changed.  Any subsequent curves are placed with the revised Radius. 

 
Place PI Alignment 
The second Alignment tool is placing a PI based alignment. 

 
Store Chain 
The third Alignment tool is storing a chain comprised of graphical elements. This 
works similar to Automatic Create Complex Chain, while the chains are 
automatically being stored into the COGO database file. 
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Manipulate Tools 

 
MANIPULATE TOOLS 

 

 

 
Move Plan View Element 
The Move a Plan View Element enables the user to move / translate an element or 
to make copies. 

 
Rotate Plan View Element 
The Rotate Plan View Element rotates the selected element about a user-defined 
point.  The Angle may be manually entered and locked, or dynamically changing. 

 
Extend Plan View Element 
The Extend Plan View Element tool can extend or shorten any element.   

 
Delete Element  
When using the Delete Element tool, no tool settings dialog opens. 
Select and accept the element to be deleted.  The element is removed from the 
coordinate geometry database.  This tool works with a MicroStation selection set if 
present.  Warning:  there is no undo for this command. 
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LAB EXERCISE:   HORIZONTAL ALIGNMENT TOOLS 

 Accessing Horizontal Alignment Tools 

1. Open the MicroStation file c:\data\geo\sc219\sc219pp.dgn. 

2. Access Project Manager.  It should automatically access the Road workflow dialog since we 
“remembered” the options in Lab 2. 

3. Select the Horizontal Alignment icon from the Road Project: sc219.prj workflow dialog. 

4. Click YES when prompted to activate the default design tables. 

 
5. COGO should activate and the following dialog should appear  

 
6. Enable Permanent Visualization, then you can either move the COGO window out of the 

way or “sink” it using the Bentley icon. 

 

 Setting Preferences 

1. Use the File > Preferences pulldown to access the Preferences dialog.  Select the option 
for COGO Element Names then populate the dialog as shown  

 

2. Select the Curve Design Tables option. Using the Files button, select the appropriate file 
for each option. The files are located in the following directory: c:\program 
files\bentley\geopak\bin\ 
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Lab Exercise:   Horizontal Alignment Tools 

 

 

Symmetrical 
3 Centered 
Curve Design 
Table 

HA_3CenteredCurve_Symmetrical_2001english.tbl 

Asymmetrical 
3 Centered 
Curve Design 
Table 

HA_3CenteredCurve_Asymmetrical_2001english.tbl 

Symmetrical 
Tapered 
Curve 

HA_TaperCurve_2001english.tbl 

Asymmetrical 
Tapered 
Curve 

HA_TaperCurve_Asymmetrical_2001english.tbl 

  

3. Set the PI Alignment Display category as shown below. 

 

4. Set the Parameter Formats category as shown below. 



Lab Exercise:   Horizontal Alignment Tools 

 

 

5. Dismiss the Preferences dialog by clicking the X in the upper right hand corner. 
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6 
CHAPTER OBJECTIVES 

In this chapter, you will create and store horizontal chains using Graphical Coordinate Geometry tools. 

INTRODUCTION 
Graphical Coordinate Geometry is a tool that allows the user the ability to store coordinate geometry 
elements into the COGO database (GPK file) graphically.  Points, curves, lines, spirals, chains, and 
parcels can be stored, modified, or deleted.   The COGO elements can be manipulated by key-in or a 
click of the mouse and are stored directly into the COGO database. 

Note Graphical Coordinate Geometry does not read the exclusive MicroStation graphics. 

ACCESSING 
Graphical Coordinate Geometry is not accessed from Project Manager.  It can be invoked by 
selecting Applications > GEOPAK ROAD > Geometry > Graphical Coordinate Geometry or by 
selecting the Graphical COGO icon from the GEOPAK ROAD tool frame. 

 

Note A session of COGO must be active. 

After Coordinate Geometry is activated and Graphical COGO is selected, the main COGO dialog will 
appear as below. 
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Store Elements 

 
STORE ELEMENTS 

The Store Elements tool box contains eleven icons. 

 

As elements are stored, the visualization parameters in the SMD file (as defined in the user parameters) 
are utilized.  This assumes that the temporary or permanent visualization is activated.  If no 
visualization is active, no elements are visualized. 

When a Store Element command is selected, the Tool Settings open to allow the user to enter data if 
necessary as depicted below. 

 

The Store Elements commands are detailed in the table below. 

 
Store a Point 
The Store Point tool enables the user to store points utilizing either Cartesian 
coordinates (x, y, z or N, E, Z) or Curvilinear (station, offset, elevation). 

 
Store Equally Spaced Points 
The Store Equally Spaced Points stores a user-defined number of  points between 
two previously defined points or any two data points.  A line drawn between the 
two previously defined points is not necessary.   

 
Locate Point 
The Locate Point command stores a point based on the distance and direction from 
a previously defined visualized point. 

 
Store Line From Existing Points 
The Store Line from Existing Points utilizes two previously stored points to store a 
line.   

 
Store Line By 2 Points 
The store line by two points command requires two new points, rather than existing 
points.  The command stores the line and the new points, utilizing the "next" 
available point and line names. 

 
Store Tangent Line 
The Store Line Tangent To Element tool stores a line and its two endpoints in the 
coordinate geometry database. 
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Modify Elements 

 

 
Store Curve By 3 Points 
The Store Circular Curve by Three Points tool stores a circular curve (using chord 
definition).  The stationing is set to 0+00 at the P.C.  The Radius can be manually 
typed in or defined dynamically. 

 
Store Curve By Center 
This tool enables the user to store a circular curve by defining the center point, 
radius, and sweep angle. 

 
Store Tangent Curve Constrained 
The Store a Constrained Tangent Curve tool places a curve tangent to the specified 
curve or line. 

 
Store Tangent Curve Unconstrained 
The Store an Unconstrained Tangent Curve tool places a curve through a specified 
point tangent to the specified curve or line. 

 
Store Tangent Spiral 
The Store Transition Spiral tool quickly places and visually modifies spirals based 
on an initial line or curve. 

MODIFY ELEMENTS 

       

When a Modify command is selected, the Tool Settings dialog opens to allow the user to enter data if 
necessary as depicted below. 

 

The Modify Elements commands are detailed in the table below. 

 
Partial Delete 
The Partial Delete tool enables the user to delete part of a COGO line or curve, 
creating two separate elements. 

 
Extend Plan View Element 
The Extend Plan View Element tool can extend or shorten any COGO element. 

 
Trim Elements 
The Trim Elements tool trims numerous elements to their intersection with another 
element. 

 
Intersect Elements 
The Compute Intersection of Two Element tool stores a new point by trimming or 
extending one element to its intersection with another element.  Note the two 
elements remain intact. 

 
Extend Element to Intersection 
The Lengthen or Shorten an Element tool works functionally the same as its 
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Manipulate Elements 

 
MicroStation counterpart. 

 
Extend Elements to Intersection 
The Lengthen or Shorten Both Elements tool works functionally the same as its 
MicroStation counterpart. 

 
Construct Circular Fillet 
The Construct a Fillet Between Two Elements tool works functionally the same as 
its MicroStation counterpart and stores a circular curve between two elements. 

 
Construct Chamfer 
The Construct a Chamfer Between Two Elements tool works functionally the same 
as its MicroStation counterpart and stores a line between two elements.  Both the 
line and two new endpoints are stored in coordinate geometry. 

 
Cut Element 
The Cut Elements into Smaller Elements tool cuts elements into segments. 

MANIPULATE ELEMENTS 

             

When a Manipulate command is selected, a sub pallet will appear to allow the user to enter data if 
necessary as depicted below. 

 

 

 
Move Plan View Element 
The Move a Plan View Element enables the user to move an element or to make 
copies. 

 
Rotate Plan View Element 
The Rotate Plan View Element rotates the selected element about a user-defined 
point.  The Angle may be manually entered and locked, or dynamically changing. 

 
Copy Parallel 
The Copy Parallel tool works functionally the same as its MicroStation counterpart. 

 
Delete Element 
When using the Delete Element tool, no tool settings dialog opens. 
Select and accept the element to be deleted.  The element is removed from the 
coordinate geometry database.  This tool works with a MicroStation selection set if 
present.   

Warning There is no undo for this command. 
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Groups 

 
GROUPS 

           

When a Group command is selected, the Tool Settings opens to allow the user to enter data if 
necessary as depicted below. 

 
                                                     

The Groups Commands are detailed in the table below. 

 
Store Chain 
The Store Chain command works in the same manner as the MicroStation 
Automatic Create Complex Chain with the additional benefit that the chain is 
automatically stored in the COGO database. 

 
Store Parcel 
The Store Parcel tool enables the user to store parcels, takings, easements, and 
other types of right of way features.  It is very similar to the Store Chain tool with 
many of the same options. 
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LAB EXERCISE:   HORIZONTAL ALIGNMENT AND GRAPHICAL COGO 

This exercise will lay out a ramp from chain SC219R to chain I26.  The parameters of the ramp are as 
follows: 

• The chain will start at station 123+00 on SC219R. 
• The departure angle from chain SC219R is 70°. 
• The initial tangent is to be 125’ in length. 
• The reverse curves will be 8° and 4° 30’ respectively with a 250’ tangent between the curves. 
• The 4° 30’ curve will be tangent to chain I26, 54’ offset. 

 Storing a Ramp 

1. Open the MicroStation file c:\data\geo\sc219\sc219pp.dgn. 

2. Open Project Manager. 

3. Open the Horizontal Alignment and Graphical COGO tools. 

4. Using Graphical COGO’s Store Point tool, store a point at station 123+00 on chain SC219R. 

 

5. Use COGO’s Locate Traverse tool to locate a point 200’ from point 3121 at a 70° angle to 
chain SC219R. 

 

Note The first point above is PC SC219R-3. 

6. Store a COGO line from point 3121 to point 3122. 

7. Visualize chain I26 using COGO Navigator. 



Lab Exercise:   Horizontal Alignment and Graphical COGO 

 
8. Using MicroStation’s Copy Parallel command, copy the chain 54’ to the west. 

 

9. Drop the complex chain using MicroStation’s Drop Element command. 

10. Use the Place Reverse Curve tool (Horiz. Alignment Generator:  Tools>Curve 
Combinations) to place a reverse curve between the initial tangent line and the offset chain 
I26 using the parameters shown below. 

 

11. Use the Store Chain tool from Horizontal Alignment Generator to store the chain RAMP2 
beginning at Station 1906+50.  Set the chain stationing to run toward chain SC219R. 

 

12. Save the COGO input file with a name of RAMP2. 

13. Close COGO. 
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CHAPTER OBJECTIVES 
In this chapter, you will learn more about: 

• How to use D&C Manager to plot horizontal alignments into MicroStation.  
• Understand the format of the hierarchical database and how to use it. 
• Be able to use the D&C Manager in conjunction with other GEOPAK tools & MicroStation to 

draw and manipulate elements. 

INTRODUCTION 
The Design and Computation Manager (D&C Manager) is a tool that allows the user to standardize 
graphics elements for drafting and pay item quantities. 

A hierarchical database is used with the Design and Computation Manager. This database stores 
information concerning functional classification and display preferences for each feature and item used 
in a MicroStation file. This file is commonly referred to as the ddb file (*.ddb). 

Categories are used to group and classify the features and items used in creating construction drawings.  
Two common examples of these categories are Pay Items and Drafting Standards as shown in the 
following diagram.  

 

These three categories each contain sub-categories.  The sub-categories break down each classification 
into more specific items.  For example, Drafting Standards may be broken into several additional 
categories such as Imperial and Metric. 
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Introduction 

 

 

Imperial may be broken into numerous other categories. Within a category (represented by the folder 
icon), the items that are included are designated according to the process that they will be used for (as a 
drafting item indicated by a paintbrush shown in the following diagram): 

 

Each entry represents a specific item.  The various icons representing the function they will be utilized 
for can identify items. 
• Calculator (quantities calculations) 
• Paintbrush (draw design elements) 
• Report icon (default, pavement design, pavement markings, etc.) 

See report and calculator icons in diagram below: 
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Accessing the Design and Computation Manager 

 

 

The database may also be password protected if desired. This can be used as a security measure to 
protect the integrity of the database file and ensure its consistent application on a statewide or company 
wide basis. 

ACCESSING THE DESIGN AND COMPUTATION MANAGER 
Design and Computations Manager can be accessed by selecting Applications > GEOPAK ROAD > 
Design & Computation Manager.  It can also be invoked from the GEOPAK ROAD Tools tool 
frame and the Plan View Design tool box in Project Manager. 

When the Design and Computation Manager is accessed, two dialogs are displayed. 

 

The main D&C Manager dialog is composed of two distinct areas: 

• Across the top are icons for the various modes.  The D&C Manager may be configured to operate 
in seven different modes: Display, Design, Set, Compute, Shape, Pavement Marking and 
Preferences.  As various modes are selected, more icons are displayed within this area. 

• The Path box displays the name of the attached database file and your current position within the 
database structure.  It lists the categories, sub-categories and items available for selection.  This 
hierarchical data structure functions much like a directory. Double clicking enables the user to 
move up or down within the database. 
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Accessing the Design and Computation Manager 

 
A second dialog appears differently depending on the mode of operation.  This dialog enables the user 
to set other options not available on the main dialog. 

 

FILE COMMANDS 
 

 

For the GEOPAK designer, the only file command options needed are Open and 
Exit.  The other commands such as Save, Merge, and Compress are used by 
personnel who maintain the database. 
As mentioned previously, the Password option may be used to password protect 
the database so a user would not be able to make changes to it. 

EDIT COMMANDS 
 

As a designer, the most-used Edit commands will be Find, Identify and 
Review Item.  
Find – This tool will search the database (from your current location) for an 
item or category.  If the database is password protected, all other items will be 
disabled. 
Identify – This tool will allow you to select an element in the design file to 
identify which item it matches in the database. 
Review Item – This tool will allow you to review the settings/symbology for 
a particular item in the database. 
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Operational Mode - Design 

 
SETTINGS 

Display Settings - temporarily changes the display of elements on the 
screen to one common color, then the user may specify additional 
elements to be viewed in their original colors.  This tool enhances 
visualization when working on a complex project. 
Design Settings - sets the maximum gap tolerance and deduction 
tolerance used in computations and the drawing scale for placing cells. 

 

FAVORITES 
Add to Favorites - saves current D&C Manager path for easy recall in the 
future. 
Organize Favorites – allows the organization of previously saved paths.  

OPERATIONAL MODE - DESIGN 
The Design mode enables the user to draw each roadway element or COGO element (and associated 
attributes) in the design file based on drafting item parameters.  

First, the desired item is highlighted in the main dialog list box, i.e., alignment, edge of pavement, etc. 

 

The Place Influence option sets the level, symbology and attribute tags of elements drawn or copied 
using MicroStation commands.  When the Place Influence toggle is activated, elements are drawn 
using the level, symbology and attributes as defined in the GEOPAK database.  When Place Influence 
is off, elements are drawn using the active level, symbology and attributes of MicroStation. 

 

The Draw COGO Element button is for drawing COGO elements to a design file.  A single click to 
this button prompts the user for a job number then opens a dialog that enables the user to choose a 
COGO item to draw. 
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Operational Mode - Design 

 

 

If an alignment, profile or parcel item is chosen, the Draw COGO Element button changes to Draw 
Plan and Profile. 

 

If Match Point Text is selected the active MicroStation settings are set to match the drafting 
preferences symbology for points of the selected item. 

 

Adhoc Attributes is used with Place Influence to add Adhoc Attributes to any new element when that 
element is drawn.  A table is displayed when a MicroStation command is selected and the user can 
modify the value of the Adhoc Attribute prior to placement of the element. 

    

If New Element Only is selected and an element is modified or moved, it’s symbology is not changed 
to the selected item. 
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Operational Mode - Design 

 
From the secondary dialog that is opened, click the Draw Plan & Profile button to initiate the drawing 
of COGO elements into the design file. Clicking this button prompts the user for a job number (the 
coordinate geometry database file wherein the COGO elements are stored), and then opens a dialog 
that enables the user to choose a COGO item to draw. Do Not activate the Place Influence toggle when 
using Draw Plan & Profile. 

Hint If utilizing the Design & Computation Manager within Project Manager, you are not prompted 
for a job number since this is associated with the active project. 

 

Eight operations may be accessed from the 
Plan and Profile Draw dialog: Points, Lines, 
Curves, Spirals, Chains, Stationing, 
Parcels, and Profiles.  Each of these 
operations dynamically changes the dialog to 
reflect the selection with the various draw and 
label features used when placing a COGO 
element in a graphics file. 

 

 

The points and lines dialog boxes have a key-
in field that allows the user to specify the 
names of the COGO elements to be drawn.  
To use the line operation, the user must use 
point numbers to specify the ends of the line.  
The points/lines are drawn immediately after 
you enter their respective names and press the 
enter key.  To draw more than one point or 
line, place a dash in-between the point 
numbers.  To draw a line without using 
consecutive point numbers, use a forward 
slash (i.e. 10/11). 
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Operational Mode - Design 

 
The dialog settings for curves, spirals, 
chains, stationing, parcels, and profiles 
have a list box that display the names of all 
curves, spirals and chains stored in the active 
coordinate geometry database file.  
Highlighting one of the available elements 
initiates further commands to draw the 
element into the design file.  Each type of item 
has a list of parameters that can be optionally 
plotted. 

 

 

 

Hint GEOPAK can draw elements to non-active levels.  After elements are drawn, it may be 
necessary to turn on appropriate levels and fit the elements into the view. 
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DP Station/Offset 

 
DP STATION/OFFSET 

INTRODUCTION 
The DP Station/Offset tool works in conjunction with MicroStation commands and the D&C 
Manager.  It can be used as the data point for any MicroStation command.  DP Station/Offset provides 
precision placement of elements based on a station and offset of a stored chain.  Uses for this 
command include precision placement of elements and window functions. 

ACCESSING 
The DP Station/Offset tool can be accessed by selecting Applications > GEOPAK ROAD > Plans 
Preparation > DP Station/Offset.  It can also be invoked from the GEOPAK ROAD Tools tool 
frame and the Plan View Design tool box in Project Manager. 

When the DP Station/Offset tool is accessed, the dialog below is displayed. 
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Draw Transition 

 
DRAW TRANSITION 

INTRODUCTION 
The Draw Transition tool draws a line/curve based on a beginning station/offset and an ending 
station/offset relative to a selected chain.  Use of this command includes turn lanes, mailbox widening, 
curve widening and lane transitions. 

ACCESSING 
The Draw Transition tool can be accessed by selecting Applications > GEOPAK ROAD > Plans 
Preparation > Draw Transition.  It can also be invoked from the GEOPAK ROAD Tools tool frame 
and the Plan View Design tool box in Project Manager. 

When the Draw Transition tool is accessed, the dialog below is displayed. 

 

Note Elements placed with Draw Transition have MicroStation element type curve when the 
beginning and ending offsets are different and MicroStation element type line and/or arc 
when the beginning and ending offsets are the same. 
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LAB EXERCISE:   D&C MANAGER – PLANS PRODUCTION 

 Accessing Design and Computation Manager 

1. Open the MicroStation file c:\data\geo\sc219\sc219pp.dgn. 

2. Access Project Manager.  It should automatically access the Road workflow dialog since we 
“remembered” the options in Lab 2. 

3. Select the icon Plan View Design button from the Road Project: SC219.prj workflow dialog, 
which opens the Plan View Design tool box. 

 

 Drawing Alignments 

1. Select the Design and Computation Manager tool (as indicated above) to invoke the Design 
and Computation Manager shown below. A secondary dialog opens to be used in conjunction 
with the Design and Computation Manager dialog. 

 

2. Select item DESIGN > BL & CL > BL50. 

 



Lab Exercise:   D&C Manager – Plans Production 

 
3. Next, click Draw Plan and Profile from 

the secondary dialog: 

 

4. Select the Chains operation.  Chain 
‘SC219R’ should be displayed in the list 
box as shown.  Notice that the options that 
are to be drawn with the chain are already 
activated. Set the Label Scale to 50. 

5. To draw the chain, select SC219R in the list 
box.  Only click once!! 

 

 

6. Change the Operation to 
Stationing and annotate the 
alignment SC219R by selecting 
the chain name in the list box. 

7. Dismiss the Plan and Profile 
dialog by clicking the X in the 
upper right hand corner. 

8. Review the results of steps five 
and six. 
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8 
CHAPTER OBJECTIVES 

In this chapter, you will learn to calculate existing ground profiles extracted from a surface model. 

INTRODUCTION 
The Draw Profile tool enables the user to draw several profiles from a variety of sources simultaneously. 

● GEOPAK coordinate geometry database wherein the vertical alignment is stored.   
● GEOPAK binary TIN file, Site Model or Site Object.  The Site Model or Object are created utilizing 

GEOPAK Site Modeler software and are stored within the GEOPAK Site project (gsf) file. 

In addition, if the source data is TIN files or site components, the resultant profile may optionally be stored 
within the coordinate geometry database. 

INVOKING THE DRAW PROFILE TOOL 
The Draw Profile Tool is not supported by Project Manager.  It can be accessed by selecting 
Applications > GEOPAK ROAD > Plans Preparation > Draw Profiles or from the GEOPAK ROAD 
Tools tool frame. 
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Update Options 

 
The generation of profiles must be invoked from within the 2D MicroStation design file wherein the 
profile is to be drawn. 
The initial entries that are required are the Job Number and Chain name.  Once selected, click Dialog 
Profile Cell Control (to the right of the Job Number field).    

 

Select the Active Chain that the new or existing profile is to be stationed along.  If no profile cell 
exists, click Place Profile Cell along the right side of the window to place a new cell.  If multiple 
profile cells exist, highlight the desired cell and click Activate Profile Cell. 
 

UPDATE OPTIONS 
Four update options exist that allow the user the control needed to tell the software what to do if a 
profile has been previously drawn in the file and needs updated.  The options are toggled off / on by 
each selection of the option by clicking the Update Options pulldown.  The check to the left of the 
option indicates the option is active.  Only one option may be active at any given time, therefore, if an 
option is selected, the previous active option is de-activated.  The four options are detailed in the table 
below. 

Delete Existing Elements and 
Redraw 

When this option is activated, any profiles previously drawn with this 
tool are deleted and new ground lines are drawn. 

Delete Non-Modified Elements 
and Redraw 

When this option is activated, any profiles previously drawn with this 
tool and not modified with any MicroStation commands are deleted 
and new ground lines are drawn. 

Draw on Top of Existing When this option is activated, any previously drawn profiles are 
ignored and a new set is drawn, resulting in multiple copies of each 
profile. 

Query When activated, the user is prompted each time the Draw button is 
pressed. 

SURFACES TAB 
The Surfaces tab defines the surfaces utilized as source data when drawing profiles.  Multiple surfaces 
from a variety of sources can be drawn in a single processing.  When the tab is selected and a profile 
cell is placed, the dialog dynamically changes as depicted below. 
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Display Settings 

 

 

Each surface to be drawn must be added to the list box.  This is accomplished via the action / edit 
buttons on the right side of the dialog box.  Each surface draws a cross section line string or lines.  
When a line is added to the list box, the profile is drawn.  Note:  clicking on the draw toggle in the list 
box deletes or redraws the profile. 
To add to the list box, simply select the source data and method, Display Settings, Tolerances and 
Offsets, and then add the profile to the list.  Once a profile is drawn, it may be updated at any time by 
using Update Profile.  Refer to the Update Options section to review those options.  Any profile may 
optionally be stored to the GPK file if desired. 

DISPLAY SETTINGS 
The Display Settings group box specifies the element symbology of the cross section elements being 
generated.  The symbology may be specified using Level Symbology or a feature selected from a D&C 
Manager database. 
To use By Level Symbology, set the option to By Level Symbology, then double click on the graphic.  
This opens the Set Feature dialog box, wherein the symbology can be specified.  Click OK when 
completed. 
To use By Feature, set the option to By Feature.  Next, press the Paintbrush icon, which invokes the 
current Design and Computation Manager.  Select the desired item, and then press the OK button, 
which closes the Design and Computation Manager, and populates the Draw Profile Display Settings 
group box. 

FILTER TOLERANCES 
Both Horizontal and Variance filter tolerances are considered together for each pair of profile 
segments.  The middle point is deleted if both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord between the two end points 
is less than the Variance tolerance. 
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Display Settings 

 

 

OFFSETS 
Vertical or Horizontal Offsets may be specified in terms of master units (i.e., feet or meters).  The 
Horizontal Offset is the distance offset from the Chain.  Once the horizontal location for the profile is 
determined, the data source is utilized to determine the profile.  Any Vertical Offset is applied after the 
profile is generated from the source data. 

STORE PROFILE TO COGO 

 
When the profile is drawn, it may also be stored in COGO by 
pressing this button, which opens the dialog box depicted below 
left. 

 

The profile may be stored, or just the input file may be created.  If 
an input file is created, the Operator Code and File Name are 
required.  If the dialog box is invoked while in a 3D file, the user 
may toggle on the option to create a 3D profile string. The 3D 
profile string consists of the circles denoting every location where 
the design centerline intersects topographic elements.  If the circles 
are not deleted at this time, they can be deleted at any time with a 
single application of the MicroStation "Delete Element" command. 
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Display Settings 

 
COGO TAB 

The Cogo Tab is utilized for drawing any profile that has been previously stored into the GPK file. 

 

To draw a profile, first select the Profile Name to be drawn.  The Vertical Offset defaults to a value of 
0, but can be set to any value.  This instructs the software to draw the profile at a distance above or 
below the elevations in the GPK file.  Station Limits may also be specified to have the software draw 
only a portion of the profile.  If the Display Settings are set to By Feature and a feature is selected, the 
Options area of the dialog box is un-ghosted.  This is where various labeling options for the profile can 
be specified.  If a value is given for the Strip Grade Increment, elevations will be placed at that 
increment along the bottom of the profile. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 8-6 

Profile Report 

 
PROJECTION TAB 

In this option, a new profile is created, 
extracting the elevations from the specified tin 
file along the chain selected in the Details 
section, but projecting the stations onto the 
chain that controls the profile cell settings.   

 

 

PROFILE REPORT 
To review a textual report listing stations and elevations of a ground profile, open the GEOPAK 
Coordinate Geometry dialog box.  A couple of different methods can be used to create this listing for 
any profile.   
By selecting Element > Profile > 
Utility then highlighting a specific 
profile name and clicking Print.  The 
results of this command will be 
displayed in the Command Output 
window of the Coordinate Geometry 
dialog box.  To obtain a hardcopy of 
this information, create an output file 
using the File > File Utility > Output 
command and supply a filename of 1-
5 characters.  Then use the File > File 
Utility > Print Output File command 
to print this to the default system 
printer. 
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Lab Exercise:   Existing Ground Profile 

 
The second method utilizes the COGO 
Navigator tool to create the Print 
Profile command.  The advantage to 
this method is that multiple profiles 
can be identified at once and printed 
to the Command Output window.  
Start the COGO Navigator by clicking 
Tools > Navigator or selecting the 
icon from the COGO dialog box.  
Change the Element to Profile then 
highlight the desired profile(s).  Once 
selected, click the Print/Describe 
Element icon on the Navigator to 
process the profile(s). 

 

LAB EXERCISE:   EXISTING GROUND PROFILE 

 Extract Existing Ground Profile 

1. Open the MicroStation file c:\data\geo\sc219\sc219profile.dgn. 

2. Access Project Manager.  It should automatically access the Road workflow dialog since we 
“remembered” the options in Lab 2. 

3. Access the Draw Profile tool by selecting Applications>GEOPAK ROAD>Plans 
Preparation>Draw Profiles or from the GEOPAK ROAD Tools tool frame. 

 
4. Select chain “SC219R” from the chain dropdown list. 
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Lab Exercise:   Existing Ground Profile 

 
5. Click Dialog Profile Cell Control icon (to the right of Job Number).  

6. Set the Active Chain to SC219R.     

7. Click Place Profile Cell on the right side of the dialog.   

 

8. Populate the dialog as shown above and snap and accept the lower left corner of the grid. 

Hint The coordinates of this location is 10000,10000. 

9. Fit the view contents. 

10. Close the Profile Cell Control dialog. 

 

11. From the Surfaces tab, select the Browse TIN File button in the Details area, then select the 
SC219.TIN file for the TIN File to cut the profile. 

12. Set the Method to Triangles. 

This instructs the software to compute elevations at each location that the chain intersects a 
triangle leg from the TIN. 

13. Set the option button to By Feature in the Display Settings area of the dialog. 

14. Click the Browser Feature (Paintbrush) icon then navigate to the item shown below.  

 

15. Click OK 
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Lab Exercise:   Existing Ground Profile 

 
16. Click Add Surface Settings to add the profile to the list box as well as draw the profile into 

the MicroStation file. 

 

 Store Profiles into COGO Database 

1. Click Store Surface in COGO. 

 

2. Populate the dialog as shown above. 

3. Click Apply. 

4. Close the Store Profile dialog. 

5. Click Remove Surface icon. 

Note This erases the profile from the DGN file.  We will re-draw the profile shortly. 

 Review Profiles in COGO 

1. Select the Coordinate Geometry tool.  (Click Coordinate Geometry on the workflow dialog 
box).  

2. Select Element > Profile > Utility. 

 

3. Select the profile ‘SC219REP’  

4. Click the Print icon. 

5. Review the profile information in the COGO output display window. 

6. Close the Coordinate Geometry dialog.  When prompted to save the COGO session, select 
No. 
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Lab Exercise:   Existing Ground Profile 

 
 Drawing and Labeling the Existing Centerline Profile 

1. Click the COGO tab on the Draw Profile dialog then set the Label Scale to 50 in the upper 
right hand corner. 

 
2. Select the Profile Name SC219REP in the Details section. 

3. Set the option to By Feature in the Display Settings section. 

4. Click the Browser Feature (Paintbrush) icon then navigate to the item shown below. 

 

5. Click OK. 

6. Select General in the Options area and set the Strip Grade Increment to 50.   

This will label the elevations every 50’ along the bottom of the profile area. 

 

7. Click Add COGO Profile Settings to draw the profile. 

This will draw the existing ground profile with the proper symbology in addition to labeling 
the stations and elevations along the bottom of the profile and the elevations along the left 
side of the profile. 

8. Close the Draw Profile dialog. 



Lab Exercise:   Existing Ground Profile 

 
 Project Manager Define 

1. From the Workflow dialog of Project Manager, click Define. 

2. Highlight the Profile View option and populate the dialog box as depicted below. 

 

Note We have not designed the proposed profile; therefore, we will return to populate this field in a 
later exercise. 

3. Highlight Location. 

4. To quickly populate this category within working alignment, click Identify Cell, then data 
point on the cell for the centerline profile in the file and accept. 

Note Your coordinates may be different than those shown below.  That is not a problem 

 

5. Click OK to save the updates and close the dialog. 

6. Exit MicroStation. 
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CHAPTER OBJECTIVES 
 

In this chapter, you will learn to create and store vertical alignments using the Vertical Alignment 
Generator. 

INTRODUCTION 
The Vertical Alignment Generator is a GEOPAK tool that can graphically create and modify proposed 
design profiles or modify an existing ground profile.  These operations may be accomplished through a 
dialog box and/or by dynamic manipulation of graphic elements. 

A profile may also be created with Coordinate Geometry (COGO) input (key in commands).  In 
addition, there are VC commands that compute and display vertical geometry and the parameters 
associated to aid in the development and generation of vertical alignments used in conjunction with 
Store Profile commands.  VC commands define parabolas for various combinations of stations, 
elevations, grades, slopes and the rate of vertical curvature (K value), and also define the tangents 
between two parabolas or between a parabola and a point. 

ACCESSING 
The Vertical Alignment Generator can be accessed by selecting Applications > GEOPAK ROAD > 
Geometry > Layout Profiles (VPI Based).  It can also be invoked from Project Manager by clicking the 
Vertical Alignment button or by selecting the VPI Based Vertical Alignment Design Tools icon from 
the GEOPAK ROAD tool frame. 
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Using the Vertical Alignment Generator 

 
When selecting the Vertical Alignment generator, 
the first dialog that appears is labeled Settings, as 
depicted here.  The entries in this box set the 
parameters and define the location within the 
design file where the profile components are to be 
displayed.  All fields must be completed before the 
design process can begin.  Once OK is clicked, the 
Vertical Profile Generator dialog box appears. 

Note This tool also utilizes the cell that was 
drawn in the previous exercise by 
using the Identify Cell button. 

 

USING THE VERTICAL ALIGNMENT GENERATOR 
This tool enables a user to load a previously stored profile or create a new profile.  You will notice the 
dynamic changes in the dialog throughout the vertical alignment design. 
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Using the Vertical Alignment Generator 

 
Various design parameters must be defined prior to designing a new profile; which are discussed in the 
options supported under the three menu options; File, Tools, and User. 

FILE 

 
 

Preferences… - sets the rounding parameters for each of the items listed in the 
dialog box.  Also contains a toggle that will force the dialog to window center the 
view on the current VPI.  The Hold Vertical Curve toggle and the Maintain 
VC K Value /Maintain VC Length option button dictate vertical curve 
dynamics. If the Hold Vertical Curve toggle is active and if the option button is 
set to Maintain VC K Value, then dynamic operations lock the K value. This in 
essence allows the user to slide the grades along a continuous parabola 
representing the vertical curve. If the Hold Vertical Curve toggle is active and if 
the option button is set to Maintain VC Length, then dynamic operations create 
a similar effect in that the vertical curve length is held constant. 
Profile Cell Settings… - recalls the Settings dialog box that first appeared upon 
initializing Vertical Layout. 
K Value Table… - is a table of stopping sight distance K-values for crest and 
sag conditions for various design speeds.  These values are based on the 
AASHTO Green Book. 
Load Profile… - retrieves a previously stored profile from the coordinate 
geometry database (.gpk) 
Save Profile - stores a new profile or updates (redefines) a previously stored 
profile under the same name. 
Save Profile As… - is used to store the profile or to save a modified profile 
under a different name. 
Clear Profile - clears the profile display from MicroStation graphics and 
removes all VPI’s from the dialog box. 
Draw Profile - write the graphic elements of the profile to the MicroStation file. 
Exit - ends the process. 

TOOLS 

 

Issue Data Point - Permits the user to type in stations and elevations, issue a data 
point that can be part of a MicroStation place line, place a cell or perform other 
generic operations.  This is useful in displaying visual references within the profile 
that need to be considered in design of the vertical profile. 
Critical Points - Vertical curves may also be defined by one or two critical points – 
i.e. the curve will pass through these points  If mathematically solvable, the vertical 
curve will be drawn and the design speed display adjusted to fit the current 
parameters. 
Best Fit - Three Best Fit tools are supported within the Profile Generator: 

• Best Fit Line 
• Best Fit Parabola (Curve) 
• Best Fit Profile 
 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 9-4 

Best Fit tools 

 
BEST FIT TOOLS 

Three best fit tools are available to aid in the generation of a profile that closely matches the existing 
conditions.  Each tool is described in the following sections. 

BEST FIT LINE 
The Best Fit Line tool fits a line between the candidate elements.  The resultant line data is displayed 
in the dialog and the line is drawn onto the profile cell. 

 

In this example, only the candidate elements within the fence are used for the Best Fit.  

 

 

BEST FIT PARABOLA 
The Best Fit Parabola tool fits a vertical curve between the candidate elements.  The resultant curve 
data is displayed in the dialog and the curve is drawn onto the profile cell. 
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Best Fit tools 

 

 

In this example, only the candidate elements within the fence are used for the Best Fit.  

 

 

BEST FIT PROFILE 
The Best Fit Profile tool fits a profile (comprised of tangent lines and vertical curves) between the 
candidate elements based on the constraints in the Design Parameters.  As there is no symbology 
option, the active symbology is used.   
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Creating A New Profile 

 

 

The Upper and Lower Envelope Distance values determine an initial desired envelope for the desired 
profile.  Once the tangents are established within the design envelope, the Crest and Sag K values and 
Minimum Vertical Curve Length are used as guidelines to establish parabolic vertical curves. 

CREATING A NEW PROFILE 
Warning The enter/tab key must be used to ensure values are accepted. 

A new profile can be created with the following steps: 

1. Place the first VPI using one of the four supported options. 

• Type station and elevation of the VPI into the appropriate fields in the Profile Generator 
dialog. 

• Enter station of VPI as precision input (type in value), and allow the elevation to be 
defined through dynamic cursor placement on screen. 

• Elevation is defined via precision input, and the station is defined through dynamic cursor 
placement on screen. 

• Both values for the VPI can be established dynamically on screen by clicking on the 
Dynamic button and placing a DP in the view at the desired station and elevation. 

2. Define ahead (or back tangent) 

Station, elevation, grade and length parameters may be defined via precision input, dynamic 
manipulation or a combination of both. 

3. Define remaining VPI’s and Grades 

A repetition of Step 2 with an option to insert VPI’s between two existing VPI’ s. 

4. Define Vertical Curves 

Simply define the design speed from the Speed option button and GEOPAK will reference the 
K-value table and draw the vertical curve.  If a curve overlap occurs, an overlap message will 
be displayed in the dialog box along with the overlap length.  Length of Curve or K-value 
may also be keyed in. 

5. Adjusting Curve Lengths 

The vertical curve can be modified by directly keying in either the K-value, curve length or 
defining the design speed in the dialog box.  You will see the values computed automatically 
adjust to reflect the results of any modifications. 

6. Save the Profile. 

Select File > Save Profile As to name and save the newly created profile.  The names of 
profiles are any 1-9 alphanumeric characters. 
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Lab Exercise: Vertical Alignment Generator 

 
PRECISION PLACEMENT OPTIONS 

 

 

Options available for creating or modifying vertical curves, VPI’s and grade lines:  
• OFF - Values change. 
• INC (Increment) - Ensures that the designated profile parameter will be 

adjusted as defined in the Preferences dialog. 
• LCK (Locked) - Forces selected operations to maintain the designated profile 

parameters. 

 

LAB EXERCISE: VERTICAL ALIGNMENT GENERATOR 

     Generate the Proposed Profile 

1. Open the MicroStation file 
C:\data\geo\sc219\sc219profile.dgn. 

2. Access Project Manager.  

3. Select the Vertical Alignment button from the 
Road Project: SC219.prj workflow dialog. 

4. All of the information in the invoked Settings 
dialog should be automatically populated based 
upon the information we provided in the 
DEFINE dialog in Lab 8. 

5. Click OK.     

 

 

 

6. Provide the initial VPI Station = 87+25.49 and the initial VPI Elevation = 433.87 as shown in 
the diagram below. Be sure to press Enter after each entry is made. 
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Lab Exercise: Vertical Alignment Generator 

 
7. Click the Insert After button and complete the VPI Station and Elevation of the subsequent 

VPIs as detailed in the table below. 

VPI Station Elevation 

2 89+50 435.83 

3 95+00 419.69 

4 99+50 405.92 

5 111+00 384.53 

6 119+00 419.41 

7 128+50 426.82 

8 133+50 435.09 

9 146+75 472.75 

10 152+50 471.02 

11 158+50 446.78 

12 169+50 438.56 

13 178+00 397.75 

14 186+00 441.85 

15 197+25 479.8 

16 204+25 505.59 

17 211+25 521.73 

18 219+00 514.57 

8. Click the Prev button to return to VPI 2 as shown in the diagram below. 

 

9. Enter a symmetrical vertical curve Length of 400.00.  (The K value and Design Speed are 
automatically computed.) 
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Lab Exercise: Vertical Alignment Generator 

 
10. Using the Next button to move to each successive VPI, key in the following curve lengths at 

each VPI. 

VPI Length of Curve 

3 200 

4 300 

5 600 

6 500 

7 300 

8 500 

9 700 

10 450 

11 500 

12 700 

13 700 

14 680 

15 500 

16 400 

17 500 

 

11. Select File > Save As to save the profile SC219RFP.  

 

12. Exit the Profile Generator.   

13. When prompted to save your profile, click No since we did that in Step 11.   

14. When prompted to save your Vertical Alignment Settings, click Yes. 

15. Open COGO and use the Element > Profile > Utility tool to see a listing of information 
about the profile.  Select profile SC219RFP then click the Print icon to describe the profile.   
The Element > Profile > Elevations tool will provide elevations at any station or increment 
of stations desired. 

16. Exit COGO. 
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Lab Exercise: Vertical Alignment Generator 

 
 Drawing the Proposed Profile 

Next, we are drawing the proposed profile ‘SC219RFP’ utilizing the Draw Profile tool on top of the 
existing ground profile from Exercise 8. 

1. Select the Draw Profile tool. 

2. Select the COGO tab. 

3. Select the Profile Name SC219RFP in the Details section. 

4. Set the option button to By Feature in the Display Settings area of the dialog. 

5. Click the Browser Feature (Paintbrush) then navigate to the item shown below. 

 
6. Click OK.      

7. Select General in the Options area and set the Strip Grade Increment to 50.  This will label 
the elevations every 50’ along the bottom of the profile area. 

 

8. Click Add COGO Profile Settings icon to draw the profile. 

This will draw the proposed profile with the proper symbology in addition to labeling the 
stations and elevations along the bottom of the profile and the elevations along the left side of 
the profile. 

9. Close the Draw Profile dialog. 

 Update Project Manager 

We are completing the Profile View of the Working Alignment Definition in Project Manager. 

1. Click the Define button from the Workflow dialog of Project Manager, 

2. Highlight the Profile View option and populate the Proposed Profile field as depicted below. 



Lab Exercise: Vertical Alignment Generator 

 

 

3. Click the OK button to save the updates and close the dialog. 

4. Exit MicroStation. 
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CHAPTER OBJECTIVES 
In this chapter, you will learn to: 

• generate existing ground cross sections based on a horizontal alignment and the surface model 
beneath the alignment.  

• review the sections utilizing the Cross Section Navigator tool. 

INTRODUCTION 
The prerequisites to generate existing cross-sections utilizing digital terrain modeling are: 

• GEOPAK coordinate geometry database wherein the horizontal alignment is stored. 
• GEOPAK binary TIN file, Site Model or Site Object.  The Site Model or Object are created 

utilizing GEOPAK Site Modeler software and are stored within the GEOPAK Site project (gsf) 
file. 

• Pattern lines if pattern by design is to be utilized. 

The generation of existing ground cross sections must be invoked from within the 2D MicroStation 
design file wherein the sections are to be drawn.  GEOPAK does not create this MicroStation design 
file.  The user creates the blank design file utilizing the desired seed file, and then GEOPAK draws 
into it. 

PATTERN LINES 
Pattern lines are graphical lines and/or line strings in a MicroStation design file that define locations at 
which the cross sections will be cut. 
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Accessing Draw Patterns 

 
ACCESSING DRAW PATTERNS 

The Draw Pattern tool can be accessed by selecting Applications > GEOPAK ROAD > Cross Sections 
> Draw Patterns by Station Range.  It can also be invoked from Project Manager by clicking Draw 
Pattern or by selecting Draw Patterns by Station Range from the GEOPAK ROAD tool frame. 

 

Once all of the fields have been completed, and the application is initiated, graphic lines (on the specified level, color 
and style) are drawn along the chain.  This is a visual representation of the location of the cross sections to be generated. 

Six methods are supported for drawing the pattern lines: 

• Increment – starts at the beginning station, and draws a pattern line at the given increment. 
• Even – draws pattern lines at stations divisible by the given value. 
• Once – draws a pattern line at a given station. 
• Critical Points Horizontal – draws a pattern line at each of the critical point (i.e. POT, PC, PT, 

etc.) within a chain. 
• Critical Points Vertical – Draws a pattern line at each VPC and VPT in addition to the sag and 

crest station of vertical curves based on the profile defined in the dialog. 
• Superelevation Transitions - The current design file is scanned for Superelevation shapes created 

with the specified chain.  A pattern line is drawn at the beginning and end of each Superelevation 
shape, ignoring the beginning and ending station fields in the dialog.  Note the Superelevation 
shapes cannot be in a reference file. 

 

The pattern lines are drawn into the current MicroStation design file.  The user can use the 
MicroStation Place Smartline or Place Line command to draw additional pattern lines at any user 
defined location.  In addition, MicroStation commands can be utilized to modify pattern lines drawn 
via the dialog to lengthen, shorten, delete, copy, move, etc.   

Note This should be completed before the existing ground cross sections are generated. 
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Generating Cross Sections 

 
GENERATING CROSS SECTIONS 

The Draw Cross Sections tool can be accessed by selecting Applications > GEOPAK ROAD > Cross 
Sections > Draw Cross Sections from Surfaces.  It can also be invoked from Project Manager by 
clicking Existing Ground Cross Sections or by selecting Draw Cross Sections from Surfaces from the 
GEOPAK ROAD tool frame. 

Once the pattern lines have been drawn, the cross sections can be generated.  Note the Job Number 
must be defined in order to populate the Chain list.  Once the Chain is defined, the dialog unghosts. 

 

The dialog contains a menu bar with three listings: 

File Standard file utilities to load, or save settings, plus a dialog exit option. 
Edit Options to Cut, Copy and Paste rows in the surfaces list box.  Also, save 

and restore settings in the RSC file or clear list of all surfaces. 
Update Options: User-defined options on how the software handles the redrawing of cross 

sections. 

Three Update Options are supported, along with a Query option: 

Delete Existing Elements and 
Redraw  

When this option is activated, any existing ground lines previously drawn 
with this tool are deleted and new ground lines are drawn. 

Delete Non-modified Elements 
and Redraw  

When this option is activated, any existing ground lines previously drawn 
with this tool are deleted and new ground lines are drawn. 

Draw on Top of Existing  When this option is activated, any previously drawn ground lines are 
ignored and a new set is drawn, resulting in two sets of ground lines. 

Query When activated, the user is prompted each time Draw is clicked. 
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Cross Section Navigator 

 
Two tabs on the dialog support the input data required to draw cross sections: 

XS Cells  Defines the location of cross sections utilizing either pattern by station or pattern by 
design.  In addition, the scale and spacing are defined on within this tab. 

Surfaces Define the surfaces utilized for drawing cross sections.  Note multiple surfaces may 
be drawn in a single processing.  Source data includes GEOPAK TIN files, Site 
Models, or Site Objects. 

 

On the XS Cells tab, the Pattern group box has three choices: 

Pattern by Station  Utilizes Begin and End Station values in addition to an Increment/Even option and 
Left and Right Offset fields to determine cross section location.  This works well 
when no sections are needed that are at odd stations, skewed or kinked relative to the 
Chain. 

Pattern by DGN  This method utilizes graphical representation and draws one cross section for each 
line or line string of the specified parameters.  Those parameters include Design File 
which is the name of the file that contains the lines and line strings in addition to their 
associated symbology. 

In Existing Only  No user input is required, as this option draws ground lines only for cross section cells 
which were previously drawn.  Therefore, no other pattern requirements are needed. 

 

CROSS SECTION NAVIGATOR 
The Cross Section Navigator is NOT accessible from Project Manager but can be invoked by selecting 
Applications > GEOPAK ROAD > Cross Sections > Navigator or by selecting it from the GEOPAK 
ROAD tool frame. 

The Cross Section Navigator tool is used to view and traverse between cross sections.  It can also be 
used to draw cross section information. 

 

The user can scan through the cross sections by either choosing the station from the drop down list, or 
by using the First Section, Previous Section, Next Section, or Last Section icons (arrowheads).  The 
Reset Navigator icon window centers the current station to the view.   

 

The Profile Elevation enables the user to define a Profile Name, and optionally, an Alternate Chain 
and Offset.  Once the dialog is populated, pressing the DP button in the upper right hand corner acts as 
a MicroStation data point in any MicroStation command where a data point is utilized. 

 

The Open View Control Dialog enables the user to open several windows to view different portions 
of the cross section at the same time.  The user can view the whole cross section in view 1, the left side 
in view 2, and the right side in view 3, etc. 

 

Cross section elements can be added or modified using MicroStation tools or GEOPAK cross section 
drawing tools, as detailed in the table below. 

DP Offset Elevation Data points at a given offset/elevation, or find the offset/elevation of the 
cursor location. 
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Summary - Basic Steps to Creating Existing Ground Cross Sections from a DTM 

 

 

 

DP Delta Distance 
Slope 

 

Draws a line at a given horizontal distance and slope.  

 

XS Active Angle Tool 

 

Sets the active angle to the given value.  If a MicroStation tool is used with 
the active angle option, this value is used. 

 

Draw XS Line  

 

Draws a cross section line.  The length and/or slope can be specified.  

 

SUMMARY - BASIC STEPS TO CREATING EXISTING GROUND CROSS SECTIONS FROM A DTM 
1. Requires a horizontal alignment stored in  *.GPK file. 

2. Requires an existing triangle file (TIN) from a DTM. 

3. Draw pattern lines. 

4. Process cross sections using Draw Cross Sections tool. 

5. Review and modify (if necessary). 
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Lab Exercise:   Existing Ground Cross Sections 

 
LAB EXERCISE:   EXISTING GROUND CROSS SECTIONS 

 Draw Patterns 

The first step is drawing MicroStation lines or line strings is to define the location of the existing 
ground cross sections.  

1. Open the MicroStation file c:\data\geo\sc219\sc219sh.dgn. 
2. Select Project Manager. 

3. Click Draw Pattern from the Road Project: SC219.prj workflow dialog. 

4. Create a new run called SC219R.  Open the run. 

 

5. Populate the dialog as depicted below.  

 

6. Double click the Level Symbology graphic. 

 

7.  Set the Level to RD_PD_PatLn1, then Color, Style and Weight to ByLevel.   

8. Click OK.  

9. Click Draw Pattern Lines. 

This initiates the plotting of the patterns into the design file.  Fit the MicroStation view if 
necessary to see the patterns. 

10. Close the Draw Pattern dialog and Save Settings. 
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Lab Exercise:   Existing Ground Cross Sections 

 
11. Delete the pattern lines on the +50 stations on tangents. 

Hint Attach the PP file with only the levels enabled that have the chain and station annotation. 

  Update Project Manager 

We are completing the Pattern section of the Working Alignment Definition in Project Manager. 

1. From the Workflow dialog of Project Manager, click Define. 

2. Highlight Pattern. 

3. Enter the Pattern information as depicted below.  

Since we are in the pattern file, you can use Match to accomplish this task rather than 
manually typing in the information. 

 

4. Right click the Placement graphic and select By Element. 

5. Identify a pattern line in the drawing and accept.  This will set the Placement symbology for 
any future pattern lines. 

6. Click OK to save the updates and close the dialog. 
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Lab Exercise:   Existing Ground Cross Sections 

 
 Generate Existing Ground Cross Sections 

1. Open the MicroStation file c:\data\geo\sc219\sc219dx.dgn.     
2. Click Existing Ground Cross Sections on the Project Manager dialog. 

3. Create a run called SC219R. 

4. Populate the dialog as shown below: 

  

Note Note:  The Display Settings are set in the GEOPAK Set Feature dialog.  The dialog is 
accessed by double clicking on the sample graphics boxes. 

 

Note Do not forget to click the Modify icon to update the preferences 

5. Enable the Elevation toggle and populate the text parameters as shown. 
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Lab Exercise:   Existing Ground Cross Sections 

 

 

Note Do not forget to click the Modify icon to update the preferences 

6. Generate the existing ground cross-sections by clicking Draw. 

7.  Exit the Draw Cross Sections dialog and Save Settings. 

 

 Review Cross Sections 

1. Select the Cross Section Navigator tool (Road: Cross Sections > Navigator.)   

 

2. Browse and check your existing cross sections.  

3. Exit the XS Navigator dialog when done.  

Upon reviewing the sections, it is desirable to “lock” the elements to prevent accidental 
deletion or modification in later steps.   

4. Select Edit > Select All from the MicroStation menu bar.   

5. Then select Edit > Lock to lock the elements. 

6. Clear the selection set. 

 Update Project Manager 

We are completing the Pattern, Cross Section and Existing Ground sections of the Working Alignment 
Definition in Project Manager. 

1. Click Define from the road flow chart. 

2. Highlight Cross Section View. 



Lab Exercise:   Existing Ground Cross Sections 

 

 

3. Click File and select SC219dx.dgn. 

4. Highlight Existing Ground and populate the dialog as depicted below.  

  

Since we are in the cross section file, you can use Match to accomplish this task rather than 
manually typing in the information. 

5. Right click the Placement graphic. 

6. Identify a cross section ground line in the drawing and accept.  This will set the Placement 
symbology for any cross section lines. 

7. Click OK on the Working Alignment Definition dialog to save the updates and close the 
dialog. 

8. Exit MicroStation. 
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11 
CHAPTER OBJECTIVES 

In this chapter, you will learn to use GEOPAK Automated Superelevation dialog and Autoshape 
Builder to apply superelevation to a roadway. 

INTRODUCTION 
GEOPAK supports a myriad of options for the definition of pavement on proposed cross sections.  
They range from a single slope specification emanating from a baseline / profile on each section, to a 
complicated multiple roadways, each with its own superelevation transitions. 

The most basic is the project where no superelevation transitions are required, i.e., the roadway slope 
for all pavement (if any) can be specified as a single value.  In this case, the slope can be defined with 
the proposed cross section processing and any additional superelevation work is not required.  This 
process will be utilized in Exercise 12 when we have GEOPAK draw the existing shoulder and 
pavement on the sections – shapeless. 

Another option is the definition of superelevation when roadways are constant widths without tapers, 
i.e., turn lanes, acceleration and deceleration lanes, etc.  In these areas, the automated superelevation 
can be utilized, based on a user-defined design speed and considering the geometry of the specified 
roadway.  After careful review of the data (in ASCII format) and overriding the computed values, 
GEOPAK draws pavement representations as complex shapes into a MicroStation 2D design file. 

A third option is the definition of superelevation when roadways are not constant widths, i.e., gore 
areas, turn lanes, acceleration and deceleration lanes, etc.  In these areas, graphics elements within a 
MicroStation 2D design file are utilized to create complex shapes which define the superelevation 
transitions. 

A combination of these tools can be combined with a project, or even within a single roadway.  The 
shapeless mode is excellent for rural applications, low volume city streets, frontage roads, etc., while 
the automated method quickly generates automated shapes for more complex roadways.  Any area 
which cannot be defined via the automated method can be augmented by the graphical method.  
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Accessing Automated Superelevation (AutoShape Input File Maker) 

 
ACCESSING AUTOMATED SUPERELEVATION (AUTOSHAPE INPUT FILE MAKER) 

The Automated Superelevation tool can be accessed by selecting Applications > GEOPAK ROAD > 
Cross Sections > Superelevation Shape Manager Tools.  It can also be invoked from Project Manager 
by clicking the Calculate Superelevation button or by selecting the Automated Superelevation icon 
from the GEOPAK ROAD tool frame. 

The GEOPAK Superelevation package enables the user to create, edit, and run an autoshape input file 
quickly, basing it on an existing COGO alignment. 

A rich set of preferences is available which gives the user complete control over every aspect of the 
standardization of the superelevation design process.  AASHTO Method V is available as a default, 
along with the ability to employ user-defined lookup tables both for e (superelevation rate) and for 
runoff length.  User-defined equations may also be entered to compute these values.  A thorough set of 
options is available for resolving the superelevation conflicts of Reverse Curves, Compound Curves, 
Broken Back Curves, and Short Curves.  

GEOPAK calculates superelevation 
transition locations for any alignment 
stored into the coordinate geometry 
database.  The main superelevation 
dialog is simple and straightforward, 
allowing the user to select which 
preference file is to be used for the 
current session, as well as enabling the 
entry of the typical section lane 
configuration in the simple engineering 
terms of Number of Lanes, Lane 
Widths, Median Width (if any), and 
Cross Slope.  More complex lane 
configurations may be represented as 
needed. 
Upon computation of the superelevation 
parameters (cross slopes and 
stationing), the information is stored in 
an ASCII file, where the user may 
review and modify the transitions, if 
desired.  After reviewing the 
information, the ASCII file is executed 
from the Autoshape Builder to generate 
superelevation shapes. 
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Accessing Automated Superelevation (AutoShape Input File Maker) 

 
 

Job Coordinate geometry database containing the desired chains and profiles. 

Chain GEOPAK baseline chain dictating the horizontal geometry for which 
superelevation transitions are calculated.  This chain is also called the Shape 
Cluster Baseline in the Auto Shape input file.   

Begin Station When the chain is defined, GEOPAK populates the Begin Station with the 
default beginning of the chain.  To compute superelevation for part of a chain, 
adjust the station.  

End Station When the chain is defined, GEOPAK populates the End Station with the 
default beginning of the chain.  To compute superelevation for part of a chain, 
adjust the station.  

Design Speed Design speed that determines what Design Speed is to be used either in the 
tables or equations for e and length computations. 

Preference File 
   e selection 
   L selection 

The Preferences File combo box selects which Preference File is to be used 
for this computation.  The various Preferences Files which are available in the 
combo box are determined by what files have the .sep file extension in the 
Preference Files Path on the User Directories dialog.  When it is set, the 
available e and length Selection combo boxes are filled in according to the 
csv file names as specified in the Preferences File.  Those combo boxes 
determine which table within the .csv file will be used for computation. 

Facility Facility determines whether the roadway cross section is to be divided or 
undivided.  This option determines two things.  For the dialog box, it 
determines whether or not the values Profile, Tie (Offset or PGL), and or the 
Tie or PGL values may be different.  If they are different then two shape 
clusters are to be generated, which usually is required for a median.  The state 
of the Facility option button also determines which Preference is used as 
found on the Distribution tab of the Preferences dialog.   

Left / Right tabs The area enclosed in the Left / Right tabs are for the determination of values 
specific to shape clusters.    
NOTE: The right and left tabs contain data pertaining to each lane within 
each roadway.  If the Facility is undivided, then the left tab is for the left 
lane(s) while the right tab is for the right lane(s).  If the Facility is divided, 
then the right tab is for the entire right roadway, while the left tab is for the 
left roadway.   

Create Input File ASCII file wherein GEOPAK creates the autoshape input file.  DO NOT 
include the extension, as GEOPAK adds .inp to the field.  

Generate 
Superelevation 
Transitions 

Commence automatic superelevation calculations 

Profile  GEOPAK profile defined as the Shape Cluster Profile in the Auto Shape 
input file.   

Tie Offset - Horizontal distance from the Profile (PGL) to the Chain.  
PGL Chain - Chain stored in the gpk file that the shapes will be computed 
from. This chain does not require a profile be stored with it as the defined 
profile will be applied to this chain. 

Offsets Offsets define the dimension of the shape (usually a lane) by two offset 
distances from the baseline.  Note that tapers are not supported.  Offset 
distances are negative if measured to the left.  .  Each lane must have the 
same offset on the left as the left adjacent lane and must have the same offset 
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Accessing Automated Superelevation (AutoShape Input File Maker) 

 
on the right as the right adjacent lane (no gaps in offsets).  Computation may 
not proceed if this condition is not met. 

% Slope Cross slope of each shape in normal crown in percent format.  A negative 
sign denotes the roadway going downward, while emanating away from the 
PGL.  A Normal Crown section of 2.0% would, therefore, be entered as –2.0.  
Lane offset values are entered in terms of master units, i.e., feet or meters. 

Dependent / 
Independent 

One dependent shape, which is based on the profile, is required for each 
cluster.  Other shapes are drawn not based on the profile, but on adjoining 
lanes, and are independent.  For example, turn lanes are drawn abutting next 
to the mainline roadway, so they are independent.  However, a lane based on 
the profile for its initial elevation, such as one of the through lanes, is profile 
dependent. 

Edit buttons: 
Add 
Delete 
Modify 

Add – populate the fields and click Add. 
  To delete a line, highlight the desired line, then click the Delete.  To modify 
a line, highlight the desired line, click once on the value to be modified.  The 
value will be placed in an edit mode.  Change the value then hit enter or tab 
out of the field. 

Quick Entry 
(second to bottom 
tool to the right of 
the list box) 

 

Enables the user to populate the shape cluster list boxes quickly while 
entering the data using engineering terminology.   

 

Rectify Lanes 
(bottom tool to the right of the list 
box) 

 

If Offset values have been entered that create a gap between 
lanes, the Rectify Lanes option removes this gap.  Click 
Rectify Lanes and the values will be modified so that any 
gaps are removed. 

Selection of the Generate Superelevation Transitions button performs the actual superelevation computations.  Three 
things happen at this point.   
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• First, the superelevation 

transitions as computed by 
GEOPAK are written to the 
Autoshape Input File 
specified by the user (in the 
Create Input File field).   

• Second, the log file is 
written.   

• Finally, the Autoshape 
Input File is loaded into the 
text editor running within 
MicroStation.  This 
Autoshape Input File Editor 
has an icon at the top that 
allows the Autoshape Input 
File to be run.  Autoshape 
Input files can also be run 
from the Autoshape 
Builder. 

 

 

EXAMPLE - AUTO SHAPE ASCII INPUT FILE 
/* Superelevation Settings and Parameters: 
  
Project Name:  C:\data\geo\SC219\SC219.prj 
User:          C:\data\geo\SC219\projdbs\john 
Run Name:      SC219R 
Unit System is english. 
Created input file "sc219r_shapes.inp". 
Created activity log file "sc219r_shapes.log". 
Created on Fri, Dec 08, 2006 at 12:54. 
Using Preference File "scdot_e" 
Using e Selection of "6% e max". 
Using Length Selection of "Equation" 
Using Design Speed of 45.000000. 
  
*/ 
  
auto shape 
job number = 839 
  
   auto shape set 
      shape cluster baseline   = SC219R 
      shape cluster profile    = SC219RFP 
      shape cluster tie        = 0.0000 
      dependent shape 
      chain  /  offset 
         SC219R     -31.5000 
         SC219R     0.0000 
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Example - Auto Shape ASCII Input File 

 
      filler line station / slope 
         87+25.490000      -2.0800 
         104+36.557143      -2.0800 
         104+94.200000      -4.4800     /* Curve SC219R-2 */ 
         109+43.300000      -4.4800     /* Curve SC219R-2 */ 
         110+00.942857      -2.0800 
         129+48.300000      -2.0800 
         132+11.100000      0.0000 
         132+83.400000      3.0100     /* Curve SC219R-4 */ 
         139+93.300000      3.0100     /* Curve SC219R-4 */ 
         140+17.457250      2.0043 
  
   auto shape set 
      shape cluster baseline   = SC219R 
      shape cluster profile    = SC219RFP 
      shape cluster tie        = 0.0000 
      dependent shape 
      chain  /  offset 
         SC219R     0.0000 
         SC219R     31.5000 
      filler line station / slope 
         87+25.490000      -2.0800 
         101+24.100000      -2.0800 
         103+86.600000      0.0000 
         104+94.200000      4.4800     /* Curve SC219R-2 */ 
         109+43.300000      4.4800     /* Curve SC219R-2 */ 
         110+50.900000      0.0000 
         113+13.400000      -2.0800 
         132+61.061462      -2.0800 
         132+83.400000      -3.0100     /* Curve SC219R-4 */ 
         139+93.300000      -3.0100     /* Curve SC219R-4 */ 
         140+15.638538      -2.0800 
         140+17.457250      -2.0800 
  
   Plot Parameters 
      Dependent Shape 
         lvname = Default 
         co = 6 
         lc = 0 
         wt = 2 
      Dependent Text 
      lvname = Default 
      co = 6 
   Independent Shape 
      lvname = Default 
      co = 1 
      lc = 0 
      wt = 2 
   Independent Text 
      lvname = Default 
      co = 1 
  
Write shapes into dgn = C:\data\geo\SC219\sc219sh.dgn 
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Draw Shapes into Plan View File 

 
DRAW SHAPES INTO PLAN VIEW FILE 

The Autoshape Builder is NOT accessible from Project Manager but can be invoked by selecting 
Applications > GEOPAK ROAD > Cross Sections > Superelevation Shape Manager Tools or by 
selecting it from the GEOPAK ROAD tool frame. 

Once the shape input file (fname.inp) has been created and reviewed, the designer can run the input file 
to place the superelevation shapes into the specified graphics file.  To use the interactive method to 
define roadway superelevation (in a .dgn file) the designer selects the Autoshape Builder  from the 
Superelevation Shape Manager Tools tool bar (or alternately from this same tool within the Text Editor 
as described above).  

 

Autoshape Input 
File  

Name of .inp file (shapes.inp) created by the Automated superelevation 
generation containing the transitions. 

Display Only  Create the shapes in “Display Only” mode.  That is, they are not written to the 
design file and a view Update operation eliminates them, as does zoom in, etc. 

Override Input 
File Level 
Symbology 

This option is used to override the Plot Parameters settings in the Superelevation 
Shapes input file. 

The shapes are placed in a 2D graphics file on level 63 by default.  The plot parameters can be 
modified in the input file with a text editor prior to building the shapes into the graphics file or with the 
User > Symbologies pull down on the Automated Superelevation dialog. 
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Superelevation Shape Manager Tools 

 
SUPERELEVATION SHAPE MANAGER TOOLS 

The Superelevation Shape Manager Tools can be invoked by selecting Applications > GEOPAK 
ROAD > Cross Sections > Superelevation Shape Manager Tools or by selecting it from the GEOPAK 
ROAD tool frame. 

The tools in the Superelevation Shape Manager Tools toolbox are detailed below. 

 
Automated Superelevation - performs the actual calculations and stores the results in 
an ASCII file, known as the autoshape input file. 

 
Autoshape Builder - processes the autoshape input file and draws corresponding 
complex shapes in the specified 2D design file. 

 
Shape Maker - graphical method of drawing irregular superelevation shapes.  This 
method is utilized for gore areas, turn lanes, etc. 

 
Shape Analyst - provides information on any point within a GEOPAK superelevation 
shape. 

 
Shape Profiler - provides profile information based on user-define increments 
intersecting a GEOPAK superelevation shape. 

 
Shape Editor - dynamically change parameters on a previously created shape.  This 
includes filler line stationing, dynamic moving of shapes, etc. 

 
Shape Selector - highlights or selects shapes based on a wide range of user queries or 
filters. 

 

Shape Properties - provides information on any GEOPAK superelevation shape.  In 
addition, this shape information can be modified on individual shapes of selections of 
shapes. 

 

Shape to DTM - provides the option to store a DTM Dat file from the superelevation 
shapes. In addition, it can plot the calculated elevations into the design file at a user 
specified interval. 
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SHAPE ANALYST 

The Shape Analyst tool is extremely useful, as it provides information on any point within a GEOPAK 
superelevation shape. 

 

Before using this tool, the Job Number must be selected.  Upon selecting a Job Number, a Chain must 
be selected that the shapes are defined relative to.  If Display Only is enabled, information like 
elevation and a flow arrow are drawn to the view, but they are not written as elements to the active 
MicroStation file. 

When the Cross Section toggle is not activated and a data point is issued within a shape, the elevation 
of the data point and a flow arrow are displayed.  When the toggle is activated, a dashed line is placed 
through the data point, radial to the shaped cluster baseline.  In addition to the elevation and flow 
arrow placed at the data point, elevations are displayed where the cross section line intersects any 
superelevation shape and cross slopes are labeled for each shape. 

The By Sta/Offset button causes the current Station / Offset value to be projected back onto the shape 
cluster baseline and the elevation of the projected point is displayed.  This option can be manual entry 
only and requires no data point on the screen. 

The DP button works within a superelevation shape whose X, Y coordinates are utilized to compute 
station / offset from the specified shape cluster baseline, which is subsequently utilized in conjunction 
with the shape to compute the various slopes and elevations.  After the DP button is clicked, numerous 
data points can be placed.  It is not necessary to click the DP button again.  Each corresponding station 
/ offset is displayed along with the associated output information. 

The Dynamic button activates the dynamic mode.  As the cursor moves across the screen, any 
momentary pause places the elevation and flow arrow in the MicroStation file and computes and 
displays the analysis information. 

The Extrapolate Fixed Slope toggle is another option supported in the Shape Analyst tool.  The option 
is utilized when the data point, dynamic point or station / offset is outside of the shape.  When the 
option is not activated, the data point is projected back to the shape's chain.  The elevations at the 
edges of the shape are displayed and the slope of the outside shape is projected to the data point.  
When the toggle is enabled, the user defined slope is projected from the outer most shape to the data 
point to determine an elevation. 
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SHAPE PROFILER 

The Shape Profiler tool computes elevations along any GEOPAK Shape or MicroStation element at a 
user specified interval.  The element can be inside or outside of the shapes. 

 

The Job field can be populated by key in or using the Select… button.  After selecting a GPK file, click 
Identify Shape and data point on any shape along the desired Chain.  Set the From Station and To 
Station fields by keying in values or using DP. 

Even should be selected when it is desired to have the elevations compute at the even station values.  
Increment will allow the elevations to be computed starting at the From Station, then adding the 
increment value to that station.  Intersect is used with an element to compute elevations at all locations 
that the element intersects the shape(s). 

The Elevation Along toggle can be set to Shape or Element.  When set to Shape, elevations will be 
computed based on the Even/Increment value along both longitudinal edges of the shape.  When set to 
Element the elevations are computed along the element based on the Even/Increment/Intersect toggle. 

Continuous Extrapolation allows the user to identify multiple longitudinal elements outside of the 
shape area and compute elevations by a user defined Slope and one of three methods:  Radial to 
Baseline, Radial From Element, or Radial to Element. 
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LAB EXERCISE:   SUPERELEVATION 

 Compute Automated Superelevation 

Since our project consists of a single pavement configuration (4 lane undivided) we’ll create a single 
run to process the automated superelevation data. 

1. Open the MicroStation file c:\data\geo\road1\sc219sh.dgn. 

2. Access Project Manager.   

It should automatically access the Road workflow dialog since we “remembered” the options 
in Lab 2. 

3. Click Calculate Superelevation. 

4. Create a new run called SC219R and click OK. 

5. Select File > Level Symbology.  Set the level for the Dependent and Independent shapes to 
RD_PD_SuperShp1.  Close this window. 

 

6. For the upper portion of the dialog, complete as follows: 

Job Automatically set to Job 839 via Project Manager Define Settings 
Chain SC219R 
Begin Station 145+00 
End Station 219+00 
Design Speed 45 
Preference File scdot_e 
e Selection 6% e max 
Facility Undivided 
L Selection Equation 
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7. Set the profile to SC219RFP.  

All shapes are computed from this profile. 

8. Set the Tie to Offset and the offset value to 0.0.  

9. Click Quick Entry on the lower right side of the 
Left tab.   

10. Populate the resulting dialog as shown. 

11. Click OK.  

12. Review the Left and Right tabs to ensure they look like the dialog below. 

  

13. Disable the Dependant check mark for the shape on the right side. 

14. Enter the Create Input File as sc219r_shapes.inp.   

This file stores the computed transitions for this station range. 

15. Click Generate Superelevation Transitions. 

This initiates the calculation of the transitions for the Left and Right roadway. 
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 Review Computations and Draw Shapes 

1. Review the computations within the Text Editor dialog. 

 

2. Compare the computed stations and slopes with the stations and slopes in the SC219C3.PDF 
file.  Modify the input file as necessary to match the PDF’s stations for full super. 

3. Save the updates to the input file. 

4. Click Create Superelevation Shapes within the Text Editor dialog.   

This tool draws the shapes into your design file. 

3. Close the Text Editor dialog. 

4. Close the Automated Superelevation dialog.   

5. When prompted to Save Superelevation settings, click Yes. 

 

 Shape Manager Tools 

Let’s review the graphical shapes before we continue on to proposed cross sections. 

1. To access the Superelevation Shape Manager tools, select the Superelevation Shape 
Manager Tool application  from the Cross Section tool frame, or select Applications > 
GEOPAK Road > Cross Sections > Superelevation Shape Manager Tools from the 
MicroStation Menu Bar. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 11-14 

Lab Exercise:   Superelevation 

 
2. Select the Shape Analyst tool. 

 

3. Enter Job 839 and Chain SC219R to complete the required definitions. 

4. Click DP and data point within a graphical shape. 

5. Review the information in the dialog.   

Your dialog information varies from the dialog above based on the data point selection. 

6. Close the Shape Analyst dialog. 

Note Many user defined preferences are available to display information reflected by the graphical 
shape. These preferences may be set via the Shape Analyst dialog by selecting User > 
Preferences. 
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 Update Project Manager 

We are completing the Plan View of the Working Alignment Definition in Project Manager. 

1. From the Workflow dialog of Project Manager, click the Define button. 

2. Highlight the Plan View > Shapes option and populate the Shapes Design file as shown 
below: 

 

3. Click OK to save the updates and close the dialog. 

 Clean EOP Elements 

1. Attach the file sc219pp.dgn as a reference. 

Note Use Coincident World as the method of attachement. 

2. Turn off all levels in the reference except for RD_EX_Road level. 

3. Turn off all levels in the active file. 

4. Copy the EOP elements to the active file. 

5. Turn off the reference file display. 

6. Turn on the level containing the pattern lines. 

7. Modify the existing EOP lines as necessary such that the pattern line only crosses the EOP 
twice. 

 



Lab Exercise:   Superelevation 
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12 
CHAPTER OBJECTIVES 

In this chapter, you will use Project Manager to create proposed cross-sections. 

INTRODUCTION 

When the Proposed Cross Sections button in the Road Project Manager is clicked, the Select Run 
dialog is displayed.  An existing run may be selected or new run may be started.  When complete, click 
the OK, which closes the Select Run dialog and opens the proposed cross sections dialog.   

Note This dialog cannot be accessed outside of the Project Manager. 

The left side of the dialog contains 
the list of categories required to 
process proposed cross sections.  
When each category is selected, 
the dialog changes to reflect the 
requirement of each category.  For 
example, when Plot Parameters is 
selected, the dialog changes to 
reflect the various plot parameters 
and text as depicted on the 
following diagram.  
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Introduction 

 
When XS DGN File is selected from the list box, the dialog dynamically changes as depicted below.  
XS DGN File defines the MicroStation file wherein the original ground cross sections are located as 
well as the location for the proposed cross sections. 

 

When Pattern is selected, the dialog changes as illustrated below. 

 

Three dialogs (Pattern, Existing Ground, and Shapes) support a toggle to Use Working Alignment 
Definition.  For example, in the Pattern dialog, if the toggle is not active, the user must supply all 
pattern information.  
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Introduction 

 

 

However, if the toggle is active when one of these three categories is selected, the data information 
part of the dialog is ghosted and the required information is utilized from the current working 
alignment definitions.  If the toggle is activated, and the required information is not stored within the 
current working alignment, an Alert message is displayed.  
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When the Shapes parameter is selected, the dialog is displayed as depicted below. 

 

Three Shape definition options are supported: 

All in DGN  All shape elements within the specified file are utilized. 

By Search Criteria  Only those shapes that match the specified search parameters are utilized. 
Shapeless No shapes are utilized, hence, there is no field for a shapes file name or files button. 

This option will be used with the first exercise to produce existing shoulders and 
pavement on the existing cross sections. 

When the Shape Clusters parameter is selected, the dialog dynamically changes as depicted below 
(there should not be any definitions within the dialog upon the initial invoking of this parameter): 

 

The user may Add, Delete, or Modify any specified shape cluster.  When the Scan button is clicked, 
GEOPAK scans the design file and search criteria specified in the Shapes dialog and lists all matching 
clusters.  In the instance of shapeless criteria, the user must define each cluster by utilizing the Select 
button or typing in the Chain, Tie/PGL and Profile associated with this shape; then click the Add 
button. 
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Introduction 

 

 

After a cluster has been defined and highlighted, the Thick button in the upper right corner is 
unghosted.  This invokes a separate dialog to assign different pavement thicknesses and different 
symbology to different roadways.   

For example, in the dialog below, you can see we’ve assigned a pavement thickness to the Roadway 
defined by Chain Mainline.  After the information has been defined, simply close the Pavement 
Thickness Plot Parameters dialog, as it does not need to be open in order to process. 
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Introduction 

 
The Side Slope Conditions need to be set up for each shape cluster.  To define a side slope condition, 
highlight the desired shape cluster then click the Define button.  The dialog below opens.  

 

The user can choose Side Slope LT, Side Slope RT, Side Slope LT/RT or Offset Minus/Plus Side 
Slope LT/RT.  Certain conditions such as Station > 50+00, or Median Width <= 7.2 can be set up to 
apply the side slope information if those conditions are met. 

For each Side Slope condition, criteria files are added based upon the type of features to be drawn in 
the cross sections.   

 

The Define DGN Variables option allows the user to define how to locate MicroStation elements used 
by the criteria files.  Define DGN Variables can be determined from the element symbology, or from 
the symbology and attributes assigned in the D&C Manager database.  Variables that are previously 
defined in the criteria will show up in the list.  If the Select button is unghosted, variables remain 
undefined and must be defined before processing the sections.  Click Select to see a list of undefined 
variables assign a value, then click Add. 
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Introduction 

 

 

Define Variables enable the user to enter job specific values for certain variables.  (i.e. pavement 
thickness, ditch width, backslope, etc.)  The user can select the variable from the list, then enter the 
new value and click the Modify button. 

 

Plot Parameters enables the user to determine how the data from the superelevation shapes are going 
to appear.  XS Lines determine the symbology of the pavement surface.  Text plots various pieces of 
text relating to the cross section.  The elevation of the PGL of each shape cluster is automatically 
plotted.  Enable the Line Text toggle to define this symbology for the PGL text.  The Plot group box 
enables the user to control different aspects relating to the cross sections and criteria files as detailed 
below. 

Pavement Thickness draws the bottom of shaped pavement for all clusters.  If the Thick button was 
utilized in the shape clusters dialog, this should be disabled. 

Fill Gaps Between Clusters draws a line between two shape clusters if the criteria does not fill 
between them. 

Transition Definition defines the use of parabolic superelevation transitions.   

Intersect Between Clusters extends or trims elements in a median to create a finished, clean 
appearance. 
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Process Clusters as Indicated forces the criteria to process the clusters as they are listed in the Shape 
Clusters dialog.  If this option is turned off, the clusters are processed left to right. 

Remove Skew Effect forces GEOPAK to correct itself back to the pattern line if a skewed element is 
encountered in the processing of the criteria files. 

Process Only Sections With Existing Ground - If only one group (color) is indicated in the input file 
for the existing ground in each run, the program loads into memory only the ground lines of the 
specified color, and processes only those sections.  The time reduction may vary depending on the 
specific conditions of the job and type of machine. 

FILES 
Under Files, the options are Run, Save Settings, Export... and Exit.  To process 
the cross sections, click the Run button, which invokes the Process Cross Section 
dialog.  Save Settings simply saves the current settings to the run.  When the File 
> Export option is selected, the user may save the dialog information in an 
ASCII input file for review or subsequent processing.  The File > Exit option 
enables the user to exit the Proposed Cross Sections dialog box.  The software 
also prompts the user with an Alert box if the settings should be saved before 
exiting.  Clicking the Yes button saves the current dialog settings, No does not 
save the settings, but both buttons exit to the Project Manager. 

 

PROCESSING 
When File > Run is chosen, the dialog below appears. 

 

The output can be displayed on the Screen Only, or written to a Log File and displayed to the screen.  
The Pause On Each Section option enables the user to view each section as it is drawn.  Criteria 
View displays each step in the criteria file.  This is primarily for debugging purposes. 

CRITERIA FILES 
One of the most powerful and flexible features of GEOPAK is the use of criteria in generating 
proposed cross sections.  Within criteria, design conditions can be evaluated and complicated design 
decisions executed in response to these design conditions.  The flexibility of criteria allows the 
designer to make the design as basic or as complex as the project requires.  Numerous baselines can 
interrelate as ditches and medians are drawn between roadways and ramps. Sophisticated drainage 
details can also be drawn with criteria.  The list is endless. 

Cross section criteria are used to draw cross section features outside of the mosaic of superelevation 
shapes typically representing pavement.  Operationally, the software constructs the cross section 
features derived from the mosaic of shapes first.  Then, the software constructs the remaining portions 
of the cross section through the application of criteria emanating out from the outer edges of the 
mosaic of shapes.  
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TYPICAL SECTION GENERATOR 

Note the button labeled Typical.  

 

This application enables the designer to apply specific criteria files from a standardized library to 
specific typical sections, thereby foregoing the need to pick and choose which criteria files they need.  
They simply select the typical section(s) for their project and the criteria files are retrieved for them 
automatically from the library. 

When the Typical button is pressed, the Typical Section Generator dialog appears as depicted below. 

 

The user must simply select the typical section from the left then click Apply.  For a divided roadway 
with a left and right Profile Grade Line, the user would apply the selected typical once to the left 
roadway and then once again to the right roadway. You can also apply the typical to the entire length 
of the alignment or only a portion of the alignment by changing the Apply to Whole Chain toggle to 
Apply to Station Range and specifying a beginning and ending station for the typical. 
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Documentation files are available for each typical section that explains what the typical does and 
identifies variables that need to be set.  The files are accessed from within the Typical dialog by 
pressing the Description button.  Below is a sample of one of the documentation files. 

 

When the Apply button is pressed, the Typical Sections dialog closes, returning the user to the Project 
Manager - Shape Cluster dialog.  GEOPAK has inserted the Side Slope LT and RT and appropriate 
criteria, as depicted in the dialog below. 
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LAB EXERCISE:   PROPOSED CROSS SECTIONS 

This exercise consists of two distinct steps.  This first step will draw existing features on our existing 
sections.  The second step will draw the proposed cross sections. 

 Drawing Existing Features onto Cross Sections 

1. Open the MicroStation file c:\data\geo\road1\sc219dx.dgn     

2. Invoke Project Manager.   

It should automatically access the Road workflow dialog since we “remembered” the options 
in Lab 2. 

3. Choose Proposed Cross Sections from the Project Manager dialog and create a run called 
ex_pave. Then double-click on ex_pave. 

 

4. Complete the following items in the dialog. 

XS DGN File This filename should be automatically defined as sc219dx.dgn. 
 Set the tolerance to 0.1 

Pattern Use Working Alignment Definition 
Existing Ground Use Working Alignment Definition 
Shapes Set the Shape Option to Shapeless. 
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5. Next, select the Shape Clusters category to invoke the following dialog. 

 

6. Define the Chain, Tie and Profile for the shapes. 

Select the Chain, Profile and Tie shown above. 
7. Click Add to add the chain, profile and tie to the shape cluster list. 

8. Click Typical.  Click OK if you are prompted with the following dialog. 

 

9. Select the typical No. 83 – Draw EX. SUBBASE SHAPELESS. 
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10. Click Apply to use this typical for all cross sections. 

11. Select the Define DGN Variables category from the Proposed Cross Section dialog list box 
to invoke the following dialog. 

 

 Modify the variable existing edge of pavement as shown. 
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Note This tool scans all of the criteria files for the Define DGN Variables and allows you to define 

them for each proposed cross section run. 

12. Select the Plot Parameters category.  DO NOT change any of the symbology settings for XS 
Lines or Text.  Toggle off all the options in the Plot section.  The dialog should appear as 
below. 

 

At this point we are ready to process the proposed design sections for the chain SC219R. 

13. From the Proposed Cross Sections dialog, select File > Save Settings, then File > Run. 

14. The following dialog is invoked.  You may define where you want to see the computed cross 
section information, in an output file or on the screen only. 

 

15. Select To Screen.  Activate the Pause on Each Section toggle to view the first design section 
once it has been drawn.  Click Apply. 

 

Note When errors occur, change the To Screen to To Log File then click Apply to generate the log 
file. Use the GEOPAK Editor to open the log file to determine the problem 
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The error usually occurs at the end of the file. However, the error may be in the line(s) prior 
the error message. 

16. When processing is complete, click Exit to return to the Process Cross Sections dialog. 

17. Dismiss the Proposed Cross Sections dialog by clicking the “X” in the upper right of the 
dialog or by using the Files > Exit pulldown. 

18. When prompted to Save Settings, click Yes. 

19. Use Cross Section Navigator to review the existing shoulder and base as drawn. 

20. Upon reviewing the sections, it is desirable to “lock” the elements to prevent accidental 
deletion or modification in later steps.  Select Edit > Select All from the MicroStation menu 
bar.  Then select Edit > Lock to lock the elements. 
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 Proposed Finished Grade Cross Sections 

In this set of steps, a new run will be created and used to generate the proposed cross sections. 

1. Choose Proposed Cross Sections from the Project Manager dialog and create a run called 
SC219R. Then double-click on SC219R and the following dialog will appear. 

 
2. Complete the following items in the dialog. 

XS DGN File This filename should be automatically defined as 
sc219dx.dgn 
Set the tolerance to 0.01 

Pattern Use Working Alignment Definition 
Existing Ground Use Working Alignment Definition 
Shapes Use Working Alignment Definition 

3. Click Shape Clusters to define shape clusters, side slope conditions and criteria files. 

4. Click the Scan button to have the software scan the sc219dx.dgn file for all of the shape 
clusters.  The dialog below should appear. 

 

5. Double click the SC219R chain then close the List of Clusters dialog. 
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6. On the Proposed Cross Sections dialog, click Add to add the SC219R chain to the shape 

cluster window.  The dialog should appear as below. 

 
7. Select the shape cluster in the list. 

8. To define the Side Slope (areas outside of the pavement limits) conditions simply highlight 
the shape cluster that was just defined in the list box then click the Typical button. 

9. Select typical No. 05 – RURAL_URBAN UNDIVIDED.  Click *Apply to use this typical 
for all sections to be processed. 

10. Select the Define DGN Variables category from the Proposed Cross Section dialog list box 
to invoke the following dialog. 

 

Note This tool scans all of the criteria files for the Define DGN Variables and allows you to define 
them for each proposed cross section run. 

11. You should notice that the DGN filename for each variable is set to ****.dgn.  This will need 
to be modified for all variables in order for the criteria to find these DGN elements during the 
run.  Click the Select Variable DGN Name button next to the DGN File field.  Select 
C:\data\geo\SC219\sc219proposed.dgn then click Modify.  Use this design file for the first 
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four variables.  Fro the last variable, set this to the C:\data\geo\SC219\sc219sh.dgn file. After 
all variables have been modified, the dialog should appear as below. 

 
12. Select Define Variables.   The dialog should appear as below.  The variables should be 

correct. 

 
13. Select the Plot Parameters category.  Double click the sample graphics box next to Cross 

Section Lines.  Set the symbology as below then click OK. 
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Lab Exercise:   Proposed Cross Sections 

 

 

14. Toggle on Line Text.  Double click the sample graphics box next to Line Text.  Set the 
symbology as below then click OK. 

 

15. Toggle off all the options in the Plot section.  The dialog should now appear as below. 

 
16. From the Proposed Cross Sections dialog, select File > Save Settings, then File > Run. 

17. The following dialog is invoked.  You may define where you want to see the computed cross 
section information, in an output file or on the screen only. 



Lab Exercise:   Proposed Cross Sections 

 

 

18. Select To Screen.  Activate the Pause on Each Section toggle to view the first design section 
once it has been drawn.  Click Apply. 

 

Note When errors occur, change the To Screen to To Log File then click Apply to generate the log 
file. Use the GEOPAK Editor to open the log file to determine the problem 

 
The error usually occurs at the end of the file. However, the error may be in the line(s) prior 
the error message. 

19. When processing is complete, click Exit to return to the Process Cross Sections dialog. 

20. Dismiss the Proposed Cross Sections dialog by clicking the “X” in the upper right of the 
dialog or by using the Files > Exit pulldown. 

21. When prompted to Save Settings, click Yes. 

22. Use Cross Section Navigator to review the proposed cross sections. 

 Working Alignment 

Now that we have the information for our proposed cross sections, we need to update our Working 
Alignment Definition in Project Manager. 

1. From the Workflow dialog of Project Manager, click the Define button. 

2. Highlight the Proposed Finish Grade category.   

3. Enable the Lv Names toggle, then click Match to identify and accept all lines comprising the 
proposed finished grade.  Use the Display/Undisplay button to toggle the elements between 
the highlight color and their original color. 

3. Click OK to save your changes and exit the dialog. 

4. Exit MicroStation. 
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13 
CHAPTER OBJECTIVES 

In this chapter, you will learn how to utilize the Port Viewer. 

INTRODUCTION 
The Port Viewer is a tool that enables the user to view and manipulate all three major aspects of a 
road design simultaneously, even though they are located in different files.  The Port Viewer tool is 
only available while working within the Project Manager application. These applicable views for 
design display include: 

• Plan view layout 
• Profile 
• Cross sections 
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ACCESSING THE PORT VIEWER 

Prior to starting the Port Viewer the working alignment must be set up to include the plan view 
drawing file, centerline chain, profile name and location (optional), cross-section view file(optional), 
and digital terrain model information(optional).. 

To access the Port Viewer tool, click the Port Viewer button on the Project Manager workflow dialog.  
Note this is the only location from which the Port View can be accessed, as there is no GEOPAK Road 
tool supported for it. 

PORT VIEWER DIALOG SETTINGS 

 

The Port Viewer dialog box allows the user to manipulate the design views in several different ways. 

STATION SETTINGS 
The user is able to manually enter the chain station that they want to view the plan, profile or cross 
section design file.  The cross hairs in the plan and profile views will move to the active station, and 
the section view will display the cross-section nearest that station. 

TRAVERSE BUTTONS 
The “VCR” buttons (forward and backward arrowheads) allow the user to navigate station by station 
(>,<), or to the beginning or ending station (<<,>>). 

OFFSET CONTROL 
The Offset option will control the location of the locator circle in the plan view and the vertical cross 
hair in the cross-section and profile view. 

ELEVATION CONTROL 
The Elevation option will control the location of the horizontal cross hairs in the profile and cross-
section views. 
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ACTIVE GROUND SETTING 

 

If the TIN file is defined in the Working Alignment definition, the DTM view can be substituted for 
the cross-section view.  The DTM view cuts a section on the fly at the location of the cross hairs in the 
plan view. 

 

ACTIVE VIEW SETTINGS 
The Active option defines the view that controls the manipulation of the other two views. 

SET BUTTON 
Once the Active View is selected, the user can click the Set button.  This will allow the user to move 
the cursor to the Active View and move the cross hairs.  As the user moves the cursor along the Active 
View, the other two views will be updated according to the placement of the cursor in the Active View. 

DP BUTTON 
The DP button enables the user to issue a data point for a MicroStation command.  For example, if the 
user wanted to draw a line at the given station and offset listed in the Port Viewer dialog, they would 
select the line tool, and click the DP button.  This would begin drawing a line at the given station and 
offset. 

PORT VIEWER MENU OPTIONS 

VIEW 
The View pulldown from the Port Viewer menu bar allows the user to fit one or all of the views, or to 
select the Active View.   
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The Fit option will fit the entire horizontal alignment when selecting Plan View, the entire profile 
when selecting Profile View, or the current cross section when selecting XS View. 

The Active option set the active design file to be the one that contains either the Plan, Profile or Cross 
Section data and reference the others.  This is useful if you need to alter a section yet you are in the 
Plan View.  Since the Cross Section file is referenced, you can not modify the section.  However if you 
make the XS View ‘active’, then the port viewer will open the Cross Section file as defined in the 
Working Alignment dialog, and reference the Plan and Profile views. 

OPTIONS 

 

The Options menu controls which cross hairs to display, as well as the symbology of the DTM section 
view. 

 

Group boxes are supported for Plan, Profile and XS display options.   

Three toggles are located in the Plan group box:  Station, Offset Circle, and Auto Center Window.  
When the Station toggle is activated, the pattern line is displayed on the screen.  When the Offset 
Circle toggle is activated, a circle of the size specified in the Offset Circle is placed at the Station and 
Offset specified in the Port Viewer dialog.  When the Auto Center Window toggle is activated, the 
Station and Offset specified in the Port viewer dialog is centered in the Plan window. 

The Profile group box has three toggles:  Elevation, Station and Auto Center Window.  When the 
Elevation toggle is activated, a horizontal line at the Marker Display element symbology is displayed 
in the Profile View at the Elevation specified in the Port Viewer.  When the Station toggle is activated, 
a vertical line, also at the Marker Display element symbology, is displayed on the Profile view at the 
Station specified at the top of the Port Viewer dialog.  When the Auto Center Window toggle is 
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activated, the Station and Elevation specified in the Port viewer dialog is centered in the Profile 
window. 

The XS group box has two toggles:  Elevation and Offset.  When the Elevation toggle is activated, a 
horizontal line at the Marker Display element symbology is displayed in the XS View at the Elevation 
displayed in the Port Viewer.  When the Offset toggle is activated, a vertical line, also at the Marker 
Display element symbology, is displayed in the XS view at the offset specified in the Port Viewer 
dialog.  The XS Group box also contains parameters for the XS DTM Left and Right specified in terms 
of master units.  The XS DTM Left and Right parameters are the horizontal distances from the 
specified alignment which define the limits of the cross section or DTM display line, similar to a cross 
section pattern line.  

The Dynamic to Cursor Sensitivity determines how close the MicroStation cursor must get to the data 
point cross hairs (dynamic cursor) before they begin to follow the MicroStation cursor dynamically in 
the Set mode.  This is to prevent the cross hairs from jumping over to the MicroStation cursor until it is 
within a certain distance from them.  This distance is set as a percentage of the diagonal size of a given 
view.  When the dialog settings are complete, clicking the Apply button automatically updates the 
screen and revises the displays. 

The Marker Display group box contains the element symbology of the marker lines. 

After the desired settings have been completed, click Apply in the lower right corner to automatically 
close the dialog and apply all settings. 

LAB EXERCISE:  PORT VIEWER 
In this exercise we will use the Port Viewer. 

 Access Port Viewer 

1. Open the MicroStation file c:\data\geo\sc219\sc219pp.dgn. 

2. Click Select to make sure you’ve got SC219 selected as your Working Alignment. 



Lab Exercise:  Port Viewer 

 
3. Click Port Viewer. 

 
4. Use the VCR buttons to scroll through the design, profile, and cross sections. 

5. Close the Port Viewer dialog. 

6. Exit MicroStation. 
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14 
CHAPTER OBJECTIVES 

In this chapter, you will learn: 

• the procedures for calculating earthwork quantities with GEOPAK. 
• how to use Project Manager to set up and process an earthwork run. 

INTRODUCTION 

GEOPAK forms graphical earthwork shapes in a (MicroStation) cross section design file to represent 
the end areas used to calculate volumes by the end-area method.  These shapes are created when the 
designer processes an earthwork run in which the existing ground, finished grade, base, etc. are 
identified by level, color, weight and type.  

ACCESSING 
When Earthwork in the Road Project Manager is clicked, the Select Run dialog is displayed.  An 
existing run may be selected or new run may be started.  When complete, click OK, which closes the 
Select Run dialog and opens the earthwork dialog.   

 

The left side of the dialog contains the list of parameters required to compute earthwork.  When each 
parameter is selected, the dialog changes the key-in fields to reflect the selection.  For example, when 
EW Shapes is selected, the dialog changes as illustrated below. 
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EARTHWORK DIALOG 

XS DGN FILE 
In XS DGN File the user can specify the file name in which to find the cross-sections.  Tolerance 
specifies the maximum distances between two elements (in a cross section) to be considered as 
adjoining.  Vertical Search Distance specifies the distance above and below the cross-section to look 
for elements pertaining to that cross-section.  Baseline specifies the GEOPAK COGO chain the cross-
sections are based from.  Begin/End Station specifies the beginning and ending stations to perform the 
earthwork calculations. 

 

SOIL TYPES 
The Soil Types dialog requires the user to define the symbology and shrinkage/swell factors to be 
used.   
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Earthwork Dialog 

 

 

The user must first select the Class of the soil type. 

Existing Ground Identifies the surface of the existing ground.  This classification is required 
to calculate earthwork.  It also defines the default excavation material. 

Proposed Finish 
Grade 

Surface of the proposed roadway.  This classification is required to 
calculate earthwork and defines the default fill material. 

Existing Suitable Material between excavation limits that is to be removed only when it 
encroaches on the proposed design.  For example, if the proposed design is 
in fill, therefore above the existing suitable, it is not removed. 

Existing Unsuitable Material between excavation limits that is to be removed in all 
circumstances. 

Proposed Undercut Proposed layers that are not part of the finish grade, i.e. pavement layers, 
shoulder layers. 

Excavation Limit Pairs of vertical lines drawn in the cross-sections to demarcate the limits of 
removal for any existing suitable or unsuitable material.  Can also be used 
to isolate where the earthwork computations will take place. 

 

Once the Classification is chosen, a Soil Type, the element symbology of the material, and the 
shrinkage/swell factors need to be entered.  A Classification, except Existing Ground, can be listed 
multiple times.  The Soil Type determines how the cut and fill are calculated.  For example, a user 
creates an earthwork run with a classification of Existing Ground with a soil type of Existing, 
classification of Proposed Finish Grade with a soil type of Suitable_Grading, and a classification of 
Proposed Undercut with a soil type of Pavement.  The output from the run would look as follows. 
Material Name  End Areas Unadjusted  Adjusted Mult Mass 

Station     Volumes  Volumes  Factor Ordinate 

(square  (cubic  (cubic                    

ft)         ft)         ft)                  
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--------------------------------------------------------------------------------- 

287+00   

SUITABLE_GRADING 

Excavation  0.00  0      0  1.00 

Fill    12.32  336     336  1.00 2887 

EXISTING 

Excavation  25.88  654     654  1.00 

Fill    0.00  0      0  1.00 3541 

 

In the same example, if both classifications of Existing Ground and Proposed Finish Grade had the soil 
type of Suitable_Grading, then the output would look as follows. 

Material Name  End Areas Unadjusted  Adjusted Mult Mass 

Station     Volumes  Volumes  Factor Ordinate 

(square  (cubic  (cubic                    

      ft)    ft)          ft)                  

--------------------------------------------------------------------------------- 

287+00 

SUITABLE_GRADING 

Excavation  25.88     654     654  1.00 

Fill   12.32     336     336  1.00 3541 

 

As can be seen from the above examples, when the soil types for the Existing Ground and Proposed 
Finish Grade classifications were named differently, both soil types appeared in the output.  When the 
soil types for the Existing Ground and Proposed Finish Grade classifications were named the same, the 
quantities for each classification were combined into one soil type.  By paying close attention to the 
soil types, the user can specify when material can be re-used and exactly where a specific soil type 
should be placed. 

Once the Classification and Soil Type are chosen, the user can select the Element Symbology to define 
that particular Soil Type and the Multiplication Factors for the Soil Type.  The Match button can be 
used to select the Element Symbology.  Once the Match button is selected, the user can select the 
elements in the MicroStation view.  The symbology of that element will be added to the symbology list 
used to define the Soil Type. 

EW SHAPES 
EW Shapes enables the earthwork shapes to be drawn and the associated symbology.  The colors of 
the earthwork shapes can be stratified, so that cut and fill or each soil type are different. 
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OUTPUT FORMAT 

Output Format enables the user to specify which items to show in the earthwork report.   

 

An option within the Output Format dialog is Accumulate Adjusted Volume Column. When 
activated, an additional column is added to the earthwork report, where the adjusted volume of each 
excavation and fill for each material is cumulatively totaled. Note this toggle may be activated 
simultaneously with the Accumulate Unadjusted Volume Column, in which case, two columns are 
added to the report. 

Another option within this dialog is Calculate Only Between Excavation Limits. In this case, the use 
of excavation limits is to demarcate earthwork processing. This is extremely useful in projects where 
earthwork is staged or separate quantities for each roadway in a multiple alignment is necessary. When 
the toggle is activated, ALL earthwork calculations are limited to within user-defined excavation 
limits, not just existing removals. 

In normal processing, the end areas are rounded to two decimal places.  If the user desires a different 
degree of rounding, the toggle may be activated and the Number of Decimal Places set between 0 and 
4. 

In the bottom box, any combination of the three classifications of excavation volumes can be 
formulated.  For example, if the user desires to combine all three into an earthwork listing of simply 
cut and fill, press the < or > arrows until the desired option is displayed.  Options include: 

• Common Exc, Subgrade Exc, Subsoil Exc, and Fill 
• Excavation (Common and Subgrade), Subsoil Exc, and Fill 
• Excavation (Common and Subsoil), Subgrade Exc, and Fill 
• Excavation (Subgrade and Subsoil), Common Exc, and Fill 
• Excavation (all types) and Fill 
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ADD/SUB VOLUMES 

Add/Sub Volumes allows the user to enter volumes to be added or subtracted from the total earthwork 
calculated from the available sections. The user can specify whether to add excavation or fill, the soil 
type, the station, and the volume to be added. 

 

CENTROID ADJUSTMENT 
Earthwork volumes are calculated by averaging end areas and then multiplying these averaged areas by 
the distance between two successive cross sections as measured along the baseline.  If the bulk of the 
cross section areas are located predominantly to either the left or the right of the baseline, as in a 
detour, an error occurs in the volume calculations for all non-tangential portions of the baseline.  This 
error can be negligible or substantial depending on the degree of baseline curvature as well as the 
degree to which cross section areas are offset about the baseline.  These types of errors can be 
optionally accounted for via specification of the Centroid Adjustment. 
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SKIP AREAS 

Skip Areas enable the user to specify an area (i.e. bridge exception) in which to not calculate 
earthwork volumes.  End areas continue to be calculated for each cross section, but volume 
calculations are not performed between user specified station ranges. 

To utilize Skip Areas, activate the toggle at the top of the dialog. Next, type in the Begin Station and 
End Station of the area to be skipped. If the baseline has station equations, the regions must be 
included. Then click Add. The data is added to the list box. To Modify data, highlight the line to be 
modified, which populates the edit fields. Change the desired value, then click Modify. The change is 
reflected in the list box. To delete a skip area, highlight the line to be deleted, then click Delete. The 
line is deleted from the list box. 

 

IGNORE AREAS 
Ignore Areas enable the user to specify an area in which to ignore ranges of cross sections.  To utilize 
Ignore Areas, activate the toggle at the top of the dialog. Next, type in the Begin Station and End 
Station of the area to be skipped. If the baseline has station equations, the regions must be included. 
Then click Add. The data is added to the list box. To Modify data, highlight the line to be modified, 
which populates the edit fields. Change the desired value, then click Modify. The change is reflected 
in the list box. To delete a skip area, highlight the line to be deleted, then click Delete. The line is 
deleted from the list box. 
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SHEET QUANTITIES 

Sheet Quantities allows a user to write an earthwork quantity file to be used when plotting the cross-
section sheets. 

 

The name of the ASCII file can be chosen or entered.  The user then selects the columns in which to 
place the quantity, the number of decimal places, the total column width, the soil type, the earthwork 
operation, and the type of quantity. 

This information is written to the ASCII file, and can be used to plot the quantities on the cross-section 
sheets.   

From the Files menu, the Run option processes all parameters that have been set in the Earthwork 
dialog box.  The Save Settings option saves all information in the Earthwork dialog.  The Export 
option saves the parameters in the Earthwork dialog box as an ASCII input file.  The Exit option exits 
the Earthwork dialog. 

PROCESSING 
After all necessary information has been entered, the user has two options.  The preferred method of 
running the earthwork is to select the Run option.  The following dialog appears and the user may 
proceed by entering a log file name, choosing the Pause On Each Section option and then clicking 
Apply.  The second method is to export the information as an ASCII input file, then use the Process 
Cross Sections tool. 

 
The earthwork quantities are written to the bottom of the log file and can be reviewed in any standard 
ASCII text editor. 
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LAB EXERCISE :   EARTHWORK 

 Basic Earthwork Computations 

1. Open the MicroStation file 
c:\data\geo\sc219\sc219dx.dgn. 

2. Access Project Manager.  

3. Click Earthwork from the Project 
Manager dialog and create a new run 
named SC219R.  Open the new run. 

4. Populate the XS DGN File section of 
the dialog as shown below.  Be sure to 
set “Tolerance” to 0.001. 

 

 

 

5. In the Soil Types section of the dialog, create the following classifications and soil types 
utilizing the parameters detailed in the table below.   
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CLASS SOIL TYPE SEARCH CRITERIA 

Existing Ground Earth Lv Names=RD_XS_ExGround 

Proposed Finish Grade Earth Use Working Alignment Definition 

In our case, we are not using the Working Alignment Definition to define the symbology of the 
Existing Ground.  We could manually define the symbologies using the settings in the Search Criteria 
portion of the dialog. When using these settings, there are also three additional buttons to help you. 

Match Prompts you to identify an element. Once you do, it will fill in the symbology settings 
with the symbology of the identified element. 

Display  Highlights all elements in the design file matching the set symbology. 
Reset  Clears all symbology settings. 

 

6. In the EW Shapes section of the dialog, toggle on Draw Earthwork Shapes and Stratify 
Shape Color.  Populate the GEOPAK Set Feature dialog with the plot parameters as shown 
below then click OK. 
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7. Change the Output Format as shown below.  

 

Note Use the arrows (< or >) to change the format to Excavation and Fill. 

8. In the Sheet Quantities section, toggle on the Write Sheet Quantities File.  Name the file 
earth.txt.  Add the following columns to the file with Decimal Places = 0 and Total Quantity 
Length = 10: 

COL. SOIL TYPE EW OPERATION QUANTITY TYPE +/- 

1 Earth Common Exc End Area + 
2 Earth Common Exc Adjusted Volumes + 
3 Earth Fill End Area + 
4 Earth Fill Adjusted Volumes + 

 

 



Lab Exercise :   Earthwork 

 
9. Select Files > Save Setting to save your input and then, using the Files > Run pulldown, run 

the earthwork for the proposed cross sections.  Place your output into a log file as shown in 
the dialog below and Pause on Each Section. 

 

10. Review the file earth.log using the GEOPAK editor. 

11. Exit the Earthwork dialog and save your run. 

12. Review your cross sections using XS Navigator. Notice that GEOPAK has placed shapes onto 
your cross sections representative of the calculated earthwork areas.  These shape areas can be 
measured to verify earthwork areas if desired. 
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15 
CHAPTER OBJECTIVES 
 

In this chapter, you will learn the procedures for laying out cross section sheets. 

INTRODUCTION 

The GEOPAK sheet layout component provides an automated tool to draw cross section data in a 
format suitable for producing hard-copy cross section construction drawings.  The input includes 
specifying sheet layout parameters as well as the graphic design file where the cross sections were 
originally created by GEOPAK.  The output is a MicroStation design file of the cross sections.  Each 
cross section is displayed as a reference file and labels such as baseline, station, offsets and elevation 
are added.  There are several advantages to using sheet input: 

• The cross sections will be sorted in numeric order for the specified baseline.  

• The cross sections will be spaced closer together. 

• The original cross section file is left intact and any modifications to the cross sections will be 
automatically displayed in the sheet file due to the use of reference files. 

• The cross sections are placed into "sheet format" according to user specified criteria. 

The parameters for each sheet are defined in a Sheet Library.  In order to lay out sheets, a Sheet 
Library must be attached to the current session.  The name of the currently attached Sheet Library is 
shown in the title bar.  Sheet Libraries have an extension of xssl.  An unlimited number of different 
sheets can be stored within one library. When the user begins the sheet process, he selects the desired 
sheet layout from the attached library, which loads the associated parameters. 

If a different Sheet Library is needed, it can be attached via the menu items File > Sheet Library > 
Attach.  Detailed information on the set-up of the Sheet Library can be found in the online help section 
entitled "Sheet Library Set-up." 
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ACCESSING THE CROSS SECTION SHEET LAYOUT TOOL 

The Cross Section Sheet tool can be accessed by selecting Applications > GEOPAK ROAD > Cross 
Sections > Cross Section Sheet Composition.  It can also be invoked from Project Manager by clicking 
the Cross Section Sheets button or by selecting the Cross Section Sheet Composition icon from the 
GEOPAK ROAD tool frame.   

 

FILE > SHEET LIBRARY 
TOOL DESCRIPTION 

New Create a new Sheet Library. 

Attach Attach a Sheet Library. 

Save Saves a Sheet Library. 

Save As  Save a Sheet Library as a new name. 

 

FILE > SHEET 
TOOL DESCRIPTION 

New Create a new Sheet in a Sheet Library. 

Delete Delete a Sheet in a Sheet Library. 

Update Update a Sheet in a Sheet Library. 

 

FILE > LOAD V7 INPUT FILE 
This option gives the user the ability to load an ASCII input file that was created in previous versions 
of GEOPAK. 
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FILE > SAVE SETTINGS 

Saves all dialog settings in Project Manager. 

FILE > LAYOUT SHEETS 
Layout cross sections into sheet format. 

FILE > EXIT 
Exit the Cross Section Sheet Composition application. 

CROSS SECTION SHEETS DIALOG 
The left side of the dialog contains the list of parameters required to process cross sections into sheets.  
The slide bar to the right of the list box enables the user to view the entire list. When each parameter is 
selected, a graphic explanation of the parameter appears in the right side of the dialog, and keyin fields 
for each variable appear below it. 

Active Cross Section Sheet - Settings for a variety of different cross section sheets can be stored in 
the cross section sheet library as standards.  In this way, the same settings can be used for numerous 
projects by all users in the organization.  To begin, the user would select the desired sheet layout from 
the list.  If the cross section sheet library is not attached, it can be attached by selecting File > Sheet 
Library > Attach.  The setting within the attached sheet library determined what selections are 
displayed in the Active Cross Section Sheet field. 

XS DGN File – Tells the software where to locate the cross sections. The chain and stationing will be 
filled out automatically if defined via the project manager. By default, the software will find all 
elements within the confines of the cross section cell.  
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Sheet DGN File - Specifies which file the cross section sheets will be placed in. Also allows you to set 
the horizontal and vertical scale at which they are to be laid out and the coordinate location in the 
MicroStation Design file at which the sheets will be placed. 

 

If the Detach Existing Sheets before Processing option is toggled on then all elements are removed 
and reference files are detached before new sheets are processed. 

 

Attachment: 

 All Sheets In Active Model – All sheets are placed in the Active Model. 

One Sheet Per Model – Sheets are placed in separate models and no sheets are placed in the 
active model. 

One Sheet Per Model / Display All – Sheets are placed in separate models and all sheets are 
attached to the active model as reference files. 

Note Models are named XS_SHEET_ and the sheet number is added to the name. 
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Sheet Dimensions/Cell – Sheet Dimensions defines the Sheet Height and Sheet Width to be used for 
the cross section sheet.  When Place Sheet Cell is toggled on, the application will place a sheet border 
cell from the specified cell library.  A scale can be applied and the sheet cells can be placed as Shared 
Cells.  Sheet Offset from Cell Origin is the X and Y offset from the sheet border cell origin. 

 

There are two options for Sheet Cell Placement.  The sheet border cell can be placed in the sheet file 
with the cross section reference files as shown above.  It can also be placed once in a reference file 
then the sheet cell file is attached to the file that contains the cross section reference files as many 
times as it is needed.   

XS Search Criteria – Indicates the search criteria (symbology) for the data to be used as input to the 
sheet layout software.  If you need to look farther than that (i.e. outside of the cell), you can use the 
Lower and Upper Range Limit values to extend beyond the cell limits.  There is also a Horizontal 
Search to look outside the limits of Sheet Width setting. 
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Sheet Stack Orientation – Determines whether you want the sheets to be stacked vertically or 
horizontally.  Also allows you to set the maximum number of sheets you want placed per column in 
the file as well as the Horizontal and Vertical spacing between sheets. 

 

Sheet Stack Columns – Determines whether you want a single stack or a double stack of cross 
sections per sheet.  Baseline X Offset defines the distance from the left-hand edge of the sheet to the 
zero offset position (i.e. baseline) of the cross sections.  If you select Double Stack, you can give an 
offset value which is the distance of the second stack from the left hand edge of the sheet.  There are 
also options for Triple and Quadruple stacking. 
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Margins and Spacing – Cross Section Clip Limits defines the clipping limits from the left hand edge 
of the sheet.  To the left of the Left Clip X Offset remains clear space and to the right of the Right Clip 
X Offset remains clear space.  All minimum spacing requirements as well as the maximum allowable 
vertical size of any cross section is also set here. 

 

Station Labels – Allows you to define the station label locations and plot parameters. 
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Offset Labels – Allows you to define the offset label positions, increments and plot parameters. 

 

Elevation Labels – Allows you to control the elevation label locations, increment and plot parameters.  
Add Top Elevation Label - Activating this toggle adds another elevation label above the current labels 
placed within the elevation labels parameters.  If two sets of elevations labels are placed (one on each 
side of the section), the top elevation is added to both. 

Add Bottom Elevation Label - Activating this toggle adds another elevation label below the single 
label placed within the elevation labels parameters.  If two sets of elevations labels are placed (one on 
each side of the section), the bottom elevation is added to both. 
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Earthwork Quantity Labels – The user can define the ASCII file that contains the earthwork quantity 
information, as well as set the symbology and location of the earthwork quantity labels.  This will use 
the information gathered during the earthwork run to place the earthwork quantity labels on the cross 
section sheets. 

 

Sheet Labels – Allows the placement of numerous labels.  There are three sets of labels that can be 
placed where the labels change from sheet to sheet.  These labels include Sheet Number, Begin 
Station, and End Station.  Any number of custom labels can also be placed.  These labels would be 
something that does not change from sheet to sheet such as Project Number, Designer, etc.  A list of 
labels can be created and each label can have it’s on symbology.  Location of the labels is controlled 
by the DP Origin and DP Label Justification Point buttons.  The DP Origin button locates the origin of 
the sheet cell and the DP Label Justification Point button sets the X and Y Offset from the sheet cell 
origin for the placement of the label. 
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Digital InterPlot – Allows the creation of the Digital InterPlot Plot Set during the Layout Sheets 
process. 

 

GENERATING SHEETS 
From the Files menu, the Layout Sheets option will process all parameters that have been set in the 
Cross Section Sheets dialog box.  There is also a Layout Sheets button on the main dialog. 
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Lab Exercise:   Cross Section Sheets Layout 

 
LAB EXERCISE:   CROSS SECTION SHEETS LAYOUT 

 Generating Cross Section Sheets 

1. Open the MicroStation file c:\data\geo\sc219dx.dgn. 

2. Access Project Manager.  

3. Click Cross Section Sheets from the Project Manager dialog and create a new run named 
SC219R.  Open the new run. 

 

4. Click Select Sheet DGN File and select the sheet design file sc219fx.dgn.  
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Lab Exercise:   Cross Section Sheets Layout 

 
5. Select Earthwork Quantity Labels.  Click Select Earthwork Data File and select the 

earth.txt file created in the previous chapter. 

 

6. Select Sheet Labels.  Double click in the Label column to make it editable.  Enter X1 for the 
starting Sheet Number then tab out of the field.  

 

7. Using MicroStation, turn off levels Default and RD_XS_EwShp then select File > Save 
Settings. 

8. Process the cross sections onto the sheets using either the File > Layout Sheets pulldown or 
by clicking the Layout Sheets button. 

9. Close the Cross Section Sheet Composition dialog. 

10. When prompted to Save Settings, click Yes. 
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Lab Exercise:   Cross Section Sheets Layout 

 
When the Cross Section Sheet Layout process is completed, you will be in the sheet file.  
Review your work. 

11. Exit MicroStation. 



Lab Exercise:   Cross Section Sheets Layout 
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CHAPTER OBJECTIVE 
In this chapter, we will create various cross section reports: 

• for plan use (design elements and quantities). 
• as input for other programs and/or applications of GEOPAK 
• for construction layout 
Create and draw construction limits in the plan view file. 

INTRODUCTION 
The GEOPAK Cross Section Report Utility can extract up to sixteen different reports from original 
and design cross-sections.  For each report generated, the user must set the parameters of the existing 
and/or design cross sections.  GEOPAK also provides an option to make custom headers for each of 
the reports via the User pull down menu. 
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Accessing Cross Section Reports 

 

ACCESSING CROSS SECTION REPORTS 
The Cross Section Reports dialog can be accessed by selecting 
Applications > GEOPAK ROAD > Cross Sections > Reports.  It can also 
be invoked from Project Manager by clicking the Reports & XS Quantities 
button or by selecting Cross Section Reports from the GEOPAK ROAD 
tool frame.   

CUSTOM HEADER 
From the XS Report dialog, select User > Preferences.  To activate the 
individual fields simply toggle on the box next to the desired field.  Once 
you have completed the dialog box, the information will be saved as an 
.hdr file.  This allows for the creation of a separate header for each type of 
report.  The tolerance field determines the maximum gap allowed between 
cross section elements.   

  

BLUE AND RED TOP 
Based on the dialog box settings, GEOPAK determines the offset and elevation of a slope and its 
breakpoints.  Blue refers to the top of pavement and Red is the top of subgrade.  The user must 
determine this by indicating text and level, color, weight and style for each surface. 

CLEARING 
The Clearing Report is useful for obtaining clearing and grubbing quantities.  For each station, 
GEOPAK will list the clearing distance on each side of the chain and the width of any exception.  You 
can obtain the results in the appropriate units.  Toggle boxes for Cut Slope Rounding, Additional 
Clearing in Cut and Fill, and Minimum Clearing Width are provided for increased control over the 
output. 

GEOPAK can also generate quantity sub-totals based on the value specified in Sub Every. 

To use the Except Width option, you must have an existing ASCII file that includes the Beginning and 
Ending Station and Exception Width. 

Once everything is set, you can output the information to an ASCII file 

CLOSURE 
The Closure Report provides information on the intersection point between the user defined proposed 
finish grade and existing ground.  In addition to the ASCII report, the designer may instruct GEOPAK 
to close any gap either by drawing a vertical line between the endpoint of the proposed finish element 
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Custom Header 

 
and the existing ground or extending the slope of the last proposed element to intersect existing 
ground.  The procedure will not extend existing ground.  The Closure Report can be accessed within 
any MicroStation cross section file by selecting Closure from the main XS Reports dialog. 

DTM INPUT 
This process generates XYZ coordinates from cross section elements and places this information into 
an ASCII file for use by the DTM portion of GEOPAK.  To use this dialog box simply enter the .gpk 
job number, chain name and station range.  GEOPAK will read the cross section elements based on 
level, weight, color and style. 

DTM PROPOSED 3D 
This report is similar to DTM Input except that you can set both original and proposed cross sections at 
the same time.  This report also differs in that it makes break lines across the cross sections.   

HEC – 2 
This process reads cross section elements and formats the information in an ASCII text file suitable for 
use in the HEC-2 hydraulic program. 

HEC RAS 
This process reads cross section elements and formats the information in an ASCII text file suitable for 
use in the HEC RAS hydraulic program. 

MULTI-LINE 
This report is useful in creating cross-sections for staged construction.  Begin by entering the job 
number, chain name and station limits.  Primary cross section element parameters must be completed 
before secondary element parameters.  This is important due to the order in which GEOPAK reads the 
information.  Once all the parameters have been entered, the new cross sections may be drawn to the 
design file or you may choose the display only option.  An ASCII text file will be generated. 

PROFILE GRADE 
The Profile Grade Report is one of the most versatile reports available.  It prints existing ground and 
design grade elevations and low point elevations for each cross section.  Additionally, this report has 
the ability to search either for the low points or any text string that you specify and create horizontal 
and vertical alignments and store them directly into the .gpk.  Horizontal alignments created from this 
report will have no curves. 

RADIAL STAKING 
The Radial Staking Report is a specialized report created for the U.S. Federal Highway 
Administration (FHWA). 

 RT 40 
The RT 40 Report produces RDS based RT40 data.  To use this dialog box simply fill in the job chain 
name, stationing range and the parameters of the cross section elements you wish to use. 
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Custom Header 

 
SEEDING 

Other than the usual entries, the user must enter the parameters of the elements to be seeded. 

This dialog box includes slope and subtotal options as well as a way to limit the number of segments 
read (By-Pass Segments).  The user may also establish additional seeding specifications (Additional 
Distance). 

Once all of the settings are complete, the report will produce seed or sod quantities written to an ASCII 
output file for use in plan quantities.  

SLOPE STAKE 
The Slope Stake Report is a special format report developed for the FHWA.  This report generates 
offsets, elevations and superelevation information for each cross section.  To generate this report fill in 
the usual cross section parameters plus Subgrade and Hub Staking information. When complete, push 
Apply and the report is written into an ASCII file. 

 STAKING DETAIL 
The Staking Detail Report determines the tie down point between the proposed finished grade and the 
existing ground.  GEOPAK will list the right and left offset, elevation, and slope of the finish grade 
and superelevation rate for each cross section.  To create this report, fill in the project information and 
desired cross section elements’ parameters.  Once complete, you have the choice between two formats, 
a FHWA ASCII report or a Montana DOT report (includes ditch elevations). 

WSPRO 
This report takes the cross section elements and turns them into an ASCII file for use as input in the 
WSPRO hydraulic analysis program. 

XS LIST 
This report creates a listing of elevations and offsets for each cross section element according to user 
defined parameters.  You have the option of creating either an original cross section list or a design 
cross section list.  These reports are very similar to RDS cross section lists. 
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Accessing Limits Of Construction 

 
ACCESSING LIMITS OF CONSTRUCTION 

The Limits Of Construction dialog can be accessed by selecting Applications > GEOPAK ROAD > 
Cross Sections > Limits Of Construction.  It can also be invoked from Project Manager by clicking the 
Limits Of Construction button or by selecting the Limits Of Construction from the GEOPAK ROAD 
tool frame.   

When the Limits of Construction dialog in 
invoked, the dialog to the right opens.  
The user must specify the Job number, the chain 
name, and the file containing the plan view 
information.  The Existing Ground Line and 
the Proposed Finish Grade sections will be 
filled by the run if Project Manager is utilized.   
The Plot Parameters button opens the dialog 
below.  The symbology for the cut, fill, and 
transition construction limits can be set in this 
dialog.  

 

 

The Place Construction Limit toggle allows the user to place various text strings along the 
construction limits.  Clicking the Label Plot Parameters button sets the symbology for these text 
strings. 

The Radius of Display field is the size of the display circle when GEOPAK is scanning the cross-
sections. 

The last option in the main Limits of Construction dialog is the Tie Down Option.  There are two Tie 
Down Options.  If the All Tie Downs option is set, all tie downs within a section are plotted.  (I.e. wide 
medians, outer roadways, ramps, etc. may have tie downs in between the limits of the main roadway, 
and the outer roadway or ramp.)  If the Outer Tie Downs option is selected, then only the outmost tie 
downs are plotted.   

 

Once Apply is clicked, the limits of construction and the optional text are drawn into the plan view file 
at the specified symbology. 
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LAB EXERCISE:  XS REPORTS & LIMITS OF CONSTRUCTION 

 Seeding Quantities 

1. Open the MicroStation file c:\data\geo\sc219\sc219dx.dgn. 

2. Access Project Manager.  

3. Click the Reports & XS Quantities button on the main Project 
Manager dialog. 

4. From the XS Reports dialog, select User > Preferences.  

5. Set the Tolerance to 0.001 then close the Report Header dialog. 

 
6. From the XS Reports dialog, select the Seeding report. 

 

 

Note Most of the Seeding Report dialog will be populated from Project Manager. 

7. Select Chain SC219R.. 

8. Set the Ending Station to 217+00. 

9. Click Candidate Seeding Elements search criteria. 
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Lab Exercise:  XS Reports & Limits of Construction 

 

 

8. Populate the Candidate Elements dialog as below then close the dialog. 

 
9. Set the ASCII File name to seeding.txt.   

10. Click Apply. 

11. Using the GEOPAK Editor, review the report “seeding.txt”. 

12. Close the Seeding Report dialog. 

13. Close the XS Report dialog. 

 Top of Curb Profile 

The following report will read text placed on the cross sections to assist in generation of a top of curb 
profile. 

1. Select the Profile Grade report from the XS Report menu. 

2. Zoom to a single cross section.  Use the Display button for the proposed finished grade to 
check the levels defined for the Proposed Finished Grade.  If necessary, add the symbology 
for the top and front of the curb and top of the pavement. 

3. Set the Report Option to Search text. 

4. Set the Search Text box as shown below. 
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Lab Exercise:  XS Reports & Limits of Construction 

 

 

5. Set the ASCII File to SC219LTC.txt. 

6. Click Apply to process profile for the left top of curb. 

7. Open the COGO dialog to print the resulting profile information to the COGO window to 
review. 

 Plan View Limits of Construction 

1. Click Limits Of Construction from the Project Manager dialog and create a new run named 
SC219R.  Open the new run. 
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Lab Exercise:  XS Reports & Limits of Construction 

 
2. Zoom to a single cross section.  Use the Display button for the proposed finished grade to 

check the levels defined for the Proposed Finished Grade.  If necessary, add the symbology 
for the top and front of the curb and top of the pavement. 

3. Click Plot Parameters. 

4. Double click the Cut sample graphics. 

5. Populate the GEOPAK Set Feature dialog as below then click OK. 

 
6. Right click the Cut sample graphics field and select Copy.  Then right click the Fill and 

Transition graphics and select Paste. 

9. On the Plot Parameters for Construction …dialog, toggle on Place Construction Limit then 
click Label Plot Parameters. 

 
7. Populate the top portion of the Plot Parameters for Labels dialog as below. 

 
8. Double click the sample graphics box for the Left side labels. 

9. Populate the Set Feature dialog as below then click OK. 

 



Lab Exercise:  XS Reports & Limits of Construction 

 
10. Double click the sample graphics box for the Right labels. 

11. Populate the Set Feature dialog as below then click OK. 

 
12. Populate the lower portion of the Plot Parameters for Labels dialog as below then click OK. 

 
13. Click OK on the Plot Parameters for Construction …dialog. 

14. On the Limits of Construction dialog, set the Tolerance to 0.01 

15. Click Apply. 

16. Close the Limits of Construction dialog. 

17. When prompted to Save Settings, click Yes. 

18. Review the limits of construction in c:\data\geo\road1\plan.dgn. 

19. Exit MicroStation. 
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CHAPTER OBJECTIVES 

In this chapter we will: 

 Learn how to label plan information with Plan View Labeler. 

 Familiarize the user with the Cross Section Labeler. 

INTRODUCTION 
GEOPAK’s labeling tools allow a user to place “smart” labels in a MicroStation drawing.  These labels 
have the ability to calculate XYZ coordinates, station, offset, direction, length, radius, degree of 
curvature, etc. of the associated element. 

ACCESSING THE PLAN VIEW LABELER 

The Plan View Labeler can be accessed by selecting Applications > GEOPAK ROAD > Plans 
Preparation > Plan View Labeling.  It can also be invoked from Project Manager by clicking the Plan 
View Design button or by selecting the Plan View Labeling tool from the GEOPAK ROAD tool 
frame.   

PLAN VIEW LABELING 
When the Plan View Labeling icon is selected, the dialog depicted below is displayed. 
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Plan View Labeling 

 
The label to be placed is displayed in the box on the right side of the dialog as shown above.  The 
Space button places a space in the label at the cursor position.  The Return button starts a new line of 
text.  The Clear button starts a new label.  The Delimit button places a line above or below a line of 
text.  The Place Label button attaches the label to the cursor for placement in the drawing.   

The user can select the various tabs to define / modify the label appearance. 

TEXT 
For data to be computed, the job number and the chain need to be selected.  If elevations are to be 
calculated, a TIN file needs to be chosen.   

The Computed Inserts are items that Geopak has the ability to calculate for the chosen item.  The list of 
Computed Inserts changes with the type of element that is chosen.  If a line is chosen, the list of 
Computed Inserts will show inserts of bearing, and length.  If a curve is chosen the list of Computed 
Inserts will change to show inserts of radius, curvature, chord length, etc. 

The User Inserts are inserts that a user may use on a regular basis.  This list can be customized for a 
specific user’s needs. 

The Identify Element button allows the user to choose the element to use for calculations in the label.  
The Data Point button will let the user pick a specific point to calculate the coordinates, station, or 
offset for. 

PARAMETERS 

      

The Parameters tab enables the user set up the text size and symbology for the label. 

By Current sets the symbology to the current MicroStation settings.  By Element allows the user to 
set the symbology by choosing a MicroStation element.  D & C Symbology allows the user the ability 
to match symbology of an item in a DDB file.  Set All sets the symbology for all elements in the label 
(text, delimiters, leader lines, etc.).   
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Plan View Labeling 

 
SHAPE 

 

The Shape tab allows the user to place a shape around the label, and set the symbology for the shape. 

LEADER 

 

The Leader tab allows the user to attach a leader from the label to the point.  Different leader types and 
terminators can be chosen.  The active terminator can also be used. 
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Plan View Labeling 

 
ROTATE 

 

The Rotate tab allows the label to be rotated.   The rotation can be determined from the current angle, 
the angle of the element, or the alignment angle.  The angle can also be set by two data points (first 
data point set the location, next data point sets the angle) or the active angle. 

STYLES 

 

The Styles tab allows a user to choose label symbology from a library of pre-defined styles.  When the 
user chooses the style, all symbology, leaders, shapes, etc. is set up for the user. 

MENUS 
The Style Files menu allows the user to open a new style library.  You must be under the Styles tab in 
order to open a style library. 

Options > Minimize Dialog minimizes the main dialog (when the Place Label button on the main 
dialog is pressed) to allow for easier label placement. The Label Viewer can be used in conjunction to 
still view the sample contained in the Label dialog. 

The main labeling window can be maximized by selecting the Restore Label Dialog icon within the 
appropriate View Label Control tool frame or the labeling tool on the main Road, Site, or Drainage 
tool frame. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 17-5 

Plan View Labeling 

 
Options > Use Reference File Coordinates - When labeling elements within a reference file, it is 
useful to utilize the reference file coordinates, rather than the current active file.  Simply activate the 
toggle, and subsequent computed text inserts using reference file elements or data points will reflect 
the reference file coordinates, if the snap and locate in the reference file are active. 

Options > Use DP Element Association - This option will enable the association between MS 
elements and DP (data point) labels that are snapped to the element.  If the element is modified, the 
point labels will move with the element when the Label Update feature is used. Note: This only applies 
to elements within the active design file. 

Options > Label Tools invokes the tool frame shown below which enables the user to modify Geopak 
labels.  

 

Options > Label Viewer brings up a dialog that allows a user to view and place a label.  

 

The Scale > Scale Style menu allows the user to choose a plan scale.  All labels will be adjusted 
according to the plan scale.  The user simply keys in a scale, and chooses a Labeling Style.  The 
corresponding label will be placed at the correct size for the scale that was chosen.  
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Plan View Labeling 

 
Tools > Label Updater - The Label Update tool is a powerful tool for updating GEOPAK labels.  
When alignments are updated, TIN files modified, labels moved, etc., GEOPAK "remembers" the 
computed text information utilized in the placement of the original label.  Therefore, the software can 
update the label based on updated data.  The tool utilizes the dialog depicted below. 

 

Tools > Selection Set Labeling - The Selection Set Label tool is a powerful tool for placing or 
updating labels within a selection set.   

When the Selection Set Labeling tool is activated from the pulldown menu, the dialog depicted below 
opens. 
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Cross Section Labeling 

 
Tools > Plan Label Preferences – Allows for the customization of the plan view labels.  Options 
include Bearing, Distance, Elevation, and Area. 

When the Plan Label Preferences tool is activated from the pulldown menu, the dialog depicted below 
opens. 

 

CROSS SECTION LABELING 
The Cross Section Labeling dialog differs from the Plan View Labeling dialog only on the text tab.  
Cross Section Labeling works with the Cross Section Navigator.  The current Cross Section Navigator 
station is shown on the Text tab.  The Computed and User Inserts contain values and phrases related to 
cross-sections. 

 

ACCESSING THE CROSS SECTION VIEW LABELER 
The Cross Section View Labeler can be accessed by selecting Applications > GEOPAK ROAD > 
Cross Sections > Cross Section Labeling.  It can also be invoked by selecting the Cross Section 
Labeling icon from the GEOPAK ROAD tool frame. 
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PROFILE LABELING 

The Profile Labeling dialog differs from the Plan View Labeling dialog only on the text tab.  The 
Chain and Profile must be defined, in addition to profile settings.  The Computed and User Inserts 
contain values and phrases related to profiles. 

 

ACCESSING THE PROFILE VIEW LABELER 
The Profile View Labeler can be accessed by selecting Applications > GEOPAK ROAD > Plans 
Preparation > Profile Labeling.  It can also be invoked by selecting the Profile Labeling icon from 
the GEOPAK ROAD tool frame. 
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LAB EXERCISE:   LABELING 

 Accessing the Labeler 

1. Open the MicroStation file c:\data\geo\sc219\sc219pp.dgn. 

2. Access Project Manager. 

3. Click the Plan View Design button on the main Project Manager dialog. 

4. Attach SC219proposed.dgn as a reference file. 

5. Zoom in to the end of the project 

6. From the Plan View Design tool bar, click the Plan View Labeler tool. 

 

 Using Predefined Label Styles 

1. Select the Styles Tab. 

2. Traverse with the Item Selector box to locate the following style: 
Labels > Plan_Sht_Label > Removal Asph Note.   Next, double click the Removal Asph 
Note style. 

 

3. Move back to the Text tab and complete as defined below: 

Job No. 839 
Chain SC219R 
TIN File SC219.tin 



Lab Exercise:   Labeling 

 
4. To begin the process, select the DP button and then identify the location that you wish to use 

to anchor the end of the leader line for the note.  The labeler automatically calculates the 
information.  

 

5. Click the Place Label button. 

6. The label is now attached to your cursor (without the leader for the delimiter). 

7. Data point at the location you wish the text to be located. 

8. A second data point will define the side of the label, which the leader line will be drawn from 
the delimiter line to the computed location. 
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CHAPTER OBJECTIVES 

In this chapter you will learn the process for laying out and clipping plan and profiles sheets. 

OVERVIEW OF FEATURES 
These are the new features that the Plan and Profile Sheets Application provides: 

• Supports any combination of Ports on a sheet for maximum flexibility. 
• Provides powerful handling of MicroStation reference files.  This is accomplished by having other 

MicroStation files serve as patterns for the reference file attachments.  These are called motif files. 
• It has the option to automatically make a notch in the clipping shape at layout time to make room 

on the sheet for a title block.  This is done by putting the clipping shape pattern into the sheet cell. 
• Extended Stationing is used as a means to allow sheets to be placed partially off of an alignment 

or even completely off of the alignment. 
• It has the ability to place sheets with a Right to Left Station progression, which is opposite of the 

standard used in roadway design.  This was added for users doing rail design. 
• A thorough capability is provided to perform sheet numbering.  Alphanumeric prefixes and 

suffixes as well as changing the start number of the sheets and rearranging the ordering. 
• It supports Profile Stair Stepping.  In situations with steep grades or narrow profile ports, 

sometimes the profile goes off the top or bottom of the port before it gets to the end of it.  To 
handle this, users would put a break in the profile port and adjust the elevations to bring the 
coverage up or down to where it needs to be.  Within V8, GEOPAK automatically locates these 
breaks and plots the profile clipping shapes in accordance with that.  This adjustment carries 
through, then, to the sheet design file. 

• Profile Gap Equalities -- If a Profile has been plotted with the Gap option turned on, the coverage 
of the sheet is now adjusted so that subsequent sheets remain aligned with the grid. 

• Raster Manager -- Descartes is not supported by the application.  Raster Files are now to be 
referenced via the Raster Manager application available via Bentley Select. 

• Tabular Data Application -- Sheet Clip places Clipping Shapes suitable for Tabular Data.  
However, the actual placement of the tabular values in the dgn file is now done via the Draw 
Tabular Annotation (Sheet Clip Mode) tool.  This approach allows the power and flexibility of the 
Draw Tabular Annotation application to be used with sheets. 

• Digital InterPlot – The Digital InterPlot Plot set can be created during the sheet clipping process. 
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ACCESSING PLAN & PROFILE SHEET COMPOSITION 

The Plan & Profile Sheet Composition tool can be accessed by selecting Applications > GEOPAK 
ROAD > Plans Preparation > Plan/Profile Sheet Composition.  It can also be invoked from Project 
Manager by clicking the Plan & Profile Sheets button or by selecting the Plan/Profile Sheet 
Composition icon from the GEOPAK ROAD tool frame. 

INVOKING THE MAIN DIALOG 
When the Plan/Profile Sheet Composition tool is selected, the Plan Sheet Layout dialog depicted below 
opens. 

 

The dialog is comprised of the title bar which displays the current Sheet Library, the main menu bar, 
short-cut icons, and the Sheet Name Selector and Plot Scale fields. 

The first time the application is invoked, it opens up a default.psl sheet library located in the 
\geopak\bin\ folder if the configuration variable isn’t defined. 

The Plot Scale will be displayed in the proper units depending on how it is set in the User Preferences. 

SHEET LIBRARY 
The parameters for each sheet are defined in a Sheet Library.  In order to lay out or clip sheets, a Sheet 
Library must be attached to the current session.  The name of the currently attached Sheet Library is 
shown in the title bar.  Sheet Libraries have an extension of .PSL.  An unlimited number of different 
sheets can be stored within one library. When the user begins the sheet process, they select the desired 
sheet layout from the attached library, which loads the associated parameters. 

If a different Sheet Library is needed, it can be attached via the menu items Sheet > Library > Attach.  
It is also possible to review or make changes to the Sheet Library by selecting Sheet > Library > Edit.  
Detailed information on the set-up of the Sheet Library can be found in the online help section entitled 
"Sheet Library Set-up." 
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3BInvoking the Main Dialog 

 
MAIN MENU BAR OVERVIEW 

 

Four options are supported in the main menu bar: 

• File 
• View  
• Settings 
• Tools 

FILE MENU OPTIONS 

Two tools are supported in the File pulldown and are detailed in the table below. 

Sheet Library The Library file contains the various parameters, cells, and dimensions for 
creating sheets.  In this menu option, a new Library can be created, an existing 
Library can be edited, or the user can define (Attach) the desired Library.  For a 
detailed discussion of setting up and editing a Library, refer to the online 
documentation "Sheet Library Set-Up." 

 

Exit Exits the Plan and Profile Sheets application, but does not close the MicroStation 
file. 

 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 18-4 

3BInvoking the Main Dialog 

 
VIEW MENU OPTIONS 

Filter by Sheet 
Name 

The clipping shapes of the currently selected sheet name are displayed.  A 
MicroStation update view will need to be issued if “Automatic Update” is not 
toggled on. 

Filter by Scale The clipping shapes of the currently selected Scale are displayed.  A MicroStation 
update view will need to be issued if “Automatic Update” is not toggled on. 
NOTE:  “Filter By Sheet Name” and “Filter By Scale” can be used together. 

Automatic Update If this is toggled on when “Filter By Sheet Name” or “Filter By Scale” is selected 
the view is automatically updated. 

SETTINGS MENU OPTIONS 

Sheet Layout When the Sheet Layout tool is selected, the dialog depicted below opens.  Three 
settings are supported within the dialog including Left to Right or Right to Left 
layout, Stair Stepping for profiles, and Sheet View Attributes. 

 

• Sheet Layout Progression: 

Left To Right (Standard) 

 Right To Left (Rail) 

• Profile Stair Stepping: 

Off 

On 

• Sheet View Attributes: 

Use Current Design File 

Customize With Motif File 

Note The “Save Full Path” toggle applies to the Current Design file only. 
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TOOLS MENU OPTIONS 

Eight tools are supported in the Tools pulldown and are detailed in the table below. 

Identify Sheet Select Identify Sheet, then select and accept a previously placed clipping shape.  GEOPAK determines 
the settings utilized to place the original sheet and automatically populates the dialog with the Sheet 
Name and Scale.  In addition, the Sheet Name, Scale, Sheet Number, and Port are displayed in the 
MicroStation prompt field at the bottom of the screen.  If the parameters for the selected sheet are not 
found within the current library, a warning message is displayed indicating the sheet is not found, the 
name of the current library, and the name of the library used to place the original sheet. 

Sheet 
Composition 

This menu item opens the Sheet Composition dialog, wherein drawing area, overlapping options and 
other project specific variables are defined.  One sample dialog is depicted below. 

 
Sheet Layout The Layout Settings dialog is utilized to define the GEOPAK Job Number, alignments, and /or profiles 

for the desired sheets.     

 

Fields are also supported for stationing, if only part of the chain is being utilized for sheet layout. 
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Sheet Clip Once the sheets have been laid out and any modifications complete, the sheets are ready to be clipped and 
drawn for the final production sheets.  The Clip dialog is utilized to complete these tasks, as detailed 
below. 
In addition to clipping sheets, attaching reference files, and placing borders, the Clipping dialog also has 
options for placing a Sheet Title, Project Number, Match Lines, and Auxiliary Sheet Annotations. 
Create Digital InterPlot Plot Set – Allows the creation of the Digital InterPlot Plot Set during the 
Layout Sheets process.  

 
Sheet Modify After the sheets are laid out, the user may want to adjust individual sheets to conform to the project limits, 

etc.  This can be accomplished utilizing the tools in the Modify dialog, which is illustrated below. 

 

The two icons in the upper left corner are utilized to Slide sheets (along the alignment, rotating, 
offsetting) and Modify Drawing Area.  The Slide options are illustrated above, while the graphic below 
depicts the Modifying Drawing area. 
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The user can select the sheet to be modified from the pick list or by graphic identification.  Sheets can 
also follow the movement of the selected sheet, i.e., moving one sheet to left moves all preceding or 
following sheets to the left by the same amount. 

Sheet 
Number 
Manager 

After the sheets are laid out, the Sheet Number Manager can be invoked as depicted below, populated 
with the current sheets. 

 

The actual sheet number can be modified, prefix and suffix added, and other labeling options by utilizing 
the Edit Sheet Number (fourth icon down in the grouping to the right of the list box). 

 

  Another option is changing the order the sheets are drawn. 
Draw 
Tabular 
Annotation 
(Sheet Clip 
Mode) 

When the Draw Tabular Annotation tool is selected, the Draw Tabular Annotation dialog is opened, as 
depicted below.  
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The user can define the tabular data to be included within the plan /profile sheets.   

DIALOG ICONS 
Six short-cut icons are supported for ease of use.  These icons correspond to tools located within the 
menu bar pulldowns and are detailed in the table below. 

 
Sheet Composition  (Tools > Sheet Composition). 

 
Layout Sheets  (Tools > Sheet Layout). 

 
Clip Sheets  (Tools > Sheet Clip). 

 
Modify Sheets  (Tools > Sheet Modify). 

 
Sheet Number Manager  (Tools > Sheet Number Manager). 

 
ID button (Tools > Identify Sheet). 

SHEET NAME SELECTOR AND PLOT SCALE 
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Two parameters are global to the entire application and are shown on the main dialog:  

• The Sheet Name Selector enables the user to select which sheet is to be placed in the next Layout 
operation.  The drop down list displays all sheets in the currently attached Sheet Library. 

• The Plot Scale text item determines the scale at which sheets will be placed in the layout.dgn. 

PRIMARY WORK FLOW 
The approach taken by this application is to represent the reference-clipping boundary of each Port on 
each Sheet.  The clipping boundary is represented by MicroStation Shapes, referred to as Clipping 
Shapes. 

For each project, there is one design file which contains all of the Clipping Shapes for a project, for 
example, layout.dgn.  All design elements exist in files referenced to layout.dgn.  It is recommended 
that layout.dgn have only Clipping Shapes in it. 

The Primary Work Flow consists of two operations: 

• Layout of sheets – places clipping shapes into layout.dgn file. 
• Clipping sheets - reads the Clipping Shapes from the Layout dgn and creates new design files 

which include all required reference files which are clipped at the correct boundaries along with 
the Sheet Cell and other annotations. 

 

There are two options for Clipping Sheets: Rotate View and Rotate Reference. 

When Sheets are clipped using the Rotate View option, the sheet cell and the view are moved and 
rotated such that they are coordinately correct with the clipping shape of Port One.  This arrangement 
allows only one sheet per design file. 

When Sheets are clipped using the Rotate Reference option, the sheet cell and view are not rotated.  
The reference files are rotated and moved to be in the correct location with respect to the sheet cell.  
The arrangement allows multiple sheets to be placed in one design file. 

PORTS 
Each Sheet consists of one or more Ports.  A Port can be considered a window into the design.  For 
each sheet that is placed into a layout.dgn, each Port on that sheet is placed as a Clipping Shape. 

PORT TYPES 
There are three types of Ports: Plan, Profile, and Tabular Data.  It should be noted the 2001 plus 
version of Plan and Profile Sheet Composition does not place tabular data values.  The application 
places Clipping Shapes designed to include Tabular Data.  The actual placement of the Tabular Data 
values is accomplished by the Draw Tabular Annotation (Sheet Clip Mode) tool in coordination with 
the Plan and Profile Sheet Composition application. 

PORT INFORMATION 
Before laying out sheets, each Port must have its Port Information filled out.  The Port Information 
Dialogs are opened by double-clicking the corresponding row in the Layout Dialog. 
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Plan Ports only need the controlling chain, an offset value, and the name of the motif file for the given 
Port.  If the “Use Current Design File” option is selected, Current will be displayed in the dialog 
instead of a Motif File name. 

Motif files are used to determine reference file attachment.  

Profile Ports require the name of the controlling profile in addition to all the information found in a 
profile cell. 

Tabular Data Ports require the same kind of information that Profile Ports do, but also may optionally 
have the ability to stagger the placement of the ports.  This staggering allows the Clipping Shapes to be 
longer without conflicting so that they may accommodate margin labels. 

SHEET VIEW ATTRIBUTES 
Two options are supported for Sheet View Attributes: 

Use Current Design File – All reference file attachments, active levels, etc., are based on the current 
design file.  An optional toggle is supported to Save the Full Path of reference files. 

Customize with Motif Files - A blank file is utilized as a pattern file for the reference file 
attachments.  Also levels can be turned on or off as desired.  We call these files motif files.   

USE CURRENT DESIGN FILE 
The user can control reference file attachment without the use of Motif Files by selecting the Use 
Current option for Sheet View Attributes.  When this option is used, the Current dgn file (in which 
clipping shapes have been layed out) is used like a Motif file in that it’s reference file attachment 
information carries over to each Port during Clipping. 

Also the design file containing the clipping shapes will be attached as a reference file for each port to 
accommodate users that wish to place there clipping shapes in the proposed design file. 

The advantage of Use Current Design File is that the user does not need to concern themselves with 
setting up motif files.  What they see in the layout design file is what they will get in clipped sheet 
files.  However, when Use Current Design File is that selected option, it is not possible to have 
different reference file settings for different Ports on the same sheet.  All Ports must have the same 
attachment information and can’t be customized. 

The Save Full Path toggle is used when the sheets will be placed in a different directory than the 
reference files. 

NOTE:  If the sheets are to be placed in a different directory, then the reference files must be attached 
to the current design file with “Save Full Path” toggled on. 
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CUSTOMIZE WITH MOTIF FILES 

It is sometimes necessary to have two or more Ports on a sheet which have differing reference file 
attachment settings.  This could happen with two Plan Ports which cover the same area but show 
different aspects of the project.  For example, the top Port would show the proposed design and the 
bottom Port would show traffic control.  This could be considered as the two Ports on the same sheet 
having different themes or different motifs. 

The question arises as to how the various reference file settings are to be controlled for each Port.  This 
is done by using another design file to serve as a pattern for the reference file attachment information.  
For every Port, there would be a motif file specified by its file name.  The Ports on each sheet may 
have the same or different Motif Files. 

During a Clip operation, the reference file attachment information is read from the motif file for each 
Port.  When a Port is placed into the final sheet file, all reference files which are attached to the 
corresponding Motif File are attached to the final sheet design file.  All reference level view on/off 
settings of the motif file are also applied to the reference file attachment in the final sheet design file.  
Note the clipping shapes are still used to define the Clip Boundary of each reference file associated 
with that Port. 

In the example described above of a sheet with Design and Traffic Control, the top Port could have a 
Motif File named design_motif.dgn.  The bottom Port could have a Motif File named 
Traffic_motif.dgn.  At any time before sheets are clipped, the Motif Files (which would normally be 
blank) must be opened, desired levels should be active, and the reference files attached.  The reference 
file names and their paths used for the motif file must match exactly to the reference files and 
associated paths in the original file.  Therefore, the user will normally set up the motif files on a project 
by project basis, unless an organization has a standardized set of file naming conventions and level 
structure utilized on every project, where a single set can be developed for the entire organization. 

NOTE:  If the sheets are to be placed in a different directory, then the reference files must be attached 
to the motif file with “Save Full Path” toggled on.   
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SHEET COMPOSITION 

When the Sheet Composition tool is accessed, the dialog depicted below opens. 

 

The graphic illustrates the various values required in the dialog.  Directly below, four options are 
supported, as illustrated in the exploded view above: 

• By Begin Station/Overlap 
• By Station Range:  Inside Out 
• By Station Range:  Outside In 
• By Station Range:  Radial 
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BY BEGIN STATION/OVERLAP OPTION 

When the By Begin Station/Overlap option is selected, the Clip group box containing the Drawing 
parameters, Overlap options and associated fields as depicted in the graphic below: 

 

Before these options are reviewed, a discussion of the Active Drawing Area, located within the Clip 
group box, is warranted.  Several dimensions are found within the Clip group box.  These include: 

• Maximum Drawing Area (display only) 
• Horizontal 
• Drawing Shown 
• Vertical 
• Active Drawing Area (display only, calculated by GEOPAK) 

The graphic below illustrates each dimension for the subject sheet.  In addition, a portion of the 
adjoining sheet to the left is shown in order to depict the overlap.  Notice that the alignment is also 
displayed from approximately station 289+00 to 292+00. 
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First, GEOPAK utilizes the Maximum Drawing Area based on the Sheet Name and Scale selected in 
the main Sheet Layout dialog, in our example, 1540 x  960.  Then the Clip Vertical is subtracted 
twice, once for the top and once for the bottom.  In this case,  

    960 - 10 - 10 = 940 

which is shown in the Active Drawing Area.  The same method is utilized for the Horizontal 
computations.  The horizontal clip is subtracted twice, once for the right side and once for the left side.  
In this case,  

    1540 - 10 - 10 = 1520 

which is shown in the Drawing Shown and the Active Drawing Area. 

   

Once again referring to the graphic above, GEOPAK considers the Overlap shown on the left side 
between the two adjoining sheets.  The Overlap toggle has two options as depicted in the exploded 
view below: 
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• Percentage 
• Fixed Distance 

When the Percent option is selected, the designer keys in the desired overlap in percent format in the 
Overlap field.  Note the percent sign (%) is not required.  The Percentage is calculated utilizing the 
Drawing Shown value.  In this example, the 5.26% overlap is 156.75 feet (5.26% of 176.75). 

In our Percentage example, the overlap is 5.26%.  Therefore, a 20.00 foot overlap in clip areas is 
present between successive sheets. 

If the Fixed Distance option is utilized, the Value field is in master units, i.e. feet or meters.   

When placing sheets on a curve, the chord of the curve where it intersects the inside border is utilized 
to orient the sheet as depicted in the graphic below: 

 

Since the By Begin Station/Overlap Sheet Composition option uses a chord distance to compute the 
length of the sheet, in the area of a curve more stationing will be covered.  On a Plan/Profile sheet, this 
means there will be unequal coverage between the Plan and Profile.  With this in mind, it is 
recommended that By Begin Station/Overlap Sheet Composition option be used for a Plan only case. 
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BY STATION RANGE:  INSIDE OUT OPTION 

The By Station Range:  Inside Out option orients sheets between a rounded station interval.  This 
interval is entered in the Station Range field.  When utilizing this option, the Clip group box also has 
a slightly different look as seen in the graphic depicted below. 

 

Now the Active Drawing Area is not constant, but displays Variable in the output field.   

The Horizontal keyin has a slightly different meaning which can be best illustrated with an example.  
Let's use 500 feet for the Station Range, and 15 feet Horizontal.  The dialog is depicted below. 
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Utilizing the dialog above, the following sheets are generated. 

 

The first step when the sheets are drawn is to determine the stationing for each sheet.  Our first sheet 
will be oriented between stations 115+00 to 120+00. GEOPAK then expands the sheet clip area by the 
Horizontal keyin distance.  Looking at a detail of the beginning of the project, the clip area is 
expanded fifteen feet before station 115+00 as seen in the graphic below.  Note the inside border is the 
dashed line, and station 115+00 and its associated tick mark are shown. 

 

The curve is calculated slightly different.  The second sheet in this series is on a curve.  The station 
range is 120+00 to 125+00.  A chord is drawn for the curve between stations 120+00 and 125+00 as 
seen in the graphic below. 
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Notice that the inside sheet border is wider than the chord.  The software will extend the chord the 
amount of the Horizontal keyin (in our example, fifteen feet) to establish the vertical edge of the inside 
border as seen in the detail below. 
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BY STATION RANGE:  OUTSIDE IN OPTION 

The By Station Range: Outside In option orients sheets between a rounded station interval.  This 
interval is entered in the Station Range field.  When utilizing this option, the Clip group box also has 
a slightly different look as seen in the graphic depicted below. 

 

The Outside In option is slightly different as seen in the dialog below. 
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The Clip Area is no longer variable, but a constant based on the Sheet Size as well as the Horizontal 
and Vertical fields.  In our example, the same 500 feet is keyed in.  When generating the sheets, 
GEOPAK determines the center of the sheet, and the corresponding station.  In our example the 
midpoint of the stationing for the sheet from 120+00 to 125+00 is 122+50.  This point will be placed at 
the midpoint of the sheet as depicted in the drawing below: 

 

Since the clip area covers a constant station range, the length of the clipping shape will vary depending 
on the curvature of the alignment. 
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BY STATION: RADIAL OPTION 

The By Station Range: Radial option orients sheets between a rounded station interval.  This interval 
is entered in the Station Range field.   

 

An example best describes how this feature works.  In the dialog below, each sheet has a station range 
of 1480 feet.  Based on the station ranges in the bottom of the dialog, the first sheet would encompass 
station 120+00 to 134+80, while the second sheet would include stations 134+80 to 149+60. 

 

To draw this second sheet, GEOPAK locates the midpoint station 122+50, which in our example is on 
a curve.  Utilizing the chord of curve as the vertical center, GEOPAK draws the top and bottom of the 
clip regions 460 from the chord, making the clip region 920 feet high.  This is computed from the sheet 
size of 960 minus the vertical keyin of 20 for the top and 20 for the bottom, resulting in a 920 feet 
height. 

In the next step, GEOPAK moves to station 134+80 and draws the clip border radial to the alignment 
at the specified station until it intersects with the previously computed top and bottom clip regions.  
The same process is repeated at the other end of the sheet, i.e., 149+60.  Therefore, the inside clip 
region is trapezoidal as depicted in the graphic below. 
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Since the clip area covers a constant station range, the length of the clipping shape will vary depending 
on the curvature of the alignment. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 18-23 

8BLab Exercise:   Plan and Profile Sheets 

 
LAB EXERCISE:   PLAN AND PROFILE SHEETS 

 Configure Sheet Settings 

1. Open the MicroStation file c:\data\geo\sc219pp.dgn.  Attach as a reference 
c:\data\geo\sc219\sc219proposed and c:\data\geo\sc219\sc219profile.dgn.   

2. Access Project Manager. 

3. Click the Plan & Profile Sheets button from the Road Project: Road1.prj workflow dialog. 

4. Create a run SC219R to set up the plan/profile sheets. The dialog should appear as shown 
below. 

 

5. Select Settings > Sheet Layout.   

6. Change Sheet View Attributes option to Customize with Motif Files then click OK. 

 

7. Populate the GEOPAK Sheet Layout dialog as below.  

 

8. Press the Sheet Composition icon.  Populate the Sheet Composition dialog as below. 
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9. Dismiss the Sheet Composition dialog by clicking the X in the upper right hand corner. 

 Sheet Layout Process 

1. Press the Layout Sheets icon.  The Job Number will be set automatically from Project 
Manager. 

2. Double click on Port 1 to invoke the Plan Port Data dialog.  Select SC219R from the Chain 
dropdown list.   

3. Click the Create Motif File icon.  Select motif_seed.dgn as the seed file and key in a name of 
plan_motif.dgn as the Motif File. Click OK to create the new file.  The Plan Port Data 
dialog should appear as below.  Click OK.    

 

4. Double click on Port 2 to invoke the Plan Sheet Layout: Profile dialog. Select Profile 
SC219REP in the pull down box, then populate the Plan Sheet Layout: Profile dialog by 
pressing the Identify Cell button then graphically identify the profile cell to populate the 
dialog.   
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5. Click the Create Motif File icon.  Select motif_seed.dgn as the seed file and key in a name of 
profile_motif.dgn as the Motif File. Click OK to create the new file.  The Plan Sheet 
Layout: Profile dialog should appear as below.  Click OK.    

 

Note The X and Y coordinates may be different than what is shown in the dialog.  They should 
match the insertion points of your profile cell. 

6. Double click on Port 3 to invoke the Plan Sheet Layout: Tabular dialog.  Select Profile 
SC219REP in the pull down box, then populate the Plan Sheet Layout: Tabular dialog by 
pressing the Identify Cell button then graphically identify the profile cell to populate the 
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dialog.  Select profile_motif.dgn as the Motif File. The Plan Sheet Layout: Tabular dialog 
should appear as below.  Click OK. 

 

Note The X and Y coordinates will be different than what is shown in the dialog. 

7. Set the Beginning Station to 145+00. 

8. Click the Layout 5 Sheets button to draw the clipping borders into the design file. 

 

Note 5 clipping shapes should be placed for the plan port. 

Note 5 clipping shapes should be placed for the profile port. 

Note 5 clipping shapes should be placed for the tabular data port. 

9. Dismiss the Layout Sheets dialog by clicking the X in the upper right hand corner. 
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 Motif File Setup 

1. Open the file c:\data\geo\sc219\plan_motif.dgn. 

2. Attach the following references: sc219pp.dgn and sc219proposed.dgn. 

3. Turn levels on/off as desired in each view.  The levels displayed in each view will appear just 
like that on the sheets. 

4. Open the file c:\data\geo\sc219\profile_motif.dgn. 

5. Attach the following references: c219profile.dgn. 

6. Turn levels on/off as desired in each view.  The levels displayed in each view will appear just 
like that on the sheets. 

7. Open the file c:\data\geo\sc219\sc219pp.dgn. 

 Sheet Number Modification 

1. Click the Sheet Number Manager icon. 

2. Highlight all of the sheets in the list. 

3. Click the Edit Sheet Number icon along the right side of the dialog. 

4. Let’s set the starting sheet number to 6.  Click OK to renumber the sheets. 

 

5. The Plan Sheet Layout: Sheet Number Manager dialog should appear as shown below. 

 

Note This tool can also be used to resequence the order of the sheets. 

6. Dismiss this dialog.  When prompted to save the sheet number changes, click Yes. 
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 Clip Sheets 

1. Click the Clip Sheets icon.  Populate the Clip Sheets dialog as below.  

 

Note The Match Line prefix field has the following text:  MATCH LINE STA 
Make sure to include a blank space in the prefix field after the “A” in “STA”.  This will provide a 
blank space after the “A” and before the computed match line station text. 
 
The Match Line suffix field has the following text:  SEE SHEET NO. __ 
Include a blank space before the S in See. 

2. Toggle on Auxiliary Sheet Annotations. 

3. Double click the sample graphics box next to Auxiliary Sheet Annotations to invoke the 
Plot Parameters dialog.  Populate the dialog as shown below.  Click OK. 
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4. Click Process Sheets to create the plan and profile sheets. 

5. Close the Clip Sheets dialog. 

6. Close the Plan Sheet Layout dialog. 

7. When prompted to Save Settings, click Yes. 

8. Open any of the newly created files to see the resulting sheets.   

9. Exit MicroStation.   



8BLab Exercise:   Plan and Profile Sheets 
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19 
CHAPTER OBJECTIVES 

In this chapter, you will learn more about the operational modes of the D&C Manager including 
calculating automated quantities. 

INTRODUCTION 
The Design and Computation Manager (D&C Manager) is a tool that enables the user to standardize 
graphics elements for drafting and pay item quantities.  To review how to access the Design and 
Computation manager, see session 7. 

One of the major goals of any design project is the cost-effective development of plans production 
sheets.  This includes construction plans, profile sheets, estimated quantities, and various other sheets 
needed to actually construct the design.  Although generic MicroStation commands can be utilized to 
produce the required sheets, several GEOPAK tools can be used in conjunction with the Design and 
Computation Manager and these MicroStation commands  to help automate the process.   

Other GEOPAK tools are within the Design and Computation Manager and various plan view 
functions: 

• Controlling Various MicroStation Copy Functions utilizing the Place Influence option and the 
Design mode 

• Controlling the MicroStation Display Filters (Display mode) 

• Changing the MicroStation symbology via GEOPAK Items (Set mode) 

• Identification of plan view areas to incorporate into the automated quantities (Shape mode) 

• Plan view quantities (Compute mode) 

• Pavement Markings 

• Pavement Symbols 

ACCESSING THE DESIGN AND COMPUTATION MANAGER 
Design and Computations Manager can be accessed by selecting Applications > GEOPAK ROAD > 
Design & Computation Manager.  It can also be invoked from the GEOPAK ROAD Tools tool 
frame and the Plan View Design tool box in Project Manager. 

OPERATIONAL MODES 
Several operational modes are supported within the Design and Computation Manager.  The Design 
mode was discussed in session 7.  In this session, the following modes are reviewed: display, set, 
shape, compute and pavement markings. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 19-2 

Operational Modes 

 
DISPLAY 
Display mode is used to enhance on screen visualization by enabling the user to manipulate the display 
of GEOPAK intelligent elements.  

The feature(s) to be visualized are added to the Collection box – the bottom window of the D&C 
Manager dialog when set to Display or Compute modes.  Individual items or entire categories can be 
placed in the collection by utilizing the Add to Collection icon as shown below. 

     

Three display options are supported for the display of the items in the Collection box. 

• Highlight - changes those items stored in the collection area to the MicroStation highlight color. 

• Not - simply turns off the display of the collection items leaving everything else on. 

• Only - will turn off everything but the collection items. 

Before utilizing the display filters, visualization is enhanced if all the elements on the screen are gray, 
or another singular color, rather than the vast conglomeration of color seen on the screen for a typical 
project.  Therefore, to set the color, select Settings > Display from the menu bar.  The Display 
Preferences dialog appears. 

 

SET 
The Set mode allows the user to assign attributes from the ddb database to existing graphical elements 
in the file.  Three methods are available for specifying the graphic elements to be changed: individual 
element selection, Complex Chain or MicroStation Selection Set. 
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When changing individual elements, highlight the desired item in the D&C Manager dialog.  Click Set, 
then datapoint the element to modify, then datapoint off the element to accept. 

Complex Chain automatically creates a chain from graphic elements and applies the attributes of the 
highlighted item in the content box. 

To modify the symbology of many elements to a single item, create a MicroStation Selection Set of the 
elements.  Next, click Set to transfer the attributes of the item selected in the D&C Manager to the 
items identified in the MicroStation design file. 

     

COMPUTE 
An important, yet time-consuming part of any project is the computation of quantities. Through the 
Compute mode of the Design and Computation Manager, GEOPAK offers tools that make the 
completion of this task much quicker and easier.  In addition, since the software utilizes the plan view 
construction drawings to compile quantities, discrepancies between the drawings and the tabulated 
quantities are non-existent.  Chosen items within either the View or a Fence are calculated 
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Once the MicroStation plan view design file is accessed, the first step is to invoke the Design and 
Computation Manager and click the shortcut button at the top of the dialog to Compute. 

The dialog changes dynamically to reflect the compute operation. 

The Design and Computation Manager dialog is resizable.  Within the dialog, the sash (long, thin bar 
between list boxes) enables the user to adjust the partition between the list and collection boxes while 
the overall dialog size remains constant.  Simply place the cursor over the sash and dynamically move. 

In addition to dynamically adjusting the main dialog to reflect the compute operation, the auxiliary 
dialog is invoked as depicted below.  Note if the auxiliary dialog was already invoked from another 
operation, it dynamically changes to reflect the Compute operation. 

The next step is the selection of the correct item from the hierarchy.  GEOPAK computes quantities 
only for those hierarchical items that are configured for the computation of quantities. 

Two selection methods can be employed.  The first method is to select an entire category.  GEOPAK 
computes quantities for every item found in the selected category as well as any child categories.  This 
is accomplished by double clicking through the groups until the desired category is contained in the 
Content list box.  Single click onto the desired category and click the Add to Collection button at the 
top of the dialog. 

The second method involves the selection of individual features.  This is accomplished by double 
clicking through the categories until the desired item appears in the hierarchy list box.  When seen in 
the hierarchy list box, a single click onto the desired item and subsequent click of the Add to 
Collection button places the item in the Collection box. 

Options that apply to various Output types are detailed in the table below 

Note All Extents options are sensitive to the Inside, Overlap and Clip modes. 

Job Number GEOPAK Coordinate geometry database (GPK) file wherein the specified chain is 
stored. 

Extents > Active Design 
File 

If the Active Design File toggle is selected, all selected items that are in MicroStation 
file will be computed. 

Extents > View If the View toggle is selected, only selected items that can be seen in MicroStation view 
one will be computed.  If the view includes area outside of the Range, the Range will 
override. 

Extents > Fence If the Fence toggle is selected, a fence must be placed, and all specified graphical 
features which are inside both the fence and the Range will be tabulated. 

Extents > Boundary 
Element 

If the Boundary Element toggle is selected, all selected items that are in a selected 
Boundary Element will be computed. 
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Extents > Station Range If the Station Range toggle is selected, all selected items that are within a selected 

Station Range will be computed. 

Extents > Sheet Range If the Sheet Range toggle is selected, all selected items that are in a selected Plan Sheet 
Clip Boundary will be computed. 

Extents > Selection Set If the Selection Set toggle is selected, all selected items that are in a MicroStation 
Selection Set will be computed. 

Extents > Boundary 
Selection Set 

If the Boundary Selection Set toggle is selected, all selected items that are in a group 
of boundary elements within a MicroStation Selection Set will be computed. 

Highlight During 
Computation 

When activated, all MicroStation elements utilized in computations are highlighted in 
the selected color. 

Baseline Reference > 
Chain 

Requires a minimum of one chain which must be stored in the specified job number.   

Baseline Reference > 
DGN 

The user can graphically select a DGN Element to be used as a Baseline Reference. 

Baseline Reference > 
None 

When None is selected, nothing is used as a Baseline Reference. 

Identify Chain The Identify Chain Selector allows the user to graphically select the desired chain.   
Range Left and right offset limits (in master units) from the chain where the quantities will be 

computed.  Any specified item located outside of the limits is not included in the report 
Begin/End Station Station range for computing quantities 
Compute Quantities Commences the computation process. 

 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 19-6 

Operational Modes 

 
After the desired quantities have been computed, a second dialog will be displayed containing the 
computed quantities.  The dialog is shown below. 

 

Several output formats are available as described in the table below. 

Comp Book  A more detailed report that lists not only quantity summaries, but also geometric 
properties such as plan view coordinates and station/offsets for located elements.  
File is in ASCII format. 

Item Report Quantities Summary listing pay items, descriptions, units and total quantities for 
located elements.  File is in ASCII format. 

Item Tables  Contains the same information as the Item Report, but formatted in tabular form. 
DBMS Very detailed information including calculated and rounded quantities, geometric 

properties, pay item numbers, descriptions, station / offset values, etc. The format is 
the selected database (i.e., Microsoft Access, Oracle, SQL Server, and dbase. 

CSV By Item Quantities Summary listing pay items, descriptions, units and total quantities for 
located elements.  Format is in CSV format. 

CSV By 
Element  

A more detailed report that lists not only quantity summaries, but also geometric 
properties such as plan view coordinates and station/offsets for located elements.  
Format is in CSV format. 

 
Run A method of grouping various quantities and / or pay items. 
Phase Quantities can be separated into various phases, as a means to group various pay 

items.  Default phases include:  Design, Preliminary, and Final.  Note the user can 
add new phases, but must be aware of naming limitations of downstream 
applications (i.e., Transport links in Quantities Manager.) 
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SHAPE 
The placement of shapes for area quantities is simple and fast when utilizing the shape mode.  In order 
to place a shape, GEOPAK must identify a closed area.  This area can be defined by intersecting 
elements, which do not have to be clipped or shortened to define the closed area.  There are three 
options for placing shapes depending on the complexity of the plan view and the type of area where 
quantities are desired: 

·Semi-auto - utilized when the plan view has more conflicting elements or where the selection of an 
area produces very small shapes.  In this method, the user is prompted when each element is selected to 
determine the path of the software in producing shapes. 

·Automatic - best utilized when the elements forming the shape do not conflict with other elements in 
the view. 

·Exclusive - This option utilizes the automatic option, but in addition, prompts the user for the 
identification of an area inside the original shape that is excluded from the area quantity.  The Exclude 
mode is useful for curb and gutter around a traffic island. 

Any of the three options may be chosen during the course of shape placement.  To change from one 
option to another, simply adjust the option button on the right side of dialog. 
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PAVEMENT 

 

The Pavement mode allows the user to place pavement marking including striping, and symbols.  The 
various tools are detailed in the table below. 

Striping 

 

Places single or double, solid or skip pavement stripes. 

Separation 

 

Places traffic separation pavement marking. 

Chevron 
Diverge  

 

Places pavement chevrons in areas of diverging traffic. 

Chevron 
Merge 

 

Places pavement chevrons in areas of merging traffic. 



 
GEOPAK Road I Copyright © 2005 Bentley Systems, Incorporated Do Not Duplicate 

5/15/2008 19-9 

Operational Modes 

 
SINGLE STRIPING  
This dialog offers predefined configurations for single stripe and 
double stripe options to easily control the type of striping being 
placed. 
The pay item reflects the currently selected pay item in the 
D&C Manager dialog; however, it may be changed at any time 
during the process. 
Next, define the start option by selecting Solid or Skip (or a 
combination thereof).  If Skip is active, the user must define the 
stripe and skip lengths.  If an ending stripe is shorter than the 
Tolerance value, it will not be drawn. 
The lower portion of the dialog box provides tools for 
identifying the reference element on which the striping will be 
based.  The Reference Element can be defined by DGN Element 
or a Chain stored in the GPK file. 
A Begin and End station range can be defined as well as an 
offset. 

 

After clicking Draw Stripes, the user must enter a data point on either side of the reference element to 
begin striping.  Striping is placed at the indicated offset value; the data point controls whether striping 
is offset left or right.  Striping is placed as a graphic group. 

DOUBLE STRIPING 
The process for Double Striping is the same as Single, except 
for having two pay item placement options, Inside and 
Outside and a user definable Distance Between Stripes.  The 
user must select either the Inside or Outside button for the 
highlighted (D&C Manager) pay item to be displayed in the 
dialog box.  Separate quantities are calculated for each stripe.  
The remaining process is the same as described above. 
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SEPARATION 

This option draws pavement markings between two sets of 
selected elements.  Elements may be either GEOPAK or 
MicroStation generated.  
Once a pay item has been selected, the user may set the 
Distance Between Stripes and the Slash Stripe Angle.  
Tolerance functions the same as for striping. 
A Begin Point and End Point should be issued before the 
Reference/Pivot Point is identified.  The Reference DP must 
fall between the beginning and ending DP.  It marks the 
location of the first pavement marking and determines the 
direction of the slashed stripe.  All other markings will be 
based on the first stripe. 
 

 

Tools for defining the limits of the pavement markings are located at the bottom of the Separation 
dialog box.  Side 1 identifies the elements where the striping will terminate.  Side 2 is the set of 
elements from which the striping begins. 

After the Draw Separation button is selected, the user must issue a data point in the graphics file for 
the pavement markings to be displayed. 

CHEVRON DIVERGE 
Once the pay item and its relative parameters have been defined, 
there are three points needed to define the chevron: Gore Point, 
Breaking Line, and Diverge Point. 
The Gore Point defines the wide end of the gore. 
The Breaking Line point must fall between the two sides of the 
gore and sets the location of the point at which the chevron diverts 
in a different direction. 
The Diverge Point represents the narrow end of the gore where 
chevrons are to stop. 
Use the Side 1 and Side 2 buttons to identify the sides of the gore.  
Once the Draw Chevron Diverge button is selected, the chevrons 
are displayed. 
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CHEVRONS MERGE 

This process works basically the same as Chevron Diverge 
except the two points, Gore/Break Point have been combined 
into one point that serves both functions and should be located 
near the wide end of the chevron.  
The Merge Point should be located near the narrow end of the 
gore.  It simultaneously sets the beginning of the pavement 
markings and the point at which the chevron will break. 
The remainder of the process is as described above. 

 

QUANTITY MANAGER 
Quantity Manager is an application designed to manage design quantities with a direct connection to 
GEOPAK Design and Computation Manager. 

FEATURES 
Features include: 

• Standalone application for managing design quantities.  Neither MicroStation nor GEOPAK 
is required for utilizing the Quantity Manager 

• Intuitive interface to organize quantities by payitems, by stations, by units of measure etc. 

• Special treatment for rounding and lump sum items. 

• Support CAD file quantities as well as non-graphic quantities. 

• Manual input and modifications. 

• Interface with estimating systems for payitems and funding sources. 

• Custom report capabilities. 

• Funding computations. 

• Cost estimates. 

• Cost comparison. 

Several Database Management Systems are supported, including: 

Microsoft Access 2000, Oracle, and SQLServer  
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ACCESSING QUANTITY MANAGER 

Quantity Manager can be accessed by selecting Applications > GEOPAK ROAD > Quantity 
Manager.  It can also be invoked from the GEOPAK ROAD Tools tool frame or by double-clicking 
the icon from the desktop. 

INVOKING THE MAIN DIALOG 
When the Quantity Manager tool is selected, the Quantity Manager dialog depicted below opens. 

 

THE QUANTITY MANAGER DATABASE 
The quantity manager database consists of multiple relational tables.  The information stored in each 
table is described below. 

Tables - Information Stored 

Project - General information about the project.  Project name, descriptions, spec year etc. 

Chain - Information on baselines used for computing stations and offsets of quantities 

Phase - A phase is a way to group quantities.  A typical usage is to organize different phases of a 
project (design phase, construction phase), or to break down quantities from different departments or 
divisions, or for staging quantities.  A filter to view quantities by phase is provided.   

Pay Item  - The basic definition of a payitem – name (or pay item number), description, unit of 
measure, unit cost etc.   

Quantity - The quantity associated with each pay item is the sum of all individual quantities for that 
payitem.  For example, 20 pipes each with length 50' in length will correspond to 20 quantity records, 
one for each pipe.  

Element - For each quantity, there may be one or more associated elements.  The element table is only 
needed when graphic quantities are quantified.  For example, a single pipe will have one quantity 
record (linear feet) and one element record (a line element), however, a pavement area will have one 
quantity record (square feet or yard), but multiple element records composing the perimeter of that 
pavement area.  

Vertex - For each element, there may be one or more associated vertices.  A line element will have two 
vertices, a line string will have many, and a rectangular shape will have five (1, 2, 3, 4, 1).  
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Payer - This is a list of payer (funding sources) that will be participating in funding computations.   

Funding Rule - This is a list of funding rules.  Each funding rule is made up of a list of participating 
payers, and their corresponding participating percentages.  A funding rule may optionally carry a 
station range, in the event that certain payitems may be funded differently at different stretches of a 
project. 

PULLDOWN MENUS 

When a database is opened or created, tools on the menu bar are undimmed, as depicted in the graphic 
below.  Six menus are supported on the menu bar. 

 

PROJECT 
New Creates a new database by opening the Create Database dialog box. 

Open Opens the Connect To Database dialog box, wherein the desired database may be 
selected, and User Name and Password defined. 

Close Closes the current project (database) but does not exit the Quantity Manager. 
New 
Phase 

Used to separate a project into smaller, more manageable groups for large projects.   
Each sub-group can be reviewed, manipulated, etc., or all groups can be manipulated 
simultaneously.  If desired, only one phase can be used. 
Click OK to create the New Phase, and open the Phase Property dialog box. 
Additional phases may be added, phases may be deleted, and the Funding dialog can 
be opened from the action icons at the bottom of the dialog. 

Import Payitems can be imported into the current category from an aecXML document 
displayed in the Select Payitems dialog.  The Search Mask enables the user to specify 
the initial part of the Payitem to filter the list. 

Export Two export types are supported in GEOPAK Quantity Manager: 
·GEOPAK QM XML – this will export an XML document that conforms to the 
standard GEOPAK schema.  The schema document is supplied with the install and 
resides in schemas/qm.xsd. 
·aecXML which can subsequently be imported into AASHTO's Trns*port software for 
estimating purposes. 

Properties Opens the Project Properties dialog box, which is also displayed when a project is 
created. 
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History 
List 

Lists previously created or opened databases.  This short-cut enables users to select 
databases used in previous sessions. 

Exit Closes the Quantity Manager. 

EDIT 
Select All Highlights all payitems entries in the current quantity pane. 
Unselect 
All 

Unselects all payitem entries in the current quantity pane.   

Delete Deletes the highlighted item or category from the database.  If a category is 
highlighted, all child categories and payitems are also deleted.  An Alert message is 
displayed prior to any deletions. 

Rename Renames the selected category or payitem.  Please note that the highest level category 
(root) may not be renamed. 

Phase Opens the Phase Properties dialog, where phases can be added, deleted and the 
Funding dialog invoked. 

Funding Two options  are supported: 
Payer – List of Payers and Description utilized when defining funding rules.  Payers 
can be added, deleted or imported from an aecXML funding source document. 
Funding Rule – List of funding rules utilized when defining funding splits for 
quantities.  Rules can be added, deleted, or modified from this dialog. 
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VIEW 

Refresh Updates all displayed fields from the database. 

Columns Three modes are supported: 
·Payitem Table 
·Quantity Table 
·Element Table  
For each mode, a list of fields within the database is displayed.  The user may select 
or unselect which fields are hidden and which are displayed.  The options within the 
columns vary based on the select of the Table type.  Any item toggled on is 
displayed in the table, any item not toggled is hidden. 

Expand 
Category 
Quantities
  

This is a check/toggle to specify the content of the quantity pane when a category is 
selected.  If it is checked, the quantity of the selected category will be displayed, 
along with all quantities in all subcategories.  If it is checked off, the quantity pane 
will only show quantities in the current selected category, one level deep. 

Expand 
Tree  

When chosen, all categories, sub-categories, and pay items are expanded in the 
Payitem Tree (not the Payitem Table).  Note the graphic on the left is the default 
table, where only root is shown, while the graphic on the right is after the tree is 
fully expanded. 

Collapse 
Tree  

When chosen, all categories, sub-categories, and pay items are collapsed in the 
Payitem Tree (not the Payitem Table), so that only the highest level category in the 
hierarchy is shown.  Note the graphic on the left an expanded tree with several 
categories, sub-categories and payitems, while the graphic on the right is after the 
tree is collapsed, and only the Pay Items category is displayed. 

Normal When chosen, changes the database layout to normal view, where the payitem table 
is on the left, while the quantity and element tables are one above the other on the 
right side.  If the view is already normal, no changes occur. 

Tile 
Horizontally 
  

When chosen, changes the database layout to horizontal view, where the three tables 
are one above the other.  If the view is already horizontal, no changes occur. 
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INSERT 

Category
  

Insert a category from the current selected category.  Three modes are supported: 
·Above… 
·Below…. 
·Sub-category 
New categories can be added anywhere within the database hierarchical structure. 

Pay Item
  

Insert a payitem from the current selected category or payitem.  Three modes are 
supported: 
·Above… 
·Below…. 
·In Category 
New pay items can be added anywhere within the database hierarchical structure.  To 
add a single item above or below a payitem already in the table, select that payitem 
then use the Above and Below modes.  To add an item at the bottom of a category, 
select the category first, then utilize the In Category mode. 

Quantity Insert a quantity to the current selected payitem. Based on the source of the 
computations, some data may be dimmed and not available for modification.  The 
quantity property dialog is divided into a general tab and a location tab. 

TOOLS 
Reports Provide tools to define custom report styles and create reports.  Two modes are 

supported: 
·Create 
·Define Styles 

Reports > 
Create  

Create a report of the selected payitem(s) of the active phase.  The user may choose 
the desired report style and report document type.  Only document type supported 
currently is PDF (Adobe Portable Document Format). 
Once the document is created, the default viewing application will be launched. 

Reports > 
Define 
Styles 

Opens the Report Styles dialog, wherein. new report styles may be added, and 
existing report style may be modified and deleted.   

HELP 
About 
GEOPAK 
Quantity 
Manager 

Activates the About GEOPAK Quantity Manager dialog. 

Contents Activates the GEOPAK Quantity Manager online help document. 

CREATING A QUANTITY MANAGER DATABASE 

Quantity Manager databases can be created in two distinct methods: 

• Creating a new quantity manager database within Quantity Manager via Project > New on 
the menu bar. 

• Creating a new quantity manager database with Design & Computation Manager. 
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DESIGN AND COMPUTATION MANAGER 
1.  Create the database within GEOPAK Design and Computation Manager – Compute mode. 

2.  Click on the Quantity Manager icon on your desktop. 

3.  Select Project > Open and identify the database created in step 1. 

ENTERING DATA 

Quantities may be added to the Quantity Manager in two basic methods: 

• Automatically generating quantities utilizing the GEOPAK Design and Computation 
Manager.   

• Manual entry, i.e., typing the information into the Insert > Quantity tool. 

A combination of methods can also be utilized.  The user may import the quantities which are 
represented graphically via the Design and Computation Manager method.  Then non-graphic 
quantities, such as mobilization, earthwork quantities and lump sum items can be added manually.  

DESIGN AND COMPUTATION MANAGER 
Utilizing the GEOPAK Design and Computation Manager is an efficient method of automatically 
generating plan-view or graphic quantities.  One output of the D&C Manager is the QM database.  In 
this case, the payitems within the D&C Manager, method of computation, computation values, element 
information (coordinates, curve radius, etc.) and other data are imported into the QM database.  For 
more details on how to capture quantities via D&C Manager, refer to the online help in GEOPAK 
Road or Site. 

Once payitems are entered into the QM database, they can be reviewed, and in some cases modified.   
Funding splits can be performed.  Non-graphic quantities can also be added by the manual entry 
method. 

MANUAL ENTRY  

To create a new quantity, select payitem, then invoke Insert > Quantity from the pulldown menu or 
Insert Quantity from the pop up menu. 
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Two tabs are supported.  The General tab has a variety of different quantity options, as well as 
descriptions and other general information.  The Location tab has key-in fields for minimum and 
maximum station / offset values.  

EXPORTING FROM QUANTITY MANAGER DATABASE 

Exporting data from Quantity Manager is accomplished by selecting Project > Export, opening the 
dialog box depicted below.  

 

Active 
Phase  

Only a single phase may be exported at one time.  If All Phases is selected, the 
Export button is disabled.  Although the Active Phase cannot be changed (display 
only) in this dialog, a Phase change made in the main dialog automatically changes 
the Export dialog box. 

Export Style Five export schemas are supported: 
Payitem (GEOPAK QM XML) is the standard schema used for creating custom 
reports.  The schema is delivered with Quantity Manager under 
qm/schemas/qm.xsd. 
Payitem + Funding (GEOPAK QM XML) 
Payitem + Quantity (GEOPAK QM XML) 
Payitem + Quantity + Element (GEOPAK QM XML) 
Payitem + Quantity Sorted (GEOPAK QM XML) 

Document 
Type 

Displays the document type to be exported. 

Document 
File Name 

Key in the File Name or select via the Browse button. 

Note In order to export a Trns*port compatible file, the phases, and funding rules must comply with Trns*port nomenclature.
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LAB EXERCISE:   PLANS PRODUCTION WITH D&C MANAGER 

 Accessing Plans Production Tools 

1. Open the MicroStation file c:\data\geo\road1\plan.dgn. 

2. Access Project Manager. It should automatically access the Road workflow dialog since we 
“remembered” the options in Lab 2. 

3. Click Plan View Design. 

This opens the Plan View Design tools tool frame.   

4. Open Design and Computation Manager.  

 Pavement Striping - Skip 

In this section, we are placing pavement striping parallel to the main alignment. 

1. Change the Mode to Pavement Marking and select Pay Items > Pavement Marking > 710-
72 Skip Traffic Stripe (LF). 

 

2. Select the Striping Operation as shown above to access the Striping dialog. 
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3. Populate the dialog as shown below. 

 

Note Note:  Be sure that your graphic group lock is off before the next step. 

4. Click Draw Stripes.  The striping is attached to the cursor.  You can move to either side of 
the baseline and place the striping.  Data point on the left side of the alignment. 

5. Click Reset. 

6. Click Draw Stripes again to place the striping on the other side of the road. 
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 Pavement Striping – Solid 

1. Change Single Stripe A to Double Stripe A. 

2. Click the Inside and Outside buttons to select the current pay item from the ddb file. 

3. Set the Distance Between Stripes to 1.0. 

4. Change the option button to Solid/Solid for placing a dual solid line. 

5. Set the Offset to 0.00.  

 

6. Click Draw Stripes, then move the cursor to the view and issue a data point then a reset. 

7. Close the striping dialog , but leave the main D&C Manager dialog active. 

 Compute Quantities 

1. Change the current D&C mode to Compute. 
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2. Click item 710-72 Skip Traffic Stripe (LF) to make it the active item for computing 

quantities. 

3. Populate the supplemental dialog as shown below. 

 
4. Since we are doing the quantities based on what is displayed in View 1, be certain to fit all 

pavement marking in View 1. 

5. Click Compute Quantities.  Update the view so that the elements are no longer highlighted.   

6. Review the output.   

 
7. Next we will export the quantities to an Item Report.  Set the Export Format option to Item 

Report.  Enter the output file name item.txt.  The dialog should appear as below. 

 
8. Click Export.  A file named item.txt should be created in the working directory. 
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9. Open item.txt using the GEOPAK editor.  The file should appear as below. 

 

10. Close the GEOPAK editor, but leave the main D&C Manager dialog active. 

 Create Quantities Manager Database 

1. Set the Export Format to DBMS on the Computation Results dialog.  The output file name 
should change to item.mdb. 

 
2. Click Export .  A file named item.mdb is created in the working directory. 

3. Close all D & C Manager dialogs. 

4. Select Application > GEOPAK ROAD > Quantity Manager.  

 



The Quantity Manager Database 

 
5. Select Project > Open.  Select C:\data\geo\road1\item.mdb. 

 

6. Click Connect. 

7. To review the quantities exported to the Quantity Manager database, navigate to item 710-72.   

 

8. Close the Quantity Manager. 

9. Exit MicroStation. 
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