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Introduction 
 
On April 17, 2000, the Hydraulic Engineering Section of the South Carolina Department of 
Transportation adopted GEOPAK Drainage as our primary storm sewer design package. Due 
to the many specifications that need to be set to run the program, the best plan was to 
write a manual to aid everyone using the software. It is not the purpose of this manual to 
provide you every piece of information needed to run the program. Additional resources are 
available through online help and training manuals.  
 
Most of our other programs are much simpler to set up, so when misinformation is entered 
it can be easily found and corrected. GEOPAK has many settings that can cause the program 
to crash that you could spend several hours looking for that one incorrect specification. This 
manual was created to help avoid such errors and to set standards for naming conventions, 
levels, colors, etc. so our information would be easily transferable to the Roadway Designer. 
Never before has another office worked so closely with output from one of our programs. 
This is why it is critical that we are consistent with documentation so others can read our 
information.  
  
This manual does not supersede the Requirements for Hydraulic Design Studies of the 
Department. Careful attention should be paid to those requirements and every effort made 
to adhere to them.  
  
SCDOT still possesses other storm sewer design packages, and there may be a time when 
one of these methods is the best solution for a particular situation. The Hydraulic Designer 
will make that determination. If you must use another program, please notify the Roadway 
Designer immediately to inform them that you will be submitting red lined plans for their 
use. Some information like riprap pads and outfall improvements will still need to be red 
lined. We will not be required to forward any MicroStation files with notes.  
  
GEOPAK Drainage, like all other hydraulic programs, gives you the best design and analysis 
based on the input. Engineering judgment must be used to evaluate the output that the 
program produces. You must check all data carefully and make determinations on the 
validity of the answers based on your knowledge of hydrology and hydraulics.  
  
Do not be surprised to find that the program overrides some of your specifications. The 
program has the ability to change your Preferences and Constraints in order to design the 
system. The Preferences and Constraints are just guidelines to give the program a starting 
point to work with; therefore, it is imperative that you check all of your output for validity.  
  
All specifications required to run the program will be added to this manual at the 
appropriate time. You will also be receiving updates for the storm sewer part as they are 
published.  
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NOTE TO CONSULTANTS:  Consultants are to follow the standards set forth in this manual 
and the Requirements for Hydraulic Design Studies. The only procedural change that differs 
for consultants is discussed under Downloading & Organizing Files and Uploading Files. The 
consultants will obtain Road Design’s files and send their data back to the Hydraulic 
Engineer, not the Roadway Designer, via electronic means as designated by SCDOT. All 
other guidelines are to be adhered to as stated.  
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Chapter 1: Data and Organization 
1. Drives 
Network Locations and Workspaces 
Preconstruction Data Folder Structure 
  
P:  \\nts\hq\precon 
  
The hydraulic, roadway, geotechnical, and structural project files are consolidated by county 
on the network drive designated as the “P” drive.  This drive serves as a central location for 
hydraulic, roadway, geotechnical, and structural CADD and data files that are project related 
and are sorted by county and Project ID number.  New projects as well as current projects 
are stored at this location.  \\nts\hq\precon  
  
Example of a hydro folder located in Lexington County on the “P” drive: 
 

 
  
MicroStation and Geopak Workspaces 
  
MicroStation and Geopak uses a custom workspace that is available to every CADD user.  
The workspace automatically controls access within MicroStation to the most current cell 
libraries, reference border sheets, drainage files, etc.   
  
Network path 
\\nts\hq\CaddStandards\SCDOT-Bentley\Standards\SCDOT_Design\   
  
When entering MicroStation, the User and Project should be set to SCDOT_Design with the 
Interface set to the NTS user name: 
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Drainage Library (DLB)  
  
The current version is:  SCDOT_english_2018_Alt.dlb 
  
\\nts\hq\CaddStandards\SCDOT-Bentley\Standards\SCDOT_Design\Geofiles\Drainage  
  
Cell Library (CEL) 
  
\\nts\hq\CaddStandards\SCDOT-Bentley\Standards\SCDOT_Design\MSfiles\cell\RoadV8.cel  
   
GEOPAK (DDB) 
  
\\nts\hq\CaddStandards\SCDOT-
Bentley\Standards\SCDOT_Design\Geofiles\Database\scdot_engV8.ddb  
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2. Files 
 
File 
Type:  GPK 

Type Binary 

Acronym GPK = GeoPaK 

Use Stationing, Profiling and Reporting 
 
Through GEOPAK Drainage we will read the *.GPK file that the Roadway Designer produces 
to obtain the pgl and chain files for placing drainage nodes.  The Roadway Designer will 
provide the names for the centerline profile and chain, all side road profiles and chains, and 
any curb grade profiles.  From these files GEOPAK Drainage will automatically read curb 
grades and identify the centerline stationing of mainline and side roads.  The *.GPK file is 
extremely valuable.  The *.GPK file will usually be named job###.gpk.  The ### will be 
the last 3 digits of the Project ID number. 
 
File 
Type:  PP.DGN 

Type Binary 

Acronym DGN = DesiGN 

Use Plan View 
 
The pp.dgn file is the plan view of the project. It is shown exactly as surveyed. The pp.dgn 
file will usually be named r#####pp.dgn. The ##### is the Project ID number. The .dgn 
is the designation for all MicroStation design files. 
 
File 
Type:  PF.DGN 

Type Binary 

Acronym DGN = DesiGN 

Use Plan & Profile View 
 
The pf.dgn file is the plan and profile view of the project as it appears on the plan sheets. 
There will be more than one of these files for every project unless the project is very small. 
You will not need this file for GEOPAK Drainage. You may need to open these files to get tie 
equalities or look at some of Roadway Designer’s notes. 
The pf.dgn file can be named many different things. Some squads name them by the 
Project ID number, i.e. 12345pf.dgn, 1234apf.dgn, 1234bpf.dgn… Some squads name them 
by the road, i.e. sc100pf.dgn, sc100apf.dgn… The Roadway Designer will provide the names 
for these files. 
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File 
Type:  HY.DGN 

Type Binary 

Acronym DGN = DesiGN 

Use MicroStation file for Geopak Drainage design 
 
This is the MicroStation file that you will do all of your design in when running GEOPAK 
Drainage. You will need to create this file. It will be named using the same conventions as 
the pp.dgn file.  Basically we will reference Roadway Designer’s pp.dgn file into our created 
hy.dgn file. This will allow us to view the road, but our design will be in another design file. 
If the Roadway Designer changes the pp.dgn file, it will not affect our design. This will be 
discussed in the Downloading & Organizing Files section. 
 
File 
Type:  *.NEW 

Type Binary 

Acronym NEW = NEW 

Use Survey shots 
 
The .new file contains a list of all surveyed points. In the past, the Hydraulic Engineer used 
this file to determine pipe elevations from plans.  The .new is usually named a series of 
numbers with part of those numbers being the Project ID number. Any additional surveys 
submitted for the same project will follow the same naming convention but will add an A, B, 
C, etc. to the file name to be sent to the Roadway Designer. You will not need this file for 
GEOPAK Drainage. 
 
File 
Type:  *.CEL 

Type Binary 

Acronym CEL = CELL 

Use Used for placing Node Cells 
 
The Cell Library is used for placing Drainage Nodes into the HY.DGN file. 
 
File 
Type:  *.DDB 

Type Binary 

Acronym DDB = Design DataBase 

Use Used for computing quantities 
 
The Design & Computation Manager database file can be used to compute drainage 
quantities. 
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File 
Type:  *.GDF 

Type Binary 

Acronym GDF = Geopak Drainage File 

Use Stores the drainage components 
 
The .gdf is short for Geopak Drainage File. We will produce this file when we create a design 
in GEOPAK Drainage. It contains all of our preferences, nodes, links, networks, profiles and 
output. This file references our Drainage Library, cell library, and the Roadway Designer’s 
GPK File. NOTE: The GDF file is not a MicroStation file, but MicroStation uses this file to plot 
our basins and pipes. This is a file that you will upload for the Roadway Designer to aid 
them in labeling the plans. Name your .gdf files according to the naming convention 
discussed in the New Project section. The naming convention must be followed for 
consistency. You will only have one .gdf file per project. Even if you have multiple roads on 
one set of plans and you need to design storm sewers for all of them, you will still have only 
one .gdf file. Normal in-house projects have one designer assigned to that project, but 
consultant and large in-house rush projects will have several people working on them. If 
multiple people work on a project at the same time, then there will be multiple .gdf files. All 
.gdf files will need to be merged before they are sent to the Roadway Designer for labeling. 
 
File 
Type:  *.DPF 

Type Binary 

Acronym DPF = Drainage Preference File 

Use Loading Project Preferences  
 
The .DPF file references all necessary standard files needed when setting up a .GDF. These 
files are named according to the rainfall station that the file references. Once settings are 
loaded, they will be saved in the *.GDF. 
 
File 
Type:  *.DRF 

Type Binary 

Acronym DRF = Drainage Report Format 

Use Standard Report format for the output CSV files 
 
The DRF file is the standard Drainage Report Format file created in-house that contains the 
information format that is required for our standard reports. When you run these files they 
will automatically generate the CSV files that contain the output data that you will cut and 
paste into our standard output files. The .drf files that you will need to run have been preset 
and are on the server. This will be discussed in the Reports section. These files are 
areastandard.drf, nodestandard.drf, linkstandard.drf, nodestandardroad.drf, 
linkstandardroad.drf, which need to be run for each storm sewer system, and nodesum.drf 
and linksum.drf, which are not storm sewer specific. The last two files mentioned are the 
summation of all the nodes and links, respectively, for the entire project. 
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File 
Type:  *.CSV 

Type ASCII 

Acronym CSV = Comma Separated Values 

Use EXCEL™ file 
 
The CSV file is the output file that you will make through GEOPAK Drainage that is readable 
inside of EXCEL™. It will only contain the information that the DRF file requested to be 
obtained. There will be multiple files for every network (storm sewer system); three for our 
records and two to send to the Roadway Designer. This will be discussed in the Output 
section. 
 
File 
Type:  *.DLB 

Type Binary 

Acronym DLB = Drainage LiBrary File 

Use Geopak Drainage Library file 
 
The DLB File is the Drainage Library File. You will download a copy of this file into your 
project directory. This file is discussed in the Drainage Library section.  

 
This file will not email as is. You must place it into a zip file first.  Right-click the file and 

select Send To->Compressed (zipped) folder 
 
 
 
File 
Type:  *.TIN 

Type Binary 

Acronym TIN = Triangulated Irregular Network 

Use Stores 3d surfaces 
 
The TIN File is the Triangulated Irregular Network file and is used to represent the existing 
or proposed 3D surface. 
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3. Exchange of Information 
 
Per Instructional Bulletin No. 2005-8, you should receive the following information from the 
Roadway Designer to begin a design.  The submittals from the Roadway Designer should be 
checked to ensure that all the information was received by the Hydraulic Engineer.  The 
Hydraulic Engineer should also check to ensure that submittals to the Roadway Designer are 
complete. 
 
Information to be Obtained from the Roadway Designer for the Hydraulic Engineer 
  
Hard Copy 

1.      Cross Sections to scale on half size sheets 
a. Mainline 
b. Side roads 
c. Outfall ditches 

2.      Plan Sheets to scale on half size sheets 
a. Centerline final grades for mainline 
b. Final grades for side roads 
c. All outfall ditch surveys 
d. Limits of construction line 
e. All existing survey pipe recommendations 

  
Electronic Copy 

1. Project .GPK file 
2. Project PP.DGN file 
3. Project PF.DGN file 
4. Project DX.DGN & FX.DGN files 
5. Project .NEW file 
6. Excel file containing survey data, including control points 
7. Centerline and top of curb pgl’s. 
8. Project curb grades 

  
Information to be Provided for the Roadway Designer from the Hydraulic Engineer 
  
Hard Copy 

1. Plan sheets stating which existing pipes are to be abandoned or retained. 
  
Electronic Copy 

1. Project .GDF file 
2. Project .DLB Drainage Library file (if modified for project exceptions) 
3. Project HY.DGN file 
4. List of file locations and file names of requested information emailed to the 

Roadway Designer 
5. Proposed ditch cross sections 
6. Alternate Pipe spreadsheet 
7. Erosion Control Data Sheet 
8. Additional erosion control BMP recommendations as appropriate 
 

  
Explanation of common plan sheet items -- On the plan sheets, the limits of construction 
line is the cut/fill line.  Also in the plan sheets, you will find the survey recommendations to 
abandon or retain a pipe. 
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4. Downloading & Organizing 
 
The Roadway Designer will email you a Hydraulic Information spreadsheet containing a 
list of CADD and survey files that you will need to copy from the project road folder to the 
hydro folder located on the “P” drive. 
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Navigate to the project directory on the “P” drive under the road subfolder.  Highlight the 
files listed in the index file by using the ctrl + click method to select multiple files at one 
time.  Right click and select copy.  Navigate to the hydro subfolder under the same project 
directory and right click and select paste. 
 

 

 
Be certain to copy, not cut, the files from the road folder into the hydro folder.  Files should 

remain intact in the road folder at all times. 
 
For consultants, the Roadway Designer will provide the spreadsheet and deliverables 
electronically to the consultant. 

5. Hydraulic Engineering Files 
 
• You will need to download the english.DLB Drainage Library file from 

\\nts\hq\CaddStandards\SCDOT-Bentley\Standards\SCDOT_Design\Geofiles\Drainage 
into the project directory on the network. 

• You will need to create the hydrology file *#####hy.dgn (refer to pp.dgn for symbol 
significance). This can be done as follows:  

1. Open Microstation. 
2. In the File Open screen, click the “New File” button. 

 
3. Enter the name of the new hydrology file in the File Name box at the bottom of 
the window. 
4. Check the Seed box below File Name.  It should be directed to 
\\nts\hq\CaddStandards\SCDOT-Bentley\STANDARDS\SCDOT_Design\MSfiles\ 
seed\seed2d.dgn.  If not, enter that address in the box or browse to that directory 
and select seed2d.dgn. 
5. Press Save to return to the File Open menu, then select the new hydrology file 
and press Open. 

• Next, you need to reference in the pp.dgn file as follows:  
1. Go to File>Reference.  
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2. Go to Tools>Attach… Choose the pp.dgn file in your project directory. When it 
asks for a logical name just enter a 1.  
3. In the Reference window beside the pp.dgn that you just entered, put a √ under 
the Snap column. This will allow you to snap to the reference file, but not delete 
anything.  
 

It should appear as if you are looking at the plan view of the project. The greatest 
difference now is that you cannot manipulate anything currently on your screen. It is purely 
for viewing. Now the hy.dgn file is ready to use through GEOPAK Drainage.
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Chapter 2: Initial Settings 
 
1. Start a New Project 
 
To start a new Drainage Project: 
 

1. Open your hy.dgn MicroStation file.  
2. From MicroStation, select Applications>GEOPAK DRAINAGE>Drainage (if GEOPAK is 

not activated select Applications>GEOPAK>Activate GEOPAK). 
3. You should now have a new menu item by Applications titled Drainage.  
4. Selecting Drainage>Project>New… Name the file after the road being improved, i.e. 

SC100.GDF (this is the GDF file that will contain all of your work and be sent to 
Roadway Designer). 

 
 
 
 
 

 
 

GEOPAK Drainage always starts in an untitled project; it does not remember or 
automatically reopen a GDF that was previously worked in. The .GDF file must be reopened 
manually each time you open the hy.dgn. Select Project > Open each time you start to edit 

or continue working on a project.  
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2. Preferences 
 
Set the Preferences as necessary at any time during project design or analysis, from the 
main menu bar select Project > Preferences: 
 

         
                            
To establish the Preferences of a new project, navigate in Windows Explorer to   
 
\\nts\hq\precon-general\Hydraulics\Standard Files_GEOPAK\DPF Files 
 
Select the appropriate *.DPF corresponding to your project and copy and paste it to your 
working directory. In Geopak Drainage, go to Preferences, File>Open and open the copied 
.DPF. 
 

 
 
This will load the most up to date versions of all SCDOT preference files and save them to 
the created GDF when prompted. 

3. Units 
 
Set the Project Units to English: 
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4. Project Components 

Set the Project Components: 

The DLB, CEL, and DDB can all be loaded from the *.DPF.  The .GPK should be obtained 
from the Roadway group and placed in the same folder as the hy.dgn and .GDF files. 

 

 
DLB Click on the magnifying glass button and select the DLB file which was 

copied to the hydro project directory. 

 
GPK 

Click the magnifying glass button and select the GPK Job Number. You 
need to select your project directory and choose the file job###.gpk; 
there should only be one .gpk file. When you choose OK only the 3-digit 
number that was in the file name appears.  

 
CEL Click on the magnifying glass button and select the cell file located in the 

workspace folder. Select roadv8.cel. 

 
DDB Click on the magnifying glass button and select the DDB file located in the 

workspace location. Select the scdot_engV8.ddb. 

  
Leave all the other file locations blank. 
 
Under the Road Preferences, be sure that the box for Working Directory is empty.  This will 
ensure that your GEOPAK iterations write to the current working project directory – the 
hydro folder. 
 

1 

3 

4 

2 
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Press the COGO Preferences button and ensure that all three directories are empty also. 

 

 
If the Working Directory box is not empty, you risk overwriting the GPK in the roadway 

folder with the new hydrology GPK. 

5. Rainfall Parameters 
 
Set the Rainfall Parameters: 
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Rational 

Choose the down arrow under Rational Method and a list of counties 
from South Carolina appears from the Drainage Library DLB file (choose 
the county that is closest to your site). 

 
SCS Ignore the SCS Method for now. 

 

6. Land Use Options 
 
Set the Land Use Options: 
 

 

 
Rational 

The land uses are the "C" values associated with the different land 
uses and slopes throughout the state. If you have a design exception 
for a project, you will need to copy the Drainage Library (DLB) to your 
hydro project directory. You will then be able to input specific "C" 
values into the Drainage Library. Be sure to include this file in the 
Electronic Files to the Roadway Designer if you make modifications. 

 
SCS Ignore the SCS Method for now. 

For details of the SCDOT Land Use values, see Chapter 2, Section 19 and Appendix A of this 
manual. 

For instructions on using Land Use see Chapter 4, Section 2 & 3 of this manual. 
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7. Frequency Options 
 
Set the Frequency Options: 
 

 

 

 
Rational 

Our basic storm sewer design is for a 10-year storm, but if cross lines 
are involved you will need to evaluate the storm sewer for a 25 or 50 
year storm event. The Drainage Library has the values listed in it for the 
2, 10, 25, 50 and 100-year storms. You can only run one storm at a 
time, so initially choose the 10-year storm under Rational Frequency 
Options and input 1.0 as the peaking factor. If you need to run the 
other storms, simply choose that storm and input the correct peaking 
factor from the requirements for Hydraulic Studies.  

 
SCS Ignore the SCS Method for now. 

1 

2 
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8. Intensity Option 
 
Set the Intensity Option: 
 

 
 

 
Min Tc Set the "Minimum Time of Concentration" to 5.0 minutes.  

 
Accumulate 
Time by: 

Under "Accumulate Pipe Flow Time by" select "Uniform Flow 
Velocity". 

 
Intensity 
Options: 

Always toggle ON the option to "Compute Intensity from Library 
Rainfall Data Source".  

  

1 

2 

3 
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9. Junction Losses 
 
Set the Junction Losses (use the values shown below for the Junction Losses): 

 

 

10. Inlet Options 
 
Set the Inlet Options (use the values shown below for the Inlet Options): 
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11. Node Options 
 
Set the Node Options: 
 

 
 

 
 

The Default Node ID Prefix will be different depending on the type of node being placed. 
Refer to the Nodes section and input the most commonly used prefix. 

 
 

We need to be consistent with our naming conventions so we can easily read each other’s 
data and the Roadway Designer will not be confused by different symbology. 
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12. Link Options 
 
Set the Link Options: 

 

 
Design 
Optimization Set "Design Optimization" to "Minimize Depth of Cover". 

 
Elevation 
Option Set "Elevation Option" to "at Actual Link End".  

 
Link Design 
Option 

Set "Link Design Options" to "Design Partial Capacity (d/D)" and set 
to 0.94 (i.e 94% full). 

 
Link Slope 
Decimal Set "Link Slope Decimal" to "No Rounding". 

 
Hydraulic 
Gradeline Set "Hydraulic Gradeline Basis" to "Equal Hydraulic Gradeline". 

 

 
 

The Default Link ID Prefix will be different depending on the type of link being placed. Refer 
to the Links section and input the most commonly used prefix. 

 
We need to be consistent with our naming conventions so we can easily read each other’s 

data and the Roadway Designer will not be confused by different symbology. 
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13. Profile Options 
 
Set the Profile Options:  
 

 
 

 
 

You can choose to have a prefix for all profiles that you create. For now we do not plan to 
create any COGO chains or profiles. 
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14. Plan Symbology 
 
Set the Plan Symbology: We need to make sure our design is on levels that the Roadway 
Designer will not use. This way when they bring in our design there will be no confusion as 
to whose information is on what level. The labels will share the same attributes as its 
component. Make sure the following conventions are followed for levels, weight, line style, 
and colors for consistency: 
 

 
 

Use the following symbology: 
  

Attribute  Areas  Nodes  Pipes  Ditches  

Level  RD_HY_Area_SS RD_PD_DR_Inlet  RD_PD_DR_Pipe RD_PD_DR_FlowCtrl 

Color  3  106  106  106  

Style  0  0  0  0  

Weight  0  0  8  0  

  

 
 

In Plan Symbology, you can copy settings from one black box to another by right-clicking on 
a box and selecting Copy, then right-clicking on another and selecting Paste. 
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15. Updates 
 
Set the Updates Options (use the settings below):  
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16. Save Options 
 
Set the Save Options (use the settings shown below): 
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17. Drainage Library 
 
Select Drainage>Project>Drainage Library. Make sure that the Drainage Library DLB File for 
your active GDF File is open. If not, then go to File and choose the correct one. There are 
five tabs – Rainfall, Land Use, Nodes, Links, Spread Section. Rainfall, Nodes, Links, and 
Spread Section have been preset and need not be modified.  
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18. Land Uses 
 
Use the Land Use Tab to view the land uses on your project. The following are the most 
commonly used Land Uses. 
 

 
 

Entering drainage areas will be discussed in the Areas section. 

19. Links 
 
Circular Links can be the following material types: Aluminum, Concrete, Plastic (HDPE), or 
Steel. 
 
In this menu, the “Steel” setting contains the information for all smooth wall (non-
corrugated) pipes including Concrete and Plastic.  The “Concrete” and “Plastic” settings are 
not used – pipes of those materials should be set to “Steel”.  Corrugated Wall pipes are 
stored in the “Aluminum” material setting.   
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Chapter 3: Nodes 
 
A node represents any new or existing catch basin, drop inlet, junction, open-end pipe or 
outlet. Each has a cell symbol through GEOPAK that represents that particular node. All 
nodes appear large in the Drainage Library, but some intentionally plot as a dot and are 
only visible when you zoom in closely. Outlets, pipe ends, and existing structures do not 
need a visible mark. Outlets and pipe ends are defined by the line drawn for the pipe. 
Existing structures are already defined by the Roadway Designer and we want to avoid an 
overlap of cells. All nodes will have a visible label when placed, and you can always select a 
node by its label.  
 
Note that GEOPAK Drainage does not automatically space your basins; you must use our 
spacing charts. To aid in finding low and high points, use the COGO tool.  

1. COGO 

In December 1998, we were advised to use COGO to locate high and low points on the 
centerline profile of the road. You can utilize this information to space your basins. 

 

The program is under GEOPAK Road instead of GEOPAK Drainage. To open this go to 
Applications>GEOPAK Road>Geometry>Coordinate Geometry. In the Coordinate 
Geometry box choose the Magnifying Glass button by Job Number and select the GPK file. 
The Operator Code is the county number. Do not fill in the other boxes.  
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Open Element>Profile>Utility. Obtain the centerline profile and left and right top of curb 
profiles from the spreadsheet the Roadway Designer emailed, choose one from the list and 
select the Print button. The information will appear in the window. All low and high points 
for that profile will be marked accordingly. Repeat the process for the two remaining 
profiles.  

 

To print, highlight the data, then right click, then choose Copy. Paste the information into a 
text file or word processor so you can remove unnecessary information before printing as 
normal for text documents. 
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2. New Nodes 
 
It is best to place all of your nodes for a system before adding links; then if you need to add 
more nodes you can do so without having to move links.  
 
To add nodes go to Drainage>Component>Node>Add. The "Add a New Node" dialog will 
open for each Node asking for a Node name prefix and number. The nodes number 
automatically by increasing linearly from 1 to 10000. 
 

 
 
Notice in the Node ID that it is using the default that you set in Preferences. You may need 
to change this. The following chart will aid you in the naming conventions:  
  
New Node: 

Node Type  ID Prefix  

CB Type 
16,17,18,1,9,12,14,15, 25  

CB  

DI  DI  

Tee Joints  T  

MH, JB  J  

Dummy Nodes  DN  

Outlet  OP  

Water Quality Structure  WQS  

Bends (15,30,45,90)  B  
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Wye  W  

Multi-grate  MG  

Rebuild Existing Structure  RB  

  
Existing Node: 

Node Type  ID Prefix  

All CB, DI, Tee Joints, MH, JB, 
Dummies*, Outlets, Water 

Quality Structure, Bends, Wye  

EX  

  
* A dummy node defines pipe ends. It can also represent existing structures that do not 
have cells; however, cells do exist for existing manholes, drop inlets, and catch basins. 
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3. Properties 
 
Set the Properties of the Node (the Description field is optional): 
 

 
 

 
Node 
Type 

Choose the appropriate "Node Type", "Profile", and "Library Item" 
to be placed from the Drainage Library 

 
Preview Ensure the correct cell is shown in the preview window 

 

 
 

If placing a Tee or a Bend, initially choose the Tee or Bend that has the description 
“generic”. After the design is finalized go back and reselect the Library Item to the correct 
size of Tee or Bend. Make sure you adjust the inverts at the Tees if you have a different 

trunk line pipe size. For Tees, the trunk line is listed first and the stub is second. If you are 
entering the outlet node, this is where you would define the tailwater. 
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4. Location 
 
Set the Location of the Node: 

 

 
 

 
Chain 

Use the pulldown arrow to select the correct chain name. This information comes 
from the GPK File that you downloaded, and the Roadway Designer will list in 
the spreadsheet what chain represents which road. If you are placing a node on 
a side road make sure to use the corresponding side road chain name.  

 
Profile 

Use the pulldown arrow to choose the correct profile name. Once again this 
information will come from the GPK File, and the Roadway Designer will list in 
the spreadsheet the names of the left and right top of curb grades. You will use 
top of curb grades to define the starting elevation of the catch basin for all 
basins on curb.  

 
Alignment 

Set the Align to Tangent on MS Element for all nodes that will be flush with 
the Face of Curb (FOC). Then click the Select button by Tangent on MS Element 
and select the FOC line which will also automatically set the offset distance.  

 
Placement Either enter the Station value or click the large PD button to dynamically place 

the node cell 
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To be consistent with the Roadway Designer the following picture represents where the cell 
should actually be placed when on the curb. If you place nodes as instructed previously, the 
cells will match perfectly with the FOC as shown below: 
 

 
 

The image below exhibits how to place a drop inlet against the fill. Offset the inlet 
approximately one foot from the toe of fill. You don’t need to measure the one foot distance, 
just get close; the important thing is to provide a little space between the inlet and the 
slope.  This avoids cutting into the slope to install the drain and reduces sediment flow into 
the storm system. 
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The image below exhibits how to place a cell at a radius. Place the beginning of the throat 
at the radius point allowing the entire inlet to be constructed along the tangent section 
outside of the radius.  
 

 

 
 

We need every cell in its proper location because the Roadway Designer cannot move our 
cells around; this would violate our design and they will have trouble with labeling. Please 
be conscientious with every cell location. Once you get a feel for it, it will not take but a 

second to get the cells located correctly.  
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5. Spread Criteria 
 
N/A for SCDOT Drainage design. 

 
 

SCDOT does not enter any information in this window. An error message may appear due to 
spread. This message should be ignored. 
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6. Elevations 
 
Set the Elevation of the Node: 

 

 
 

 
Reference 
Surface If using a TIN file enter it here, otherwise leave blank 

 
Elevation 
Source 

Select "Reference PGL"; an elevation will automatically appear 
(this is the top of curb elevation and it is read from the Profile you 
entered previously in the Location option). If the cell is not on the 
curb, you will need to choose "User Supplied" and enter the 
elevation. For a drop inlet enter the ground elevation. The outlet is 
discussed in detail under Networks. A stub out or open end pipe 
elevation will be determined following the same procedure used for 
the outlet.  

 

Node 
Elev. 
Option 

Set to "Same as Source";  

 
Vertical 
Align 

Start with "Match Soffit" but change as needed to represent drop 
manholes, to match flowlines with other systems, etc. 

 
Min. 
Depth The Min Depth varies per Node type (see table below) 

 
Max. 
Depth 

Enter 10'.  If you get a warning message, you have exceeded your 
maximum depth; in this case special consideration will be required 
with the road designer. 
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NODE  Min. Depth  

  From TOC  From Ground  

Water Quality Structure  -  0.0’  

CB 1, CB 15, CB 16, DI 115  2.0’  -  

CB 17, CB 18  3.0’ -  

DI 24x24, DI 24x36, DI 112 - 1.0’ 

CB 9  - 2.0’ 

MH, CB 25 - 3.0’ 

Outlet, Dummy 0.0’ 0.0’ 

 
For a double CB25, the minimum cover should be measured from the lower pavement 
elevation as shown below.  This works for grade separations of up to 18”.  
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For grade separations larger than 18”, the designer should only use single CB25s.  If 
drainage is needed on both sides of the barrier/wall, 
 

o Design parallel drainage on both sides of the wall. 
o Minimum cover is 3’ from lower grade for pipe on lower side. 
o Minimum cover is 3’ from upper grade for pipe on higher side. 
o Stagger Stations of catch basins at least 100’ (only box on one side is allowed in 

any given cross section) 
o See Standard Drawings for Concrete Gravity Retaining Walls for additional 

restrictions (when available). 
 
For walls taller than 6’, the hydraulic designer should work with the Structural Engineer to 
identify maximum box depth on the high side of the wall so the box and pipe do not conflict 
with the retaining wall footing. 

 
7. Junction Loss 
 
Set the Junction Losses (use the Defined Equations option as shown below): 

 

 
8. Discharge Options 
 
Set the Discharge into the Node: 
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Discharge Set to "Use Computed Discharge" for almost all situations so the 

discharge from the associated area is directed towards the node. 
  
  

 
 

Some drop inlets and cross line pipes require a “Supplied Discharge", in which case enter 
the discharge value in the key-in field. 

9. Computations 
 
Note that the Computations Option is greyed out.  Since SCDOT does not let GEOPAK 
calculate the spread, this option will not be available.  Otherwise, view the computations. 

 

 
 

The Edit Area button (to the left of the Apply button in the above picture) opens the 
Drainage Area Definition window.  Use this to create an associated drainage area if your 
node collects water discharged from one. Junctions, outlets, and water quality structures 
cannot collect water. When you select this button it will tell you that this area does not yet 
exist and ask if you want to create it. Answer "yes". The Add a New Area box will appear. 
The Area ID is whatever you named the node; do not change this. You can add a 
description if you desire, but it will only be used to describe the area and not the node. 
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Chapter 4: Areas 
 
See the individual Area options below. 
  
  

 
 

SCDOT uses the "Rational Method" only. 

1. Definition 
 
Define the Drainage Area: 
 

 
 

There are four methods of inputting areas for a basin; use one of the two below, or for more 
info see the Bentley Geopak Drainage Manual. 
  

 
Drainage 
Area Just key-in the acreage in the key-in field 

 
Select 
Shape 

Draw a MicroStation closed shape, then click the Select Shape 
button, identify and accept the shape, and the acreage key-in 
field will automatically populate with the acreage value. 

 

 
Enter the Base C Value, and the Time of Concentration. Disregard the Compute Tc 

button.  
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2. Subareas 
 
Set the Drainage Area's subareas options.  This process assigns new C values to pieces of 
the overall Drainage Area set in the Definition option and provides a final composite C value 
for the total area.  Any remaining area not explicitly defined in this section is left as the C 
value set in the Definition option.  

 

 
 
There are three methods of inputting subareas into a basin; use one of the two below, or for 
more info see the Bentley Geopak Drainage Manual. 
  

 
Manually 

Just key-in the subarea acreage into the first key-in field, the 
"c" values in the second, and any desired description in the 
third, and use the add/modify/delete buttons to effect the 
entries in the list 

 
Automatically 

Click the Automatic Delineation button, which initiates a 
scanning of the DGN file and reference files within the main 
drainage area for closed shapes matching the symbology of the 
Library Land Uses as selected in the Preference Land Use 
Option, and automatically populates the Subarea Table. 
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Subareas can be drawn on the appropriate symbology for or have the symbology assigned 
after drawing.  To assign land uses to existing, closed shapes in the design file, select 
Component > Land Uses: 
 

 

 
 

 
Land Use Item Select from the available Drainage Library Land Use Items 

 
Table entry Highlight the Land Use Description you want to designate 

 
Select Shape Click the Select Shape button. 

 
MS select the 
shape 

Data point on the drawn shape, and again to accept, which will modify 
the shape's symbology to that of the designated land use. 

 

Once the closed shapes are designated the correct symbology above, use the Automatic 
Delineation button in the Subareas tab to delineate them. 
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3. Computation 
 
Check the Computation option, as shown below: 

 

 
 

 
Compute 
Discharge 

Click the Compute Discharge button to initiate the 
computations 

 
Results Verify the Drainage Area computation results in the read-

only dialog 
  

 
 

This is just the discharge value for this individual node, and not the discharge in the pipe.  
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Example: 

The image below shows a hypothetical drainage basin divided into sub-areas.  The majority 
of the basin is open land.  The basin also contains buildings, paved roadway, and wooded 
areas.  First, the overall basin must be delineated using the MicroStation Place Smartline 
tool and the primary land-use for the basin determined – in this case, the land use of the 
majority of the basin is Flat Lawns, Sandy Soil.  The sub-areas with different land uses from 
the primary area must also be delineated and the smartlines set to the appropriate colors 
and level using the Land Use Boundary Tool as described in Chapter 4, Section 2. 
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Open the Drainage Areas window (Drainage -> Components -> Areas -> Add) and create a 
drainage area to represent the basin.  In the Definition submenu, click the Select Shape 
button and choose the shape delineating the overall basin.  The Drainage Area, Base C 
Value, and Time of Concentration forms will be filled in automatically.  Change the Base C 
Value to 0.10, as the majority of the basin is Flat Lawns, Sandy Soil. 
  

 

 
On the Subareas submenu, click the Automatic Delineation button.  The subareas list will be 
populated with the total area associated with each land use. 
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The Computations submenu shows the composite area representing the entire basin and its 
C-value.  When the drainage area is linked to a node, Geopak will use these values to 
calculate the discharge into the storm system. 
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Chapter 5: Links 
 
Links can be pipes or ditches. At SCDOT, the Geopak Drainage ditches are used for analyses 
only and not for auto-designing.  
 
There must be two nodes of any type already placed in order to define a link.  
  
To add a link, go to Drainage>Component>Link>Add. Select a link name as stored in 
the Preferences for the prefixes shown below (the numbering will be auto-sequenced): 
 

 
  

New Pipe  NP  

Relay Pipe  RP  

Existing Pipe  EP  

New Ditch  ND  

Existing Ditch  ED  
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1. Definition 
 
Set the Link Definition option as shown below (Description field is optional): 

 

 
 

 
From Node Select the Upstream Node 

 
To Node Select the Downstream Node 

 
Length The length is automatically displayed as the distance between the From and To 

Nodes 

 
Shape/ 
Material 

Set the Shape to "Circular" and the Material to the appropriate type from the 
Drainage Library.  

 
Design Size Toggle ON for new pipe (NP); or toggle OFF for existing pipe (EP or RP) and 

click Select to pick the size from the Drainage Library 

 
Design 
Barrels 

Toggle OFF.  Set to 1 for new pipe (NP), or to the number of existing barrels 
for existing pipe (EP or RP).  

 

Override 
Library 
PayItem 

If your link is an existing pipe (EP) then check the box beside Override 
Library Payitem and type 714EP in the space provided. This will prevent the 
Roadway Designer from overriding the existing pipe line style with the new 
pipe line style.  

 
*Note: Refer to SCDOT Standard Drawings for fill height limitations for specified pipe.  
Where possible, keep pipe between the minimum and maximum fill height appropriate for 
each material.  Keeping cover over pipe between 3’ and 10’ for most installations will allow 
one of each alternate pipe available to the contractor. 

 
Work with road designer when establishing pipe depth, particularly when pipe will be very 
shallow (<3’ cover) or very deep (>10’ cover).  Shallow pipe may also present 
complications with drainage structures (see section V.D.4).  Road designer will determine 
required class, gage, or type based on fill heights listed in SCDOT Standard Drawings. 
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Pipe Type 

 
Standard Drawing # 

RCP 714-205-01, 714-205-02 

SRAP 714-605-01, 714-605-02 

HDPE  714-705-01, 714-705-02 

CAAP 714-810-01, 714-810-02 

2. Conditions 
 
Set the Conditions of the link (for the initial design only, do not hold any of the conditions. 
If you use existing pipes, then they will need to be held): 
 

 
 

 
From 
Node 

After the initial design, and only if necessary, toggle ON to set and hold the 
Invert or Soffit of the pipe.  It is better to hold the Soffit and do not hold 
both. 

 
Slope After the initial design, and only if necessary, toggle ON to set and hold the 

pipe slope. 

 
To Node 

After the initial design, and only if necessary, toggle ON to set and hold the 
Invert or Soffit of the pipe, it is better to hold the Soffit and do not hold 
both. 

 
 

The values for Min Cover and Max Depth come from the Node elevations. 
You can also make adjustments through the Profile window. 

Use this window to define the downstream outlet pipe elevation; as discussed in 
Networks. 
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3. Constraints 
 
Set the Link Constraints (use the values shown below for English units): 
 

 

 
These values should always be used for the initial design; you may have to change the 

minimum slope or min/max pipe sizes later, but only for projects with design exceptions.  

4. Computation 
 
View the read-only Computations as shown below: 

 

 
After you add the network, and then perform a design, computations and errors for this 

individual pipe appear in this window.  
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Chapter 6: Non-Network Pipes 

The following procedures are used to draw, label and report on drive pipes or cross pipes. 

1. Add Nodes 
To add nodes go to Drainage>Component>Node>Add. The "Add a New Node" dialog will 
open for each Node asking for a Node name prefix and number. The number automatically 
increases for each node up to 10000.  These instructions will place the upstream node for 
the pipe.  Repeat them for the downstream node when you are through. 
 

 
Set the Properties Options: 
 

 
 

 
Node Type Set to "Other" 

 
Library 
Item Set to "DUMMY JOINT" 

 
Apply Click the Apply button to accept the Properties. 
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Set the Location Option: 

 

 
Chain 

Use the pulldown arrow to select the correct chain name. This information 
comes from the GPK File. If you are placing a node on a side road make sure 
to use the corresponding side road chain name.  Turn off the curb profile option 
for dummy nodes. 

 
Station DP Click the Station DP button, move the cursor to place the upstream dummy 

joint at the upstream entrance of the driveway pipe. 

 
Apply Click the Apply button to accept the Location. 
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Repeat this Node>Add procedure for the downstream pipe location, so you'll have 2 Nodes 
for each Link. 

  
 

2. Add Link 

To add a link, select Drainage>Component>Link>Add and give it a name: 

 

Set the Definition Option: 

 

 
From Node Select the Upstream Node 
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To Node Select the Downstream Node 

 
Shape/ 
Material 

Set the Shape to "Circular" and the Material to the appropriate type from the 
Drainage Library 

 
Design Size Toggle OFF, and click Select to pick the size from the Drainage Library 

 
Apply Click Apply to accept the Pipe Definition. 

 

Continue adding Nodes and Links for the rest of the driveway or cross pipes. 

3. Label Plans 

The plans are now ready to be labeled using the Drainage Labeler. 

  

 

Since only a few Node and Link variables were set, only certain label variables will be 
available for driveway or cross pipes. 
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Chapter 7: Networks 
 
The network includes all areas, nodes and links connected to a single outlet node. GEOPAK 
Drainage can handle any number of networks in one GDF file.  
To add a network select Drainage>Network>Add.   

 

 
 

 
Network 
ID 

Name the network based on the names of 
its Outlet.  A network ending at Outlet OP-
201 would be Network-2. 

 
Description 

If there are multiple roads on a project put 
the road name in the description that 
matches the outfall station.  

 
Outlet 
Node 

Select the Outlet Node connected to the 
rest of the components contributing flow to 
this outlet. 

Click OK to add the Network to the GDF File, else Cancel. 

 
 

If changes are made to the components the network will need to be redesigned or 
reanalyzed.  
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 1. The Network Dialog 
 
The Network Configuration dialog is split as shown below; top half for navigating and 
bottom half (Details) for input of data and computations: 
 

 

2. Activating Networks 
 
A Network should be activated prior to a Design or Analysis; select Network > Active 
Network: 

 

 
Active Network 
Indicator This field will display the Active Network 

 
Active Network Select a Network to make Active 

 
Design/Analyze See Design or Analyze 
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3. Designing Networks 
 
Designing a Network computes the hydrologic and hydraulic parameters of the Network, and 
automatically sets any unheld node or link elevations. 
 
There are two (2) methods to Design a Network: 
 
Method 1: From the main menu bar, select Network > Active Network: 
 

 
 

 

Active 
Network 
Indicator 

This field will display the Active Network 

 
Active 
Network 

Select the Active Network on which to perform the 
design. 

 
Design Click to Design the activated network. 

  
Method 2: Select Network>Edit: 
  
Use the workflow below: 
 

 
  

 
Build 
Network 

Click Build Network to build the component 
connectivity contributing flow to the Outlet Node 
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A "Successfully Built" message should ensue, otherwise see the errors section. 
 

 
 

 
Highlight 
Network 

(Optional) Click Highlight Network to MicroStation-
highlight all the components contributing flow to the Outlet 
Node. 

 
Design 
Network 

Click Design Network to design the components of the GDF 
project. 

 

 
 

A "Successfully Computed" message should ensue, otherwise see the errors section. 
Drainage Warning/Error messages are reported for all components in the GDF project and 

are stored in the drgmsg.txt file in the Working Directory. 
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4. Analyzing Networks 
 
Analyzing a Network computes the hydrologic and hydraulic parameters of the Network, but 
does not set any unheld node or link elevations and is useful for determining effects of 
various storm events on existing networks. 
 
There are two (2) methods to Analyze a Network: 
 
Method 1: From the main menu bar, select Network > Active Network: 
 

 
 

 

Active 
Network 
Indicator 

This field will display the Active Network 

 
Active 
Network Select the Active Network on which to perform the design. 

 
Analyze Click to Analyze the activated network. 

  
Method 2: Select Network > Edit: 
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Follow the workflow below: 
 

 
  

 
Build 
Network 

Click Build Network to build the component 
connectivity contributing flow to the Outlet Node 

 

 
 

A "Successfully Built" message should ensue, otherwise see the errors section. 
 

 
 

 
Highlight 
Network 

(Optional) Click Highlight Network to MicroStation-
highlight all the components contributing flow to the Outlet 
Node 

 
Analyze 
Network 

Click Analyze Network to analyze the components of the 
GDF project 

 

 
 

A "Successfully Computed" message should ensue, otherwise see the errors section. 
Drainage Warning/Error messages are reported for all components in the GDF project and 

are stored in the drgmsg.txt file in the Working Directory. 
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5. Outlet Definition 

Several references have been made to defining the outlet in this document. The outlet is the 
only node where you have a set elevation that you must match. You want the pipe invert 
equal to the outfall invert. Below is the full explanation on how to do this. GEOPAK Drainage 
wants an envelope defined for every node. This envelope is a vertical range that Drainage 
can use to place the pipe: 

 

The pipe, regardless of its size, will fit within these limits that you set. Each node has an 
envelope, but the outlet envelope is much harder to define.  
  
In the node box under Elevation, the Elevation Source and Minimum/Maximum Depth 
defines the envelope (Figure 2). The program takes the Elevation Source and subtracts 
the Minimum Depth. This is the top of the envelope and the highest elevation where the 
soffit of the pipe can be located.  
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The program then takes the Elevation Source and subtracts the Maximum Depth. This is 
the bottom of the envelope and the lowest elevation where the flow line of the pipe can be 
located. This process is called building the envelope.  
  
For all nodes but the outlet, the Elevation Source is easily defined as either the top of curb 
or ground elevation. The outlet, however, does not have a set elevation above the soffit. 
The pipe is out of the ground, and the ground elevation is at the bottom of the pipe. The top 
of the envelope has to be defined with an assumed elevation.  
  
The following steps will aid you in building the envelope for the Outlet:  
 

1. Open the Node window for the outlet.  
2. Put 0.00 as the Minimum Depth in the Node window under Elevations. 
This means the program will not have to subtract anything to get the top of 
the envelope.  
3. Put what you normally would for the Maximum Depth. This will define the 
bottom of the envelope. This will be below the known flow line elevation, but 
this will not cause a problem. 
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4. Assume an Elevation Source. Most of the time you have a good idea of 
the outlet pipe diameter by looking at the area draining to your system. If 
you have 800’ of road drainage, an 18" pipe will probably do. In this case you 
would add 1.5’ to the outfall invert or flow line and enter this as the 
Elevation Source.  
5. Open the Links box for the last link of our system.  
6. Take the elevation that you calculated for Elevation Source and enter 
that value as the downstream soffit elevation in the Conditions window.  
  

Run the Design process for the network and check the invert elevation of your outlet pipe.  
If you guessed a pipe size too large, then your pipe is not flush with your outfall invert. Go 
back to Links>Constraints and change the soffit elevation. If you guessed a 24" pipe and it 
designed 18", subtract 0.5’ from your original input. 
  
If you guessed a pipe size too small, then your pipe invert is underground. Go back and 
change your Elevation Source under Node>Elevations. Use this value under 
Links>Constraints as your new soffit elevation. If you guessed an 18" pipe and it designed a 
24", then add 0.5’ to your original input.  
  
It is possible to have the limits of the envelope above and below the pipe with the pipe not 
coinciding with either limit. 



Chapter 8: Profiles 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 69 

Chapter 8: Profiles 
 
GEOPAK Drainage can draw the entire profile of a storm sewer very quickly and is an easy 
way to determine if you are surcharging nodes.  
 
Remember this information is used for evaluation purposes of our storm sewers and is not 
the information that the Roadway Designer will be expected to read. 
 
To add and draw a profile, select Drainage>Component>Profile>Add: 
 

 

 
Profile ID Key-in the Profile name (best not to use spaces) 

 
Description (Optional) 

 
From Node Leftmost Node on grid and 0+00 station. 

 
To Node Rightmost Node on grid and last station. 

 Click to add the Profile. 

 
A profile is for a single run of pipe in between any two connected nodes. You cannot draw a 
profile for parallel pipes at once; therefore, draw multiple profiles for a storm sewer system 

with dual trunk lines. 



Chapter 8: Profiles 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 70 

As the profile is drawn to scale, you can measure distances in between lines. These profiles 
can also be printed through IPLOT.  

1. Registration 
 
The Registration Point determines the location, scale and elevation of the profile: 
 

 
 

 
Registration 
Point 

Set the lower left point (X,Y) on the grid.  Click DP and click a point in 
the drawing to place the grid or enter the coordinates manually. 

 
Scale Set the Horizontal & Vertical Scale. 

 
Node 
Information 

From Node = left-hand on grid and 0+00 station; To Node =  right-
hand on grid and ending station. 

 
Projection n/a 

 
Stations& 
Elevations 

Stationing is read-only.  Set the Max. and Min. Elevations to encompass 
all profiles and surfaces. 

 
Reference 
Surface n/a 

 Click to draw the profile in the DGN file. 
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2. Display 
 
Set the Profile's display. Make sure they are all on Level RD_HY_Gpkprofile, but choose 
whatever color and weight you want. 
 

 
 

 
Soffit Top of Pipe 

 
Pipe Center Center of Pipe 

 
Invert Bottom of Pipe (flowline) 

 
Design Surface Proposed Finished Grade (TIN or Model) located in the 

Preferences  

 
Original Ground Existing Ground (TIN or Model) located in the Preferences  

 
Ref Surface (Optional) 3rd surface from the Registration Tab 

 
Water Line 
Crossings n/a 

 
Drainage 
Crossings Toggle ON to show the drainage crossings 

 
Sewer Line 
Crossings n/a 

 
Misc. Utility 
Crossings n/a 

Click to modify the Profile. 
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3. Drainage Information 
 
Select the drainage information to be displayed in the profile view. Make sure they are all on 
Level RD_HY_Gpkprofile but choose whatever color and weight you want. 
 

 
 

 
Hydraulic Grade 
Line Auto-generated Hydraulic Grade Line 

 
Critical Depth Auto-generated Critical Depth 

 
Uniform Depth Auto-generated Uniform Depth 

 
Energy Grade 
Line Auto-generated Energy Grade Line 

 
Maximum Soffit Maximum elevation of top of pipe 

 
Minimum Invert Minimum elevation of bottom of pipe 

 
Minimum Cover Minimum cover on top of pipe 

 
Maximum 
Depth Maximum depth of bottom of pipe 

 
Drainage Node Node display symbology in profile view 

Click to modify the Profile. 
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4. Grids & Labels 
 
Set each option on an individual basis. 
  

 
 

Pick from the options and choose whatever looks best to you. You can easily clutter the 
profile when choosing too many options; so make sure the information chosen will look 

good printed. 

 

5. Link Profile 
 
This is a powerful tool allowing you to modify the pipe invert elevations and slopes.  In the 
top portion you will see all the pipes in the profile. Highlight a pipe and its invert elevations 
appear under Details>Node.  From there you can manually change the invert and hold it or 
you can click the Edit Invert button and move the invert on the profile.  You also have the 
option to hold and change the pipe slope. 

 
  

 
Link ID Highlight the Link ID in the list 

 
Node 

Use the button to dynamically adjust the vertical invert in profile 
view; or key-in the "Hold Invert" elevation then toggle ON "Hold 
Invert". 
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Node 

Use the button to dynamically adjust the vertical invert in profile 
view; or key-in the "Hold Invert" elevation then toggle ON "Hold 
Invert". 

 

Drainage 
Library 
Item 

n/a 

 
Hold Slope Toggle ON and key-in a slope value. 

 
Modify Click the Modify button to change the Link. 

 Click to accept the revision, redesign the Network, and redraw the Profile. 

 

 
 

If a change is made, the Network should be redesigned or reanalyzed. 
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6. Conflict Finder 
Use Conflict Finder to check for vertical piping conflicts. From the main menu bar, select 
Utilities > Conflict Finder: 

 

To assess conflicts, set the Conflict Finder using the workflow shown below: 

 

 
Check Feature 

  
 

Click the ID button and data point on a single 
Drainage Link to check. 

OR  Checks all Drainage Links for all crossings. 
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Display Options (All Optional) 

  
 

Double-click to activate the control and set the 
symbology for the remaining display options. 

   
Views the conflict data information in temporary 
display mode. 

   
Displays the vertical elevation of the utility crossing in 
profile view. 

   
Displays the vertical elevation of the main crossing in 
profile view. 

   
Displays the vertical elevation of the proposed surface 
you stored in the preferences. 

   
Centers the selected MS window on the conflict in plan 
view and/or profile views. 

   
When toggled ON, and Conflicts are found, the 
Drainage Profile Edit dialog opens to enable on-the-fly 
conflict resolution. 

   
Displays the vertical clearance (feet or meters) 
between the crossings. 

   
Displays the vertical depth (feet or meters) at the 
crossing location. 

   Centers the MS plan view on the crossing. 

   Centers the MS profile view on the crossing. 

  Conflicts Options 

OR  Checks for Drainage pipe crossings. 

OR  
Checks for Sewer pipe crossings stored in 
the Drainage Preferences option. 

OR  
Checks for Water pipe crossings stored in 
the Drainage Preferences option. 

OR  Checks for Misc. Utility pipe crossings. 

 
Compute Options 

   
Click Compute, the # of Conflicts found will 
be displayed. 

   

Use Default for Sewer clearance value you 
stored in the sewer line dialogs or the water 
line dialog, or use Override and supply a 
vertical clearance in (feet or meters). 
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OR 
 

Displays the Previous crossing location 

OR 
 

Displays the Next crossing location 

OR  Displays All conflicts 

 

Profiles need to be drawn into the DGN file before using this tool. 
To remedy conflicts, toggle ON "Edit Profile" and use the Link Pipe Profile tab to modify 

vertical elevations as needed. 
 

 

 



Chapter 9: Navigator 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 78 

Chapter 9: Navigator 

The Navigator is a powerful tool to aid you in maneuvering through a project. You can also 
add, edit, delete and identify all drainage components from the Navigator: 

 

The Navigator has the following toolsets: 

 

 
Networks Choose to navigate through "All Networks" or only the "Active 

Network". 

 
Components Options include: Areas, Inlets, Nodes, Links, Profiles, Culverts 

and Routings, displayed left to right. 

 
ID List The list of components available by the selection in bullet #2 

above. 

 
Action 
buttons 

Click to add / modify / delete / or ID any component for 
modifications. 
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1. Navigating 

The Navigator window allows you to click through the lists of drainage objects to identify 
and modify the components you are interested in.   

 
 

 
Type Select the component type of interest – only that type will be shown in 

the components list. 

 
Toggles Toggle ON so the MicroStation view will highlight and center on a 

drainage component when it is selected. 

 
Component Click any component in the list. 

 
View The Microstation view updates to window center and highlight the 

selected drainage component. 

 
Repeat as necessary to navigate the components 
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2. Updating Graphics 

After editing the drainage components, you must update their graphics in the Microstation 
file. 

 
 

 
Type Select the component type of interest. 

 
Selection Select all (or any you wish) components in the list for graphical 

updating. 

 
Tools Select Tools > Update Graphics to commence the procedure. 

 
View The Microstation view updates with the revised graphics. 

 
Repeat as necessary to update the graphics on the components. 
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3. Identifying Items 

Navigator can also be used to identify a drainage component from its graphic in the 
Microstation file. 

 
 

 
Type Select the component type of interest. 

 
ID Click the ID button 

 
Select Select any component in the DGN file 

 
Navigator Notice the specific component is located and highlighted in the 

Navigator window 

 
Repeat as necessary to identify the drainage components. 
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 4. Query Mode 

Query Mode allows you to set several requirements and search the project for any drainage 
components that meet them.  Use the workflow below to utilize the Query Mode: 

 

 
Select the Component Type 

   Use Query Mode to search for Areas 

OR  Use Query Mode to search for Inlets 

OR  Use Query Mode to search for Links 

  

 
Toggle ON "Query" mode 

  

 
Query Options 

 
Query: 
Values 

A Value is usually one of two types: "alpha" (i.e. pipe material) or 
"numeric" (i.e. pipe slope). 

OR Query: 
Constraints 

A Constraint is usually one of two types: "min" (i.e. minimum 
depth) or "maximum" (i.e. maximum depth). 
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 > Condition = "greater than" 

OR = Condition = "equals" 

OR < Condition = "less than" 

 Variable If the Query Type is set to 'value', a variable may be available. 

OR Constraint If the Query Type is set to 'constraint', a constraint may be 
available. 

 Value Value mode is usually one of two types "alpha" (i.e. curb) or 
"numeric" (i.e. curb length) 

  

 
Apply Query 

  Apply 
Query Click Apply Query to initiate the computations 

  

 
Navigator Window 

  Query 
Applied 

The components remaining in the Main Navigator Window meet the 
results of the applied Query. 

 

After a Query is applied, the Navigator Window will continue to display only the results of 
the Query, until it is reopened, or another Component Type is selected. 

 

5. Global Editor Mode 

The Global Editor mode expands the Navigator to let you edit components directly from the 
Navigator window.  From the Navigator's View pull-down menu, select Global Editor: 
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Use the workflow below for Globally Editing components: 

 

 
Select the Component Type: 

  Components Only Areas, Inlets, Nodes or Links are available for Global Edits. 
  

 
Select the Component(s): 

  Keyboard 
Input 

Highlight (use keyboard shortcuts) single, multiple, or all components on 
which to perform the Global Edit(s). 

  

 
Variable to Edit 

  Variable to 
Edit Select any one of the available Variables to Edit. 

  

 
Current/New Value 

Current 
Value Current Value Displays the current value of the selected variable in 

the step above. 

New Value  Key-in the new value of the Variable. 

Overwrite 

OR 

Find/Replace 
 

Either "Overwrite Text" with "New Text", 

OR 

Use "Find Text" / "Replace Text" feature. 
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Apply Edits 

  Apply Edit with 
Confirm 

Click to make the changes without any confirmation warning 
messages. 

OR Apply Edit No Confirm Click to make the changes with a confirmation warning message 
for each component selected in bullet #2 above. 

 

Use the same workflow above (for any available variables) for Areas, Inlets, Nodes, or 
Links. 
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Chapter 10: Reports 
 
Under the Drainage>Reports menu, the three top options are summary reports that 
GEOPAK Drainage automatically generates. To print these reports you must open one of the 
three reports, press Alt-PrtScn, then open Paint and press Ctrl V or open Microsoft Photo 
Editor and choose Edit>Paste as New Image. You can print directly from either program.  
To generate a specific report you must open the Report Builder.  This is where you can 
generate custom reports for system evaluation.  
 

 

1. Alternate Pipe 
 
The alternate pipe spreadsheet is used to organize drainage network data for inclusion in 
plan sets.  The spreadsheet itself can be found on the Preconstruction intranet webpage 
under “Design Tools” listed as Alternate Pipe Editor.  The information for generating the 
necessary reports is located in the DrainReport4AltPipe2010.drf file in 
\\nts\hq\precon-general\Hydraulics\Standard_Files_GEOPAK_2009\ 
GEOPAK_Output\Output_drf_files.   

2. Generate 
 
To export the drainage system data from Geopak, select Drainage>Reports>Generate. 
Make sure you have an active network selected. By Drainage Report Format File choose 
the preset DrainReport4AltPipe2010.drf.  
 
By Output File Name choose your working directory and name the file whatever you 
desire, but change the extension to csv. Select Generate and you will receive a message 
stating the file has been generated.  
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3. AltPipe Spreadsheet 
 
Copy the AlternatePipeEditor spreadsheet from the Preconstruction intranet webpage to 
your working directory and open it.  You will need to authorize it to use Macros and possibly 
to confirm that files from the internet are allowed. 
 

 

 
 
Fill in the File Number on the Input tab of the spreadsheet.  The Joint Pressure cell should 
be 13 psi for coastal regions and 10 psi for all others unless otherwise indicated for the 
project in question.  Set Smooth Data to Yes and Corrugated Data to No.  If Driveway Pipes 
are to be included in the final report, set that field to Yes.  Then enter the name of the .drf 
file created in the previous section next to the Smooth Data field under File Names. 
 

 
 
Press the “Import Geopak Data” button to fill in the network data from the .CSV file.  The 
leftmost column of data, System ID, must be filled in manually.  For each Link, enter the 
point number of the outlet of its system.  The SPT “N” values must be entered manually by 
the geotech.  Once both columns have been filled out, press the “Generate Hydro Output 
Tables” button and enter a file name to create the final reports. 

4. Standard Interoffice 
 
The information for our standard interoffice reports and Roadway Designer reports has been 
preset in a set of DRF files found on \\nts\hq\precon-
general\Hydraulics\Standard_Files_GEOPAK_2009\GEOPAK_Output\Output_drf_
files: - nodestandard.drf, linkstandard.drf, areastandard.drf, nodestandardroad.drf, 
linkstandardroad.drf, nodesum.drf, linksum.drf. The .drf files were developed under Report 
Builder and their contents are listed in section 4.    
 
To create our final standard interoffice reports is no simple task. Basically you must 
generate a set of CSV files from a set of DRF files, and then paste the information in the 
.csv files in a .xls file for the final report. In the end, you will only have five .xls files for the 
whole project regardless of the number of storm sewers you design. 
 
To create the CSV files, follow the same instructions from section II, substituting the 
appropriate .drf files as needed.  Linksum.csv and nodesum.csv will only need to be 
generated once, and it does not matter which storm sewer is active since these files are not 
storm sewer specific. You must generate the remaining five CSV files for every network 
(storm sewer system) you designed. These files are specific to each particular storm sewer. 
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5. Final Reports 
 
Download our standard output XLS files from\\nts\hq\precon-
general\Hydraulics\Standard_Files_GEOPAK_2009\GEOPAK_Output\ Blank Files 
to your project directory. The CSV files (linksum.csv and nodesum.csv) will be pasted in the 
linkstandardroad.xls and nodestandardroad.xls, respectively. We will discuss this in the next 
section. Now we will discuss the storm sewer specific files. The storm sewer specific files are 
the CSV files you created from the DRF files (nodestandardroad.drf, linkstandardroad.drf, 
nodestandard.drf, linkstandard.drf, and areastandard.drf.) You should have five .csv files for 
each storm sewer. The following is the process for creating our standard output files, for the 
individual storm sewers, from the CSV files.  

1. Open the appropriate .xls file for the .csv file that you already have open– 
nodestandard.xls, linkstandard.xls, areastandard.xls, nodestandardroad.xls, 
linkstandardroad.xls. You will alter this file to reflect your information.  
2. Add headings to the first sheet in rows 1 and 2. View the files under 
\\nts\hq\precon-general\Hydraulics\Standard Files\GEOPAK 
Output\Sample output to see exactly how the reports should look.  
3. Select Edit>Move or Copy Sheet… and copy as many sheets as you have 
networks/storm sewer systems.  
4. Change the sheet name to match the network name, i.e. System 12+00. 
Each sheet within the workbook will represent one system.  
5. Highlight the data in the .csv file.  
6. Right click and select Copy.  
7. Go to the standard file (.xls) you just modified. Activate the appropriate 
sheet for the .csv file you are copying.  
8. Click on the first cell under the table heading in the A column.  
9. Right click and select Paste Special…  
10. Choose Values  
11. Choose OK. The font and alignment should be automatically set.  
 

The files with road at the end (linkstandardroad.xls and nodestandardroad.xls) are to be 
sent to Roadway Designer. The other files are for your in-house report. Be sure to check 
that the max Design Capacity of 94% has not been violated. Eventually we will add a line in 
the report to give you such information.  
  
Summary Report Files  
  
We need to paste the linksum.csv and nodesum.csv files into the linkstandardroad.xls and 
nodestandardroad.xls files, respectively.  

1. Open one of the sum.csv files.  
2. Go to Data>Sort….  
3. Click the down arrow under Sort by and choose Item.  
4. Choose OK.  
5. Open the appropriate .xls for the appropriate sum.csv file you have open.  
6. Select the sheet labeled Summary Report.  
7. Add headings to the first two rows. View the files under 
\\nts\hq\precon-general\Hydraulics\Standard Files\GEOPAK 
Output\Sample output to see exactly how the reports should look.  
8. Highlight the data in the .csv file.  
9. Right Click and select Copy.  
10. Go to the standard file (.xls) you just modified. Activate the Summary 
Report sheet for the .csv file you are copying.  
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12. Click on the first cell under the table heading in the A column.  
13. Right click and select Paste Special…  
14. Choose Values  
15. Choose OK. The font and alignment should be automatically set.  
 

Lastly, we need to run a macro to sum the pipes and basins. Two summary tables will be 
generated, one in the nodestandardroad.xls and one in the linkstandardroad.xls.  
 

1. Open either nodstandardroad.xls or linkstandardroad.xls and activate the 
Summary Report sheet.  
2. Open \\nts\hq\precon-general\Hydraulics\Standard 
Files\macros\drainage_report.xls. This is the macro file.  
3. A message box will appear. Choose Enable Macros. It will appear as if 
nothing has happened.  
4. Go to Tools>Macro>Macros….  
5. Choose drainage_report.xls!Link_cal.Link_cal if you are in 
linkstandardroad.xls and drainage_report.xls!Node_cal.Node_cal if you 
are in nodestandardroad.xls.  
6. Choose Run.  
7. You will get two messages. Click OK for both. The summary table will 
appear just below your inputted data.  
8. Repeat these steps to generate the other summary table. 

6. Interoffice Report 

The following information is preset in our DRF files.  

Our interoffice report will contain the following information:  

  -  Node Report 

File name: nodestandard.drf 

Node Information:  
1. I.D.  
2. Description  
3. Type  
4. Library Item Name  
5. Reference PGL  
6. Station  
7. Offset  
8. Reference Elevation  
9. Elevation  
10. Depth  
11. Junction Loss  
12. Tc Used  
13. Cumulative Tc  
14. Cumulative Discharge  
15. Cumulative Area  
16. Cumulative C Value  
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17. Cumulative Intensity  

  -  Area Report 

File name: areastandard.drf 

Area Information:  
  
1. I.D.  
2. Tc Used  
3. Discharge  
4. Intensity  
5. Composite C Value  
6. Composite Area  
7. Total Subarea C Value  
8. Total Subarea  
9. Remainder C Value  
10. Remainder Area  

  -  Link Report 

File name: linkstandard.drf  

Link Information:  
  
1. I.D.  
2. Upstream Node  
3. Downstream Node  
4. Shape  
5. Material  
6. Number of Barrels  
7. Rise  
8. Actual Length  
9. Slope  
10. Discharge  
11. Capacity  
12. Uniform Depth  
13. Uniform Velocity  
14. Soffit Upstream  
15. HGL Upstream  
16. Soffit Downstream  
17. HGL Downstream  
18. Invert Upstream  
19. Invert Downstream  
20. Actual Velocity Upstream  
21. Actual Velocity Downstream  
22. Actual Depth Upstream  
23. Actual Depth Downstream  
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7. Roadway Report  
The following information is preset in our DRF files.  

Road Design’s report will contain the following information:  

  -  Link Report 

File name: linkstandardroad.drf  

Link Information:  
  
1. I.D.  
2. Library Item  
3. Type  
4. Material  
5. Shape  
6. Upstream Node  
7. Downstream Node  
8. Actual Length  
9. Slope  
10. Rise  
11. Pay Item  
12. Invert Upstream  
13. Invert Downstream  
  

  -  Node Report 

File name: nodestandardroad.drf  

Node Information:  
  
1. I.D.  
2. Library Item Name  
3. Reference PGL  
4. Station  
5. Offset  
6. Elevation  
7. Depth  
8. Pay Item  

 



Chapter 11: Microstation Drafting 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 92 

Chapter 11: Microstation Drafting 
 
Add completed networks and surface data to the Microstation plans, profiles, and cross-
section sheets.   

1. TIN Files – Draw Contours 
From DTM Tools->Load->DTM Feature choose your *.TIN file to be loaded. 

 

From the Load DTM Features dialogue set up the Display preferences. In the Load 
dropdown, choose whether you would like to load the entire .TIN or just specific locations. If 
just for reference purposes choose display only. This temporarily loads the DTM but will be 
removed at any change of the window (i.e. zoom in/out). 

Highlight Contours and double click to turn on the display. With Contours highlighted set the 
values desired for Minor and Major intervals. Also, select read to set the MIN/MAX contour 
lines inside of the tin to be displayed. 

 



Chapter 11: Microstation Drafting 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 93 

Select the Major Lines and double click the black box to set up the features of the Major 
lines.  

 

This opens up the Set Feature dialogue. Set up the Symbology as shown below, changing 
the Level to correspond to the feature for Major Label, Minor Lines, and Minor Labels. 

 

Once all settings have been established choose Load to display contours. 

2. TIN Files – Height/Slope Analysis  

From DTM Tools->Analysis->Height/Slope, load your *.TIN file to be analyzed. 

 



Chapter 11: Microstation Drafting 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 94 

After a *.tin file has been selected the user should choose the mode for analyzing the 
the*.tin, choosing from Elevation or Slope from the Mode drop down box. 

With Elevation selected, choose the Display Only check box to find spot elevations for 
reference purposes only. To adjust the text for elevations double click the text box to load 
the text dialogue box. Within elevation mode the user can choose to show the contour 
associated with the elevation, show the triangle associated with the slope, or show the 
arrow denoting the direction of water flow. The colors for each of these can be changed by 
double clicking the box to the right. 

 

Select Start to begin.  Move cursor throughout the *.tin file to display elevations and the 
other options selected. If display only was checked, any data point will be removed if any 
change is made to the view (i.e. zoom in/out) 

 

With Slope selected you will have the same option of changing the text and what will be 
displayed. Two options are available for measuring the slope: using a triangle and the two 
point method. Triangle slope changes dynamically with the cursor, while point method is 
found by selecting two points. 
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3. TIN Files – Creating Profiles  

From DTM Tools->Analysis->Profile load your *.TIN file to be analyzed, and select “add list 
item” 

 

Select the Create Profile button, choose the option of place profile element  
and place two data points in the area you want the profile. This will display the profile in the 
dialog for review. 

 

If satisfied with the profile previewed choose the third option to place the profile into the 

drawing. To place the profile data, click anywhere within the *.dgn. 
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4. Cross Section Files – Draw Side Line Pipes 
 
Open the *dx.dgn design file and select  
Applications -> GEOPAK -> ROAD -> Design & Computation Manager from the menu bar.   
 

 
 
Select English -> VBA Applications -> XS Pipes and double click to start the macro.   
 

 
 
On the General tab, select the Job and Chain, then browse to select the *.gdf file in the 
project folder. Check on the Honor XS Exaggeration. (This toggle controls the size of the 
pipe drawn on the cross sections in case they are drawn 10:5 vs. 5:5). 
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On the Side-Line Pipes tab, accept the defaults and press the Process Cross Sections 
button. (You can change the symbology by clicking the appropriate buttons prior to 
processing as well.)  
 

  
 
Press the Begin button and wait for the program to finish. Select Yes to save a *.csv pipe 
report file.  Pipe drawings in cross sections should be reviewed by roadway and 
hydraulic engineers after processing. 
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5. Cross Section Files – Draw Cross Line Pipes 
 
Open a plan view .dgn file showing the cross line pipes.  Draw drainage pattern lines along 
each cross line pipe using MicroStation “draw line” command.  Pattern lines should be set to 
one of the RD_PD_PatLn# levels and should extend a minimum of 20 feet beyond each end 
of the cross line pipe or to the construction limits.   
 

 
 
Alternatively, open the D&C Manager (Applications -> GEOPAK -> ROAD -> Design & 
Computation Manager on the menu bar), select English -> VBA Applications -> Drainage 
Patterns, and double click to start the macro. 
 

 
 
In the Culvert Pattern Lines window, enter the Job number of the project and select the 
chain of the road being crossed.  Click the magnifying glass next to the “Drainage Project”  



Chapter 11: Microstation Drafting 

 SCDOT Specifications and Support Manual for GEOPAK Drainage Last printed: 12/20/2019 
Page 99 

space and browse to the .GDF file for the project.  Check the box marked “Pattern Lines for 
Cross-Line Pipes” and enter 0 for the Pattern Line Offsets 
 

 
 
Open or create a *xp.dgn file for the project.  Cut existing and proposed cross sections 
using the new drainage pattern lines. Cross sections will be skewed.   
 
Open the D&C Manager, select English -> VBA Applications -> XS Pipes and double click to 
start the macro. 
 

 
 
On the General tab, select the Job, Chain and browse to select the *.gdf file. Check on the 
Honor XS Exaggeration. On the Side-Line Pipes tab, turn off all of the checks. 
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On the Cross-Line Pipes tab, check on all of the boxes. You can accept the defaults for 
symbology or click the appropriate buttons to change them. 
 

 
 
Press the Process Cross Sections button. Press the Begin button and wait for the 
program to finish. Select Yes to save a *.csv pipe report file.  Pipe drawings in cross 
sections should be reviewed by roadway and hydraulic engineers after processing. 
 
 
 

6. Displaying 3-D Networks 
 
Create a new 3-D .dgn.  Start GEOPAK Drainage and open the .gdf containing the network.  
Open the GEOPAK Drainage Preferences menu and go to the Project Components tab. 
Ensure that the Drainage Cell Library being used is the most up-to-date RoadV8.cel dated 
8/24/2011 or later.  If not, load the *.dpf file associated with the project and check again. 
 
Update all Nodes and Links via Navigator. 
 

  
 
Activate the 3D display using Utilities -> Display 3D in the Drainage menu.  Change the 
Display Style in View Attributes from “Wireframe” to “Smooth.” 
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A 3-D representation of the network will be drawn above the existing 2-D version.  Use the 
Rotate View tool in the View menu to observe the network from other angles. 
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A 3-D view can reveal errors in the network design, such as incorrect structure and pipe 
elevations.  Examining this view for pieces that appear out of place or incorrectly shaped 
can be much quicker than comparing the data associated with each pipe and node in text 
format using the Navigator tool.
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Chapter 12: Uploading Files 
 
After you complete your design, you must put all pertinent information about your project 
on the server for the Roadway Designer to access. All the information that you must supply 
to them is listed under Exchange of Information. Below is the form that you will email to the 
Roadway Designer explaining where the files are located and what you named them.  
 
This will be the only thing that you will send them electronically. They will access everything 
else electronically from our server. Make sure you send them a hardcopy of the 
abandon/retain notes. 
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If you have revisions to your GDF file and must resubmit files to Roadway Designer, resend 
them the email and state what changes were made. Be specific and name the pipes and 
nodes that were affected. If a large section of roadway was affected then give road stations 
that define the limits of those changes. 

 
 

Consultants will still need to submit all files to the Hydraulic Engineer by a CD or FTP for the 
Roadway Designer’s use and a hard copy of the plans for our review. Labels will still be 
required for all pipes and basins, but they are to be very basic. The Roadway Designer will 
do the final labels themselves for both Right-of-Way and Construction plans. Also include 
the spreadsheet on the previous page in the submittal and the Hydraulic Engineer will 
forward it to the Roadway Designer. 
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Chapter 13 - Import/Export 
This section covers the import & export of shapefiles, XPSWMM, HEC-RAS, Google Earth, 
DEM files and LiDAR. 

1. Shapefiles 
Shapefiles (.SHP) can be opened as a MicroStation file and saved as a .DGN, imported into 
an existing drawing, or referenced within a drawing.   
 
Opening a shapefile in MicroStation works the same as opening a .DGN file. Go to File-
>Open in the menu bar. In the Open File screen, change the file type (located at the bottom 
of the screen) from CAD Files (.DGN) to Shapefiles (.SHP), then select the desired shapefile 
and press open.  The file will be opened as Read-Only, but it can then be saved normally as 
a .DGN file and edited from there. 
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To Import a shapefile into an existing document, use the File->Import->CAD Files command 
in the main menu. 
 

 
 
In the import menu, set the file type to Shapefiles exactly as per the process for opening a 
shapefile, select the file in question, and press Open.   
 
To attach a Shapefile as a reference, follow the same process as for attaching another 
Microstation drawing as a reference.  When browsing to the desired file, set the file type to 
Shapefile as per the previous two processes, then select the shapefile and press Open. 
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2. XPSWMM 

To Export any Network of the current Drainage GDF file: 

 

 

 

The Network is now available for import into XPSWMM. 
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3. HEC-RAS 

Microstation surfaces can be used to produce cross-section data importable into HEC-RAS 
models.  To do so, you will create a chain representing the stream, cut cross-sections along 
it from a surface file, and then export those cross-sections as a file readable by HEC-RAS. 

Streams may be delineated in the project survey.  However, preparing a new chain for the 
stream based on the FEMA blue-line data will allow closer coordination with FEMA and other 
state and federal authorities that base their data on FEMA models.  The FEMA stream 
delineation can be found in the S_WTR_LN.shp ShapeFile in the National Flood Hazard Layer 
(NFHL) data available in SCDOT files and on the FEMA website.   

 

Open the r#####hy.dgn file for the project.  Open the References menu and Select Attach, 
then browse to the shapefile containing the stream line.  For the Attachment Method, select 
“Geographic – Relocated”, then press Open.   
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Use the Smartline tool to draw a new line for the stream, beginning at the downstream end, 
and use Geopak -> Road -> Geometry -> Store Graphics to turn it into a chain.  Select the 
GPK file for the project and name the Stream.  The Beginning Point and Beginning Station 
entries can be left as they are.  Click ID Element, click on the line drawn for the stream, 
then click Store. 

 

Using Smartlines, draw the pattern lines for the required cross-sections along the stream.  
The pattern lines should be drawn on one of the RD_PD_PatLn levels.  The pattern lines 
should be perpendicular to the chain within the streambed, then turn to perpendicular with 
the topographic contours in the overbank areas to either side.  Place pattern lines as needed 
to clearly define the stream bed cross-section and any curves in its flowline, as well as any 
and all notable features in the overbank area such as steep slopes, ditches, and structures.  
Features that directly impact the waterway such as bridges or connections with other 
streams should be clearly defined using as many cross-sections as necessary. 
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Open Geopak -> Road -> Cross Sections -> Draw Cross Sections From Surfaces.   

 

 
 

 

 
Job Number Select the .gpk file for the project 

 
Chain Select the chain representing the stream 

 
Pattern Select “By DGN File” to use the pattern lines in the current file.  

 
Design File Select the file for the cross sections to be drawn in.  It may be 

the current file. 

 
Pattern Line 
Symbology 

Select the Level, Color, Style, and Weights of the pattern lines for 
the cross sections. 

 
Scale Set the horizontal and vertical scale for the cross section views 

 
Spacing Set the spacing at which the cross section views with be drawn 

 
Surfaces Tab Go to the Surfaces tab to enter data about the topographic 

surface. 
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File Type Select the file type of the topographic surface, usually a .Tin file. 

 
Surface Browse to the location of the topographic surface file and select it 

 
Method Select Triangles 

 
Display 
Settings If desired, set new symbology for the cross-section line work. 

 
Text Settings If desired, set new symbology for the cross-section elevations. 

 
Filter 
Tolerances Do not change. 

 
Add Surface Click the top icon to add the topographic surface to the system 

 
Draw Click the Draw button to draw the cross sections 
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Go to the new cross sections you just drew.  Open Geopak -> Road -> Cross Sections -> 
Reports and click the HEC-RAS button.   

      

 

 

Click Reset to clear the fields, then make sure that only Lv Names and Colors are turned 
on using the check boxes.  Click Display, then Match to begin inputting data.  Click on the 
surface lines in the cross sections.  As level names and colors are filled in, any lines 
matching those combinations of level and color will be highlighted to show they are being 
included in the report.  Make certain that all surface lines in the cross sections are 
highlighted before continuing.  Then close the Select Elements window, enter the HEC RAS 
Report File name and location and click Apply in the HEC RAS Report window. 

 

 
Job Select the .GPK file for the project 

 
HEC RAS 
Elements 

Click the image to go to the HEC RAS Select Elements Window – 
see below. 

 
HEC RAS 
Report File 

After completing the HEC RAS Select Elements window, enter or 
browse to the file location and name of the report to be created 

 
Apply Click Apply to create the export file 
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Open HEC RAS.  Create a new project or open an existing one, then open the Geometric 
Data screen. 

 

Select File -> Import Geometry Data -> GIS Format and browse to the report created in 
Microstation. 

  

On the Import Geometry Data screen, Intro tab, make sure US Customary Units is 
selected. 
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On the River Reach Stream Lines tab, confirm that the data shown is correct, that stream 
lines are being imported, and that the merge mode is set to “Replace”. 

 

On the Cross Sections and IB Nodes tab, confirm that the data shown is correct before 
pressing the Finished – Import Data button.   
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4. Google Earth 

- Exporting DGN Files In SPCS 

Exporting to Google Earth from a Microstation .DGN file set to the State Plane Coordinate 
System is very simple.  SCDOT’s Microstation seed files are automatically set to the SPCS, 
as are the majority of new surveys.  Older files may use modified or local coordinate 
systems. 

 

 
Coord. 
System Check or set the coordinate system. 

 
Export 
KML Export the entire Microstation file as a .KML file for Google Earth. 

- Exporting DGN Files In Local Coordinates 

Exporting to Google Earth from a file set to local or adjusted coordinates requires a 3-step 
procedure: 

1. Use Google Earth to add & save a Placemark 
2. Use MicroStation to Define the Google Earth Placemark Monument  
3. Use MicroStation to Export the Google Earth File 
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  -  Add/Save Placemark 

Use Google Earth to add & save the Placemark: 

1. Zoom to your desired location in Google Earth. 
2. From Google Earth, select Add > Placemark (enter the name; verify the latitude & 

longitude are correct). 
3. Right-click on the Placemark, select "Save Place As" and save as the KML or KMZ 

(the Z means zipped format and is thus a smaller file) to a folder on your local 
computer or server. 

  -  Define Placemark 

In MicroStation, select Tools>Google Earth: 

1. Zoom to your desired location in MicroStation (corresponding to step 1 in add 
placemark). 

2. In MicroStation's Google Earth toolbar, click "Define Google Earth Placemark 
Monument", and snap to the location in step #1 above. 

3. In MicroStation's "Select Monument Placemark File" window, select the saved 
placemark file (from step 3 in add placemark). 

  -  Export KML 

In MicroStation, select Tools>Google Earth (if not already open): 

1. In MicroStation's Google Earth toolbar, click "Export Google Earth (KML) File" and 
key-in the name of the (KML or KMZ) file to export to Google Earth. 

2. After clicking OK, Google Earth should automatically open (if not open already) and 
the cad elements will be exported into the Google Earth view at the proper location. 
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5. LiDAR 
To create a .tin surface file from SCDOT’s LiDAR data records, you will need access to the L: 
network drive (\\nts\hq\scdot-apps\scdot-lidar).   

 

- Identify Required LiDAR Tiles 

In Microstation, select the menu item File > References, then Tools > Attach.   
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Attach Navigate to L:\LIDAR and choose the appropriate county folder. 

 
Tile 
Index Select the Tile_Index file for the county. 

 
Model Select the County Annotation model in the Attachment Settings 

window. 

Check the numbered squares that correspond to the project location to determine which 
LiDAR tiles to import. 
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- Importing LiDAR Tiles 

Activate Data Acquisitions (Tools > Data Acquisitions), right-click on Surfaces, and create a 
new surface by importing the first of the required LiDAR tiles. 
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Select Features Import only points listed as “Ground” 

 
Filters Tin Filter 

 
Z-Tolerance 0.05 to 0.25, depending on site (see item 7) 

 
Points Density Fine 

 
Reinsert Points Toggle ON to maximize surface detail 

 
Filter Calculates Reduction % for proposed filter settings. 

 
Reduction % Shows reduction in number of points after proposed filtering.  

Adjust Z-Tolerance to achieve 60%-75% Reduction 

 
Accept Filters and imports the LiDAR surface using these settings. 

Repeat these steps for all required LiDAR tiles. 

- Merge Tiles and Survey 

Locate and copy the project survey to the project directory.  Import the survey as a Geopak 
.TIN file. 
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Expand the data tree for the project .tin until Features is expanded.  Click to turn on the 
Boundaries. Highlight the surface for the project.  Right click and select Create Graphics.  
(This draws the tin hull into the design file.) 
 

 
 

Use the MicroStation selection tool to select the tin hull.  Right click on the first Lidar .las tile 
and select Clip Polygon > Internal.  Repeat right clicking on the remaining Lidar .las tiles 
and select Clip Polygon > Internal for each one. 

 

 
 
Expand the data trees for each of the LAS Surfaces and turn on Features -- Triangles to 
verify that the tin hull has been clipped from each of the tiles.  (You can then turn the 
display back off). 
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Right click on Surfaces and select Create Surface > Empty Surface. 

 
 

On the newly created Surface, right click and select Append From > ###### (select your 
first .las surface in the list).  Repeat until all of the las surfaces in the list have been added.  
(Do not add the project surface in this step).   

 

 
 

Pay attention to the # of Triangles in the Details panel.  Occasionally it will bomb out and 
reset to 0 and you will have to delete the surface and start over again. 
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Right click on the new project surface, select Merge From, and select the project surface. 
 

 
 
Right click on the project surface and select Export to > Geopak Tin. Save the file. 
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Appendix A - C Value Table 

The highlighted values are the most commonly used "C" values and are stored in the 
Drainage Library: 

RUNOFF FACTORS FOR RATIONAL METHOD 
  Flat Rolling Hilly 

0% - 2% 2% - 10% Over 10% 
        

Pavements & Roofs 0.90 0.90 0.90 
Earth shoulders 0.50 0.50 0.50 
Drives & Walks 0.75 0.80 0.85 
Gravel Pavements 0.50 0.55 0.60 
City Business Areas 0.80 0.85 0.85 
Unpaved Road, Sandy Soils 0.34 0.45 0.59 
Unpaved Road, Silty Soils 0.35 0.47 0.61 
Unpaved Road, Clay Soils 0.40 0.53 0.69 
        

Apartment Dwelling Areas 0.50 0.60 0.70 
Suburban, Normal Residential 0.45 0.50 0.55 
Dense Residential Sections 0.60 0.65 0.70 
Lawns, Sandy Soils 0.10 0.15 0.20 
Lawns, Heavy Soils 0.17 0.22 0.35 
        

Grass Shoulders 0.25 0.25 0.25 
Side Slopes, Earth 0.60 0.60 0.60 
Side Slopes, Turf 0.30 0.30 0.30 
Median Areas, Turf 0.25 0.30 0.30 
Cultivated Land, Clay & Loam 0.50 0.55 0.60 
        

Cultivated Land, Sand & 
Gravel 

0.25 0.30 0.35 

Industrial Areas, Light 0.50 0.70 0.80 
Industrial Areas, Heavy 0.60 0.80 0.90 
Parks & Cemeteries 0.10 0.15 0.25 
Playgrounds 0.20 0.25 0.30 
        

Woodland & Forest 0.10 0.15 0.20 
Meadows & Pasture Land 0.25 0.30 0.35 
Unimproved Areas 0.10 0.20 0.30 
        

Rail Yards  0.25 0.30 NA 
Expressways & Freeways * 0.60* 0.70* 0.75* 
* The designer can also calculate weighted ‘C’ values for expressways and freeways using the 
values in the table for pavement, side slopes and planted medians.  
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Appendix B - Troubleshooting 
Here are some common problems that are easy to correct. Check here before panicking and 
thinking that the program has gone haywire.  

 

If your problem is not listed below, call your coordinator for help.  

 

Cannot find Cell Library Make sure that all of your drives are connected.  
You may have to copy the cell library and put it in 
your project directory.  Make sure to update the 
project components. 

Cannot find Land Use Say OK and ignore 
No active network selected Got to Network>Active Network 
Basins appear on screen but not in 
program 

Make sure that you have the correct project open 
and pertinent levels on 

Discharge is equal to 0 0 Check to be sure that the rainfall data matches the 
frequency option under Preferences 

Flow line of downstream pipe is higher 
than flow line of upstream pipe 

Make sure that you have the correct pipe sizes 
listed for all existing pipe or make sure design is 
selected new pipe 

The nodes/links that I deleted are still on 
the screen 

Go to Navigator and do a Graphic Update 

Some nodes/links that I did not want 
deleted are not on my screen anymore 
but are in the Navigator 

Go to Navigator and do a Graphic Update 

When I hit Graphic Update only one 
nodes/link changed 

Be sure to highlight everything that you want 
changed in the Navigator window 

I have input 5 nodes/links - where are 
they? 

Be sure that you are choosing Add after you enter 
all information and choosing Component > 
Node/Link > Add to create a new node/link. Also 
check to see if the level is on 

I cannot see my labels Check Preferences to see if you have labels 
checked.  Do a Graphic Update. Check the label 
offset in Preferences. 

The program keeps changing my set 
elevations/slopes 

Check to see if your envelopes are large enough to 
accommodate the elevations you chose. Or you 
may need to make one of your nodes a drop box 

I referenced my pp.dgn file, but I cannot 
see it on the screen 

Go to File>Reference and make sure that there is 
an X under the Display column 

The Macro for running reports didn’t ask 
me to enable and it will not let me run 
nodesum and linksum reports. 

In EXCEL go to Tools>Macro>Security. Make 
sure the security level is set to medium. 
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It keeps changing my held elevations and 
saying that I have exceeded the min deep 
at the basin 

You may need to change that node to allow drop 
manholes instead of match soffit elevations. Your 
held elevations are making it impossible for your 
inflow and outflow pipes to have matching soffits. 
The program changes the elevations to match the 
specifications that you have set 

Design/Analyze is grayed out Got to Network Active Network and choose the 
network you want to run 

When I try to move a piece of text in the 
profile the whole profile moves 

Go to Settings/Locks/Graphic Group 

It will not update my nodes. It says 
cannot find the cell library. 

Download the cell library to your project directory 
and select it again in Preferences. 
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